aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-2.6.33/081-mtd_myloader_partition_parser.patch
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2010-12-17 17:10:04 +0000
committerGabor Juhos <juhosg@openwrt.org>2010-12-17 17:10:04 +0000
commit60c7563a0a21141c62b3492482e42d59335f7512 (patch)
treefeec3fdf3af7a39013f1c872146e85dd6576dec5 /target/linux/generic/patches-2.6.33/081-mtd_myloader_partition_parser.patch
parentcfef0029284e31d3e61899ad9ef32a8c5b6b1f08 (diff)
downloadupstream-60c7563a0a21141c62b3492482e42d59335f7512.tar.gz
upstream-60c7563a0a21141c62b3492482e42d59335f7512.tar.bz2
upstream-60c7563a0a21141c62b3492482e42d59335f7512.zip
generic: nuke 2.6.33 specific stuff, is not used by any platform
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@24644 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/generic/patches-2.6.33/081-mtd_myloader_partition_parser.patch')
-rw-r--r--target/linux/generic/patches-2.6.33/081-mtd_myloader_partition_parser.patch35
1 files changed, 0 insertions, 35 deletions
diff --git a/target/linux/generic/patches-2.6.33/081-mtd_myloader_partition_parser.patch b/target/linux/generic/patches-2.6.33/081-mtd_myloader_partition_parser.patch
deleted file mode 100644
index 61b822ee88..0000000000
--- a/target/linux/generic/patches-2.6.33/081-mtd_myloader_partition_parser.patch
+++ /dev/null
@@ -1,35 +0,0 @@
---- a/drivers/mtd/Kconfig
-+++ b/drivers/mtd/Kconfig
-@@ -181,6 +181,22 @@ config MTD_AR7_PARTS
- ---help---
- TI AR7 partitioning support
-
-+config MTD_MYLOADER_PARTS
-+ tristate "MyLoader partition parsing"
-+ depends on MTD_PARTITIONS && (ADM5120 || ATHEROS_AR231X || ATHEROS_AR71XX)
-+ ---help---
-+ MyLoader is a bootloader which allows the user to define partitions
-+ in flash devices, by putting a table in the second erase block
-+ on the device, similar to a partition table. This table gives the
-+ offsets and lengths of the user defined partitions.
-+
-+ If you need code which can detect and parse these tables, and
-+ register MTD 'partitions' corresponding to each image detected,
-+ enable this option.
-+
-+ You will still need the parsing functions to be called by the driver
-+ for your particular device. It won't happen automatically.
-+
- comment "User Modules And Translation Layers"
-
- config MTD_CHAR
---- a/drivers/mtd/Makefile
-+++ b/drivers/mtd/Makefile
-@@ -13,6 +13,7 @@ obj-$(CONFIG_MTD_CMDLINE_PARTS) += cmdli
- obj-$(CONFIG_MTD_AFS_PARTS) += afs.o
- obj-$(CONFIG_MTD_AR7_PARTS) += ar7part.o
- obj-$(CONFIG_MTD_OF_PARTS) += ofpart.o
-+obj-$(CONFIG_MTD_MYLOADER_PARTS) += myloader.o
-
- # 'Users' - code which presents functionality to userspace.
- obj-$(CONFIG_MTD_CHAR) += mtdchar.o