aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-2.6.30
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@hauke-m.de>2012-04-13 19:37:15 +0000
committerHauke Mehrtens <hauke@hauke-m.de>2012-04-13 19:37:15 +0000
commit62f0c3793b6379d47b23543a625df8ef6d550ca5 (patch)
tree5871a8370d0291b47408db3399a8e40f45256a34 /target/linux/generic/patches-2.6.30
parent6af575967c780fa41029bdb64fdd68646ab516d1 (diff)
downloadupstream-62f0c3793b6379d47b23543a625df8ef6d550ca5.tar.gz
upstream-62f0c3793b6379d47b23543a625df8ef6d550ca5.tar.bz2
upstream-62f0c3793b6379d47b23543a625df8ef6d550ca5.zip
kernel: refresh patches
SVN-Revision: 31279
Diffstat (limited to 'target/linux/generic/patches-2.6.30')
-rw-r--r--target/linux/generic/patches-2.6.30/014-cfi_fix_amd_extended_table_check.patch2
-rw-r--r--target/linux/generic/patches-2.6.30/020-mips_multi_machine_support.patch2
-rw-r--r--target/linux/generic/patches-2.6.30/100-netfilter_layer7_2.21.patch2
-rw-r--r--target/linux/generic/patches-2.6.30/110-netfilter_match_speedup.patch8
-rw-r--r--target/linux/generic/patches-2.6.30/202-mips_mem_functions_performance.patch2
-rw-r--r--target/linux/generic/patches-2.6.30/203-slab_maxsize.patch2
-rw-r--r--target/linux/generic/patches-2.6.30/210-mini_fo_2.6.25_fixes.patch4
-rw-r--r--target/linux/generic/patches-2.6.30/212-mini_fo_2.6.26_fixes.patch2
-rw-r--r--target/linux/generic/patches-2.6.30/260-extend_pfifo_fast.patch2
-rw-r--r--target/linux/generic/patches-2.6.30/400-ledtrig_morse.patch2
-rw-r--r--target/linux/generic/patches-2.6.30/402-ledtrig_netdev.patch2
-rw-r--r--target/linux/generic/patches-2.6.30/511-yaffs-cvs-2009-04-24.patch76
-rw-r--r--target/linux/generic/patches-2.6.30/660-phy_mvswitch.patch6
-rw-r--r--target/linux/generic/patches-2.6.30/670-phy_ip175c.patch2
-rw-r--r--target/linux/generic/patches-2.6.30/680-phy_ar8216.patch2
-rw-r--r--target/linux/generic/patches-2.6.30/690-phy_rtl8306.patch2
-rw-r--r--target/linux/generic/patches-2.6.30/691-phy_rtl8366.patch2
-rw-r--r--target/linux/generic/patches-2.6.30/903-hostap_txpower.patch2
-rw-r--r--target/linux/generic/patches-2.6.30/910-hostap_tx_queue_len_fix.patch2
-rw-r--r--target/linux/generic/patches-2.6.30/965-arm_restore_sigmask_v2.patch6
-rw-r--r--target/linux/generic/patches-2.6.30/990-fix_feroceon_vfp_handling.patch2
21 files changed, 66 insertions, 66 deletions
diff --git a/target/linux/generic/patches-2.6.30/014-cfi_fix_amd_extended_table_check.patch b/target/linux/generic/patches-2.6.30/014-cfi_fix_amd_extended_table_check.patch
index 5c835081b8..22cd4aa8f2 100644
--- a/target/linux/generic/patches-2.6.30/014-cfi_fix_amd_extended_table_check.patch
+++ b/target/linux/generic/patches-2.6.30/014-cfi_fix_amd_extended_table_check.patch
@@ -8,7 +8,7 @@
static int cfi_amdstd_read (struct mtd_info *, loff_t, size_t, size_t *, u_char *);
static int cfi_amdstd_write_words(struct mtd_info *, loff_t, size_t, size_t *, const u_char *);
-@@ -386,12 +387,19 @@ struct mtd_info *cfi_cmdset_0002(struct
+@@ -386,12 +387,19 @@ struct mtd_info *cfi_cmdset_0002(struct
if (extp->MajorVersion != '1' ||
(extp->MinorVersion < '0' || extp->MinorVersion > '4')) {
diff --git a/target/linux/generic/patches-2.6.30/020-mips_multi_machine_support.patch b/target/linux/generic/patches-2.6.30/020-mips_multi_machine_support.patch
index caabacc335..6ff7504dd3 100644
--- a/target/linux/generic/patches-2.6.30/020-mips_multi_machine_support.patch
+++ b/target/linux/generic/patches-2.6.30/020-mips_multi_machine_support.patch
@@ -157,7 +157,7 @@
unsigned int vced_count, vcei_count;
-@@ -33,8 +34,12 @@ static int show_cpuinfo(struct seq_file
+@@ -33,8 +34,12 @@ static int show_cpuinfo(struct seq_file
/*
* For the first processor also print the system type
*/
diff --git a/target/linux/generic/patches-2.6.30/100-netfilter_layer7_2.21.patch b/target/linux/generic/patches-2.6.30/100-netfilter_layer7_2.21.patch
index 8100b1285c..3791642d72 100644
--- a/target/linux/generic/patches-2.6.30/100-netfilter_layer7_2.21.patch
+++ b/target/linux/generic/patches-2.6.30/100-netfilter_layer7_2.21.patch
@@ -71,7 +71,7 @@
depends on NETFILTER_ADVANCED
--- a/net/netfilter/Makefile
+++ b/net/netfilter/Makefile
-@@ -88,6 +88,7 @@ obj-$(CONFIG_NETFILTER_XT_MATCH_RECENT)
+@@ -88,6 +88,7 @@ obj-$(CONFIG_NETFILTER_XT_MATCH_RECENT)
obj-$(CONFIG_NETFILTER_XT_MATCH_SCTP) += xt_sctp.o
obj-$(CONFIG_NETFILTER_XT_MATCH_SOCKET) += xt_socket.o
obj-$(CONFIG_NETFILTER_XT_MATCH_STATE) += xt_state.o
diff --git a/target/linux/generic/patches-2.6.30/110-netfilter_match_speedup.patch b/target/linux/generic/patches-2.6.30/110-netfilter_match_speedup.patch
index 926966ced0..e75d7aaee4 100644
--- a/target/linux/generic/patches-2.6.30/110-netfilter_match_speedup.patch
+++ b/target/linux/generic/patches-2.6.30/110-netfilter_match_speedup.patch
@@ -127,10 +127,11 @@
e = (struct ipt_entry *)(loc_cpu_entry + off);
if (copy_to_user(userptr + off
-@@ -986,6 +1026,14 @@ copy_entries_to_user(unsigned int total_
+@@ -985,6 +1025,14 @@ copy_entries_to_user(unsigned int total_
+ ret = -EFAULT;
goto free_counters;
}
-
++
+ flags = e->ip.flags & ~IPT_F_NO_DEF_MATCH;
+ if (copy_to_user(userptr + off
+ + offsetof(struct ipt_entry, ip.flags),
@@ -138,7 +139,6 @@
+ ret = -EFAULT;
+ goto free_counters;
+ }
-+
+
for (i = sizeof(struct ipt_entry);
i < e->target_offset;
- i += m->u.match_size) {
diff --git a/target/linux/generic/patches-2.6.30/202-mips_mem_functions_performance.patch b/target/linux/generic/patches-2.6.30/202-mips_mem_functions_performance.patch
index 6ea9ba51ee..e4324717b4 100644
--- a/target/linux/generic/patches-2.6.30/202-mips_mem_functions_performance.patch
+++ b/target/linux/generic/patches-2.6.30/202-mips_mem_functions_performance.patch
@@ -1,6 +1,6 @@
--- a/arch/mips/include/asm/string.h
+++ b/arch/mips/include/asm/string.h
-@@ -133,11 +133,44 @@ strncmp(__const__ char *__cs, __const__
+@@ -133,11 +133,44 @@ strncmp(__const__ char *__cs, __const__
#define __HAVE_ARCH_MEMSET
extern void *memset(void *__s, int __c, size_t __count);
diff --git a/target/linux/generic/patches-2.6.30/203-slab_maxsize.patch b/target/linux/generic/patches-2.6.30/203-slab_maxsize.patch
index 25567f8488..e3aa724a1a 100644
--- a/target/linux/generic/patches-2.6.30/203-slab_maxsize.patch
+++ b/target/linux/generic/patches-2.6.30/203-slab_maxsize.patch
@@ -1,6 +1,6 @@
--- a/include/linux/slab.h
+++ b/include/linux/slab.h
-@@ -115,8 +115,8 @@ int kmem_ptr_validate(struct kmem_cache
+@@ -115,8 +115,8 @@ int kmem_ptr_validate(struct kmem_cache
* to do various tricks to work around compiler limitations in order to
* ensure proper constant folding.
*/
diff --git a/target/linux/generic/patches-2.6.30/210-mini_fo_2.6.25_fixes.patch b/target/linux/generic/patches-2.6.30/210-mini_fo_2.6.25_fixes.patch
index d71e3b6faa..b64630d500 100644
--- a/target/linux/generic/patches-2.6.30/210-mini_fo_2.6.25_fixes.patch
+++ b/target/linux/generic/patches-2.6.30/210-mini_fo_2.6.25_fixes.patch
@@ -61,7 +61,7 @@
#if LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,0)
extern int mini_fo_create(inode_t *dir, dentry_t *dentry, int mode, struct nameidata *nd);
-@@ -501,6 +505,29 @@ static inline void double_unlock(struct
+@@ -501,6 +505,29 @@ static inline void double_unlock(struct
#endif /* if LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,0) */
#endif /* __KERNEL__ */
@@ -127,7 +127,7 @@
#endif /* defined(FIST_DEBUG) || defined(FIST_FILTER_SCA) */
--- a/fs/mini_fo/aux.c
+++ b/fs/mini_fo/aux.c
-@@ -164,11 +164,11 @@ dentry_t *bpath_walk(super_block_t *sb,
+@@ -164,11 +164,11 @@ dentry_t *bpath_walk(super_block_t *sb,
err = vfs_path_lookup(mnt->mnt_root, mnt, bpath+1, 0, &nd);
/* validate */
diff --git a/target/linux/generic/patches-2.6.30/212-mini_fo_2.6.26_fixes.patch b/target/linux/generic/patches-2.6.30/212-mini_fo_2.6.26_fixes.patch
index 8bd9ba3244..b5fa64e6a1 100644
--- a/target/linux/generic/patches-2.6.30/212-mini_fo_2.6.26_fixes.patch
+++ b/target/linux/generic/patches-2.6.30/212-mini_fo_2.6.26_fixes.patch
@@ -1,6 +1,6 @@
--- a/fs/mini_fo/super.c
+++ b/fs/mini_fo/super.c
-@@ -84,6 +84,7 @@ mini_fo_write_inode(inode_t *inode, int
+@@ -84,6 +84,7 @@ mini_fo_write_inode(inode_t *inode, int
#endif /* defined(FIST_DEBUG) || defined(FIST_FILTER_SCA) */
diff --git a/target/linux/generic/patches-2.6.30/260-extend_pfifo_fast.patch b/target/linux/generic/patches-2.6.30/260-extend_pfifo_fast.patch
index ad9e9badd3..2ad7adfb8e 100644
--- a/target/linux/generic/patches-2.6.30/260-extend_pfifo_fast.patch
+++ b/target/linux/generic/patches-2.6.30/260-extend_pfifo_fast.patch
@@ -85,7 +85,7 @@
for (prio = 0; prio < PFIFO_FAST_BANDS; prio++)
skb_queue_head_init(list + prio);
-@@ -453,9 +490,36 @@ static int pfifo_fast_init(struct Qdisc
+@@ -453,9 +490,36 @@ static int pfifo_fast_init(struct Qdisc
return 0;
}
diff --git a/target/linux/generic/patches-2.6.30/400-ledtrig_morse.patch b/target/linux/generic/patches-2.6.30/400-ledtrig_morse.patch
index 2754ed6d7e..155144ee1c 100644
--- a/target/linux/generic/patches-2.6.30/400-ledtrig_morse.patch
+++ b/target/linux/generic/patches-2.6.30/400-ledtrig_morse.patch
@@ -11,7 +11,7 @@
endif # NEW_LEDS
--- a/drivers/leds/Makefile
+++ b/drivers/leds/Makefile
-@@ -38,3 +38,4 @@ obj-$(CONFIG_LEDS_TRIGGER_HEARTBEAT) +=
+@@ -38,3 +38,4 @@ obj-$(CONFIG_LEDS_TRIGGER_HEARTBEAT) +=
obj-$(CONFIG_LEDS_TRIGGER_BACKLIGHT) += ledtrig-backlight.o
obj-$(CONFIG_LEDS_TRIGGER_GPIO) += ledtrig-gpio.o
obj-$(CONFIG_LEDS_TRIGGER_DEFAULT_ON) += ledtrig-default-on.o
diff --git a/target/linux/generic/patches-2.6.30/402-ledtrig_netdev.patch b/target/linux/generic/patches-2.6.30/402-ledtrig_netdev.patch
index 90664d135f..8d1cdc657f 100644
--- a/target/linux/generic/patches-2.6.30/402-ledtrig_netdev.patch
+++ b/target/linux/generic/patches-2.6.30/402-ledtrig_netdev.patch
@@ -14,7 +14,7 @@
endif # NEW_LEDS
--- a/drivers/leds/Makefile
+++ b/drivers/leds/Makefile
-@@ -39,3 +39,4 @@ obj-$(CONFIG_LEDS_TRIGGER_BACKLIGHT) +=
+@@ -39,3 +39,4 @@ obj-$(CONFIG_LEDS_TRIGGER_BACKLIGHT) +=
obj-$(CONFIG_LEDS_TRIGGER_GPIO) += ledtrig-gpio.o
obj-$(CONFIG_LEDS_TRIGGER_DEFAULT_ON) += ledtrig-default-on.o
obj-$(CONFIG_LEDS_TRIGGER_MORSE) += ledtrig-morse.o
diff --git a/target/linux/generic/patches-2.6.30/511-yaffs-cvs-2009-04-24.patch b/target/linux/generic/patches-2.6.30/511-yaffs-cvs-2009-04-24.patch
index 5c70e79a05..c334b17d08 100644
--- a/target/linux/generic/patches-2.6.30/511-yaffs-cvs-2009-04-24.patch
+++ b/target/linux/generic/patches-2.6.30/511-yaffs-cvs-2009-04-24.patch
@@ -601,7 +601,7 @@
dev->checkpointBlockList[i] = -1;
}
-@@ -191,18 +185,17 @@ int yaffs_GetCheckpointSum(yaffs_Device
+@@ -191,18 +185,17 @@ int yaffs_GetCheckpointSum(yaffs_Device
static int yaffs_CheckpointFlushBuffer(yaffs_Device *dev)
{
@@ -926,7 +926,7 @@
{
unsigned char cDelta; /* column parity delta */
unsigned lDelta; /* line parity delta */
-@@ -294,8 +292,7 @@ int yaffs_ECCCorrectOther(unsigned char
+@@ -294,8 +292,7 @@ int yaffs_ECCCorrectOther(unsigned char
return 0; /* no error */
if (lDelta == ~lDeltaPrime &&
@@ -936,7 +936,7 @@
/* Single bit (recoverable) error in data */
bit = 0;
-@@ -307,7 +304,7 @@ int yaffs_ECCCorrectOther(unsigned char
+@@ -307,7 +304,7 @@ int yaffs_ECCCorrectOther(unsigned char
if (cDelta & 0x02)
bit |= 0x01;
@@ -945,7 +945,7 @@
return -1;
data[lDelta] ^= (1 << bit);
-@@ -316,7 +313,7 @@ int yaffs_ECCCorrectOther(unsigned char
+@@ -316,7 +313,7 @@ int yaffs_ECCCorrectOther(unsigned char
}
if ((yaffs_CountBits32(lDelta) + yaffs_CountBits32(lDeltaPrime) +
@@ -954,7 +954,7 @@
/* Reccoverable error in ecc */
*read_ecc = *test_ecc;
-@@ -326,6 +323,4 @@ int yaffs_ECCCorrectOther(unsigned char
+@@ -326,6 +323,4 @@ int yaffs_ECCCorrectOther(unsigned char
/* Unrecoverable error */
return -1;
@@ -1398,7 +1398,7 @@
{
unsigned char *alias;
int ret;
-@@ -329,7 +395,7 @@ static int yaffs_readlink(struct dentry
+@@ -329,7 +395,7 @@ static int yaffs_readlink(struct dentry
return ret;
}
@@ -1560,7 +1560,7 @@
static int yaffs_file_flush(struct file *file, fl_owner_t id)
#else
static int yaffs_file_flush(struct file *file)
-@@ -513,8 +579,8 @@ static int yaffs_file_flush(struct file
+@@ -513,8 +579,8 @@ static int yaffs_file_flush(struct file
yaffs_Device *dev = obj->myDev;
T(YAFFS_TRACE_OS,
@@ -1571,7 +1571,7 @@
yaffs_GrossLock(dev);
-@@ -535,15 +601,15 @@ static int yaffs_readpage_nolock(struct
+@@ -535,15 +601,15 @@ static int yaffs_readpage_nolock(struct
yaffs_Device *dev;
@@ -1591,7 +1591,7 @@
BUG_ON(!PageLocked(pg));
#else
if (!PageLocked(pg))
-@@ -555,9 +621,9 @@ static int yaffs_readpage_nolock(struct
+@@ -555,9 +621,9 @@ static int yaffs_readpage_nolock(struct
yaffs_GrossLock(dev);
@@ -1604,7 +1604,7 @@
yaffs_GrossUnlock(dev);
-@@ -575,7 +641,7 @@ static int yaffs_readpage_nolock(struct
+@@ -575,7 +641,7 @@ static int yaffs_readpage_nolock(struct
flush_dcache_page(pg);
kunmap(pg);
@@ -3193,7 +3193,7 @@
if (n < step) {
n++;
continue;
-@@ -2119,7 +2356,7 @@ static int yaffs_proc_write(struct file
+@@ -2119,7 +2356,7 @@ static int yaffs_proc_write(struct file
char *end;
char *mask_name;
const char *x;
@@ -3202,7 +3202,7 @@
int i;
int done = 0;
int add, len = 0;
-@@ -2129,9 +2366,8 @@ static int yaffs_proc_write(struct file
+@@ -2129,9 +2366,8 @@ static int yaffs_proc_write(struct file
while (!done && (pos < count)) {
done = 1;
@@ -3213,7 +3213,7 @@
switch (buf[pos]) {
case '+':
-@@ -2148,20 +2384,21 @@ static int yaffs_proc_write(struct file
+@@ -2148,20 +2384,21 @@ static int yaffs_proc_write(struct file
mask_name = NULL;
mask_bitfield = simple_strtoul(buf + pos, &end, 0);
@@ -3240,7 +3240,7 @@
mask_name = mask_flags[i].mask_name;
mask_bitfield = mask_flags[i].mask_bitfield;
done = 0;
-@@ -2172,7 +2409,7 @@ static int yaffs_proc_write(struct file
+@@ -2172,7 +2409,7 @@ static int yaffs_proc_write(struct file
if (mask_name != NULL) {
done = 0;
@@ -3249,7 +3249,7 @@
case '-':
rg &= ~mask_bitfield;
break;
-@@ -2191,13 +2428,13 @@ static int yaffs_proc_write(struct file
+@@ -2191,13 +2428,13 @@ static int yaffs_proc_write(struct file
yaffs_traceMask = rg | YAFFS_TRACE_ALWAYS;
@@ -5691,7 +5691,7 @@
{
/* Get the real object in case we were fed a hard link as an equivalent object */
equivalentObject = yaffs_GetEquivalentObject(equivalentObject);
-@@ -2363,33 +2396,31 @@ yaffs_Object *yaffs_Link(yaffs_Object *
+@@ -2363,33 +2396,31 @@ yaffs_Object *yaffs_Link(yaffs_Object *
}
@@ -7622,7 +7622,7 @@
int nToCopy;
int n = nBytes;
int nDone = 0;
-@@ -4600,27 +4665,26 @@ int yaffs_ReadDataFromFile(yaffs_Object
+@@ -4600,27 +4665,26 @@ int yaffs_ReadDataFromFile(yaffs_Object
dev = in->myDev;
while (n > 0) {
@@ -7657,7 +7657,7 @@
if (dev->nShortOpCaches > 0) {
/* If we can't find the data in the cache, then load it up. */
-@@ -4641,14 +4705,9 @@ int yaffs_ReadDataFromFile(yaffs_Object
+@@ -4641,14 +4705,9 @@ int yaffs_ReadDataFromFile(yaffs_Object
cache->locked = 1;
@@ -7673,7 +7673,7 @@
cache->locked = 0;
} else {
/* Read into the local buffer then copy..*/
-@@ -4657,41 +4716,19 @@ int yaffs_ReadDataFromFile(yaffs_Object
+@@ -4657,41 +4716,19 @@ int yaffs_ReadDataFromFile(yaffs_Object
yaffs_GetTempBuffer(dev, __LINE__);
yaffs_ReadChunkDataFromObject(in, chunk,
localBuffer);
@@ -7718,7 +7718,7 @@
}
n -= nToCopy;
-@@ -4704,28 +4741,37 @@ int yaffs_ReadDataFromFile(yaffs_Object
+@@ -4704,28 +4741,37 @@ int yaffs_ReadDataFromFile(yaffs_Object
return nDone;
}
@@ -7923,7 +7923,7 @@
int newFullChunks;
yaffs_Device *dev = in->myDev;
-@@ -4955,13 +4981,11 @@ int yaffs_ResizeFile(yaffs_Object * in,
+@@ -4955,13 +4981,11 @@ int yaffs_ResizeFile(yaffs_Object * in,
yaffs_CheckGarbageCollection(dev);
@@ -7941,7 +7941,7 @@
if (newSize < oldFileSize) {
-@@ -4994,21 +5018,20 @@ int yaffs_ResizeFile(yaffs_Object * in,
+@@ -4994,21 +5018,20 @@ int yaffs_ResizeFile(yaffs_Object * in,
}
@@ -7968,7 +7968,7 @@
{
obj = yaffs_GetEquivalentObject(obj);
-@@ -5024,7 +5047,7 @@ loff_t yaffs_GetFileSize(yaffs_Object *
+@@ -5024,7 +5047,7 @@ loff_t yaffs_GetFileSize(yaffs_Object *
@@ -9789,7 +9789,7 @@
{
int init_failed = 0;
unsigned x;
-@@ -7040,6 +7126,8 @@ int yaffs_GutsInitialise(yaffs_Device *
+@@ -7040,6 +7126,8 @@ int yaffs_GutsInitialise(yaffs_Device *
dev->chunkOffset = 0;
dev->nFreeChunks = 0;
@@ -9798,7 +9798,7 @@
if (dev->startBlock == 0) {
dev->internalStartBlock = dev->startBlock + 1;
dev->internalEndBlock = dev->endBlock + 1;
-@@ -7049,18 +7137,18 @@ int yaffs_GutsInitialise(yaffs_Device *
+@@ -7049,18 +7137,18 @@ int yaffs_GutsInitialise(yaffs_Device *
/* Check geometry parameters. */
@@ -9823,7 +9823,7 @@
return YAFFS_FAIL;
}
-@@ -7070,6 +7158,12 @@ int yaffs_GutsInitialise(yaffs_Device *
+@@ -7070,6 +7158,12 @@ int yaffs_GutsInitialise(yaffs_Device *
return YAFFS_FAIL;
}
@@ -9836,7 +9836,7 @@
/* Got the right mix of functions? */
if (!yaffs_CheckDevFunctions(dev)) {
/* Function missing */
-@@ -7097,31 +7191,18 @@ int yaffs_GutsInitialise(yaffs_Device *
+@@ -7097,31 +7191,18 @@ int yaffs_GutsInitialise(yaffs_Device *
dev->isMounted = 1;
@@ -9875,7 +9875,7 @@
/*
* Calculate chunkGroupBits.
-@@ -7133,16 +7214,15 @@ int yaffs_GutsInitialise(yaffs_Device *
+@@ -7133,16 +7214,15 @@ int yaffs_GutsInitialise(yaffs_Device *
bits = ShiftsGE(x);
/* Set up tnode width if wide tnodes are enabled. */
@@ -9896,7 +9896,7 @@
dev->tnodeWidth = 16;
dev->tnodeMask = (1<<dev->tnodeWidth)-1;
-@@ -7193,7 +7273,7 @@ int yaffs_GutsInitialise(yaffs_Device *
+@@ -7193,7 +7273,7 @@ int yaffs_GutsInitialise(yaffs_Device *
dev->hasPendingPrioritisedGCs = 1; /* Assume the worst for now, will get fixed on first GC */
/* Initialise temporary buffers and caches. */
@@ -9905,7 +9905,7 @@
init_failed = 1;
dev->srCache = NULL;
-@@ -7203,25 +7283,26 @@ int yaffs_GutsInitialise(yaffs_Device *
+@@ -7203,25 +7283,26 @@ int yaffs_GutsInitialise(yaffs_Device *
if (!init_failed &&
dev->nShortOpCaches > 0) {
int i;
@@ -9940,7 +9940,7 @@
init_failed = 1;
dev->srLastUse = 0;
-@@ -7229,29 +7310,30 @@ int yaffs_GutsInitialise(yaffs_Device *
+@@ -7229,29 +7310,30 @@ int yaffs_GutsInitialise(yaffs_Device *
dev->cacheHits = 0;
@@ -9979,7 +9979,7 @@
T(YAFFS_TRACE_ALWAYS,
(TSTR("yaffs: restored from checkpoint" TENDSTR)));
} else {
-@@ -7273,24 +7355,25 @@ int yaffs_GutsInitialise(yaffs_Device *
+@@ -7273,24 +7355,25 @@ int yaffs_GutsInitialise(yaffs_Device *
dev->nBackgroundDeletions = 0;
dev->oldestDirtySequence = 0;
@@ -10011,7 +10011,7 @@
/* Clean up the mess */
T(YAFFS_TRACE_TRACING,
(TSTR("yaffs: yaffs_GutsInitialise() aborted.\n" TENDSTR)));
-@@ -7318,7 +7401,7 @@ int yaffs_GutsInitialise(yaffs_Device *
+@@ -7318,7 +7401,7 @@ int yaffs_GutsInitialise(yaffs_Device *
}
@@ -10710,7 +10710,7 @@
{
if (etags) {
memset(etags, 0, sizeof(*etags));
-@@ -169,9 +169,9 @@ static int rettags(yaffs_ExtendedTags *
+@@ -169,9 +169,9 @@ static int rettags(yaffs_ExtendedTags *
* Returns YAFFS_OK or YAFFS_FAIL.
*/
int nandmtd1_ReadChunkWithTagsFromNAND(yaffs_Device *dev,
@@ -11038,14 +11038,14 @@
+ yaffs_UnpackTags2(tags, &pt);
+ }
+ }
-
-- if(tags && retval == -EBADMSG && tags->eccResult == YAFFS_ECC_RESULT_NO_ERROR)
-- tags->eccResult = YAFFS_ECC_RESULT_UNFIXED;
++
+ if (localData)
+ yaffs_ReleaseTempBuffer(dev, data, __LINE__);
+- if(tags && retval == -EBADMSG && tags->eccResult == YAFFS_ECC_RESULT_NO_ERROR)
+ if (tags && retval == -EBADMSG && tags->eccResult == YAFFS_ECC_RESULT_NO_ERROR)
-+ tags->eccResult = YAFFS_ECC_RESULT_UNFIXED;
+ tags->eccResult = YAFFS_ECC_RESULT_UNFIXED;
+-
if (retval == 0)
return YAFFS_OK;
else
diff --git a/target/linux/generic/patches-2.6.30/660-phy_mvswitch.patch b/target/linux/generic/patches-2.6.30/660-phy_mvswitch.patch
index 731f30301f..237ad16bf5 100644
--- a/target/linux/generic/patches-2.6.30/660-phy_mvswitch.patch
+++ b/target/linux/generic/patches-2.6.30/660-phy_mvswitch.patch
@@ -1,8 +1,8 @@
--- a/drivers/net/phy/Kconfig
+++ b/drivers/net/phy/Kconfig
-@@ -93,6 +93,9 @@ config ADM6996_PHY
- ---help---
- Currently supports the ADM6996F switch
+@@ -95,6 +95,9 @@ config ADM6996_PHY
+ Currently supports the ADM6996FC and ADM6996M switches.
+ Support for FC is very limited.
+config MVSWITCH_PHY
+ tristate "Driver for Marvell 88E6060 switches"
diff --git a/target/linux/generic/patches-2.6.30/670-phy_ip175c.patch b/target/linux/generic/patches-2.6.30/670-phy_ip175c.patch
index 5d8ba3c622..7224d5f558 100644
--- a/target/linux/generic/patches-2.6.30/670-phy_ip175c.patch
+++ b/target/linux/generic/patches-2.6.30/670-phy_ip175c.patch
@@ -1,6 +1,6 @@
--- a/drivers/net/phy/Kconfig
+++ b/drivers/net/phy/Kconfig
-@@ -96,6 +96,10 @@ config ADM6996_PHY
+@@ -98,6 +98,10 @@ config ADM6996_PHY
config MVSWITCH_PHY
tristate "Driver for Marvell 88E6060 switches"
diff --git a/target/linux/generic/patches-2.6.30/680-phy_ar8216.patch b/target/linux/generic/patches-2.6.30/680-phy_ar8216.patch
index caa69d6e0e..c2ddda557c 100644
--- a/target/linux/generic/patches-2.6.30/680-phy_ar8216.patch
+++ b/target/linux/generic/patches-2.6.30/680-phy_ar8216.patch
@@ -1,6 +1,6 @@
--- a/drivers/net/phy/Kconfig
+++ b/drivers/net/phy/Kconfig
-@@ -100,6 +100,10 @@ config IP17XX_PHY
+@@ -102,6 +102,10 @@ config IP17XX_PHY
tristate "Driver for IC+ IP17xx switches"
select SWCONFIG
diff --git a/target/linux/generic/patches-2.6.30/690-phy_rtl8306.patch b/target/linux/generic/patches-2.6.30/690-phy_rtl8306.patch
index 259f7ec6e6..08f1d81a28 100644
--- a/target/linux/generic/patches-2.6.30/690-phy_rtl8306.patch
+++ b/target/linux/generic/patches-2.6.30/690-phy_rtl8306.patch
@@ -1,6 +1,6 @@
--- a/drivers/net/phy/Kconfig
+++ b/drivers/net/phy/Kconfig
-@@ -104,6 +104,10 @@ config AR8216_PHY
+@@ -106,6 +106,10 @@ config AR8216_PHY
tristate "Driver for Atheros AR8216 switches"
select SWCONFIG
diff --git a/target/linux/generic/patches-2.6.30/691-phy_rtl8366.patch b/target/linux/generic/patches-2.6.30/691-phy_rtl8366.patch
index 62a6430b86..7594e97294 100644
--- a/target/linux/generic/patches-2.6.30/691-phy_rtl8366.patch
+++ b/target/linux/generic/patches-2.6.30/691-phy_rtl8366.patch
@@ -1,6 +1,6 @@
--- a/drivers/net/phy/Kconfig
+++ b/drivers/net/phy/Kconfig
-@@ -135,4 +135,29 @@ config MDIO_GPIO
+@@ -137,4 +137,29 @@ config MDIO_GPIO
To compile this driver as a module, choose M here: the module
will be called mdio-gpio.
diff --git a/target/linux/generic/patches-2.6.30/903-hostap_txpower.patch b/target/linux/generic/patches-2.6.30/903-hostap_txpower.patch
index 197d0a1e32..e220b0b36e 100644
--- a/target/linux/generic/patches-2.6.30/903-hostap_txpower.patch
+++ b/target/linux/generic/patches-2.6.30/903-hostap_txpower.patch
@@ -1,6 +1,6 @@
--- a/drivers/net/wireless/hostap/hostap_ap.c
+++ b/drivers/net/wireless/hostap/hostap_ap.c
-@@ -2335,13 +2335,13 @@ int prism2_ap_get_sta_qual(local_info_t
+@@ -2335,13 +2335,13 @@ int prism2_ap_get_sta_qual(local_info_t
addr[count].sa_family = ARPHRD_ETHER;
memcpy(addr[count].sa_data, sta->addr, ETH_ALEN);
if (sta->last_rx_silence == 0)
diff --git a/target/linux/generic/patches-2.6.30/910-hostap_tx_queue_len_fix.patch b/target/linux/generic/patches-2.6.30/910-hostap_tx_queue_len_fix.patch
index b421662d9c..cb7b04012a 100644
--- a/target/linux/generic/patches-2.6.30/910-hostap_tx_queue_len_fix.patch
+++ b/target/linux/generic/patches-2.6.30/910-hostap_tx_queue_len_fix.patch
@@ -1,6 +1,6 @@
--- a/drivers/net/wireless/hostap/hostap_main.c
+++ b/drivers/net/wireless/hostap/hostap_main.c
-@@ -875,15 +875,16 @@ void hostap_setup_dev(struct net_device
+@@ -875,15 +875,16 @@ void hostap_setup_dev(struct net_device
switch(type) {
case HOSTAP_INTERFACE_AP:
diff --git a/target/linux/generic/patches-2.6.30/965-arm_restore_sigmask_v2.patch b/target/linux/generic/patches-2.6.30/965-arm_restore_sigmask_v2.patch
index 30acd0316b..c8f0bf5c8e 100644
--- a/target/linux/generic/patches-2.6.30/965-arm_restore_sigmask_v2.patch
+++ b/target/linux/generic/patches-2.6.30/965-arm_restore_sigmask_v2.patch
@@ -261,7 +261,7 @@ Signed-off-by: Russell King <rmk+kernel@arm.linux.org.uk>
handle_signal(unsigned long sig, struct k_sigaction *ka,
siginfo_t *info, sigset_t *oldset,
struct pt_regs * regs, int syscall)
-@@ -592,7 +557,7 @@ handle_signal(unsigned long sig, struct
+@@ -592,7 +557,7 @@ handle_signal(unsigned long sig, struct
if (ret != 0) {
force_sigsegv(sig, tsk);
@@ -270,7 +270,7 @@ Signed-off-by: Russell King <rmk+kernel@arm.linux.org.uk>
}
/*
-@@ -606,6 +571,7 @@ handle_signal(unsigned long sig, struct
+@@ -606,6 +571,7 @@ handle_signal(unsigned long sig, struct
recalc_sigpending();
spin_unlock_irq(&tsk->sighand->siglock);
@@ -278,7 +278,7 @@ Signed-off-by: Russell King <rmk+kernel@arm.linux.org.uk>
}
/*
-@@ -617,11 +583,12 @@ handle_signal(unsigned long sig, struct
+@@ -617,11 +583,12 @@ handle_signal(unsigned long sig, struct
* the kernel can handle, and then we build all the user-level signal handling
* stack-frames in one go after that.
*/
diff --git a/target/linux/generic/patches-2.6.30/990-fix_feroceon_vfp_handling.patch b/target/linux/generic/patches-2.6.30/990-fix_feroceon_vfp_handling.patch
index 0ee18f02b1..8d986d484a 100644
--- a/target/linux/generic/patches-2.6.30/990-fix_feroceon_vfp_handling.patch
+++ b/target/linux/generic/patches-2.6.30/990-fix_feroceon_vfp_handling.patch
@@ -53,7 +53,7 @@ Cc: Nicolas Pitre <nico@cam.org>
check_for_exception:
--- a/arch/arm/vfp/vfpmodule.c
+++ b/arch/arm/vfp/vfpmodule.c
-@@ -253,12 +253,14 @@ void VFP_bounce(u32 trigger, u32 fpexc,
+@@ -253,12 +253,14 @@ void VFP_bounce(u32 trigger, u32 fpexc,
}
if (fpexc & FPEXC_EX) {