aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic/hack-5.4
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@hauke-m.de>2021-07-18 23:51:48 +0200
committerHauke Mehrtens <hauke@hauke-m.de>2021-07-19 22:47:17 +0200
commita1d50e7b45080f60a0066e9ca88ad756480dd1f8 (patch)
tree22dcfbbc4fc62d12483e9ffb961385d2da9993f3 /target/linux/generic/hack-5.4
parent88c8d0a2193bd3dd2cf00bc875def6155f2e34db (diff)
downloadupstream-a1d50e7b45080f60a0066e9ca88ad756480dd1f8.tar.gz
upstream-a1d50e7b45080f60a0066e9ca88ad756480dd1f8.tar.bz2
upstream-a1d50e7b45080f60a0066e9ca88ad756480dd1f8.zip
kernel: bump 5.4 to 5.4.132
Manually rebased layerscape/patches-5.4/805-display-0002-drm-rockchip-prepare-common-code-for-cdns-and-rk-dpi.patch All others updated automatically. Compile-tested on: ramips/mt7621 Runtime-tested on: ramips/mt7621 Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
Diffstat (limited to 'target/linux/generic/hack-5.4')
-rw-r--r--target/linux/generic/hack-5.4/204-module_strip.patch6
-rw-r--r--target/linux/generic/hack-5.4/221-module_exports.patch2
-rw-r--r--target/linux/generic/hack-5.4/661-use_fq_codel_by_default.patch2
3 files changed, 5 insertions, 5 deletions
diff --git a/target/linux/generic/hack-5.4/204-module_strip.patch b/target/linux/generic/hack-5.4/204-module_strip.patch
index 22bb1ac33a..c6420739c0 100644
--- a/target/linux/generic/hack-5.4/204-module_strip.patch
+++ b/target/linux/generic/hack-5.4/204-module_strip.patch
@@ -96,7 +96,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
--- a/init/Kconfig
+++ b/init/Kconfig
-@@ -2195,6 +2195,13 @@ config TRIM_UNUSED_KSYMS
+@@ -2198,6 +2198,13 @@ config TRIM_UNUSED_KSYMS
If unsure, or if you need to build out-of-tree modules, say N.
@@ -112,7 +112,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
config MODULES_TREE_LOOKUP
--- a/kernel/module.c
+++ b/kernel/module.c
-@@ -3252,9 +3252,11 @@ static int setup_load_info(struct load_i
+@@ -3256,9 +3256,11 @@ static int setup_load_info(struct load_i
static int check_modinfo(struct module *mod, struct load_info *info, int flags)
{
@@ -125,7 +125,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
if (flags & MODULE_INIT_IGNORE_VERMAGIC)
modmagic = NULL;
-@@ -3275,6 +3277,7 @@ static int check_modinfo(struct module *
+@@ -3279,6 +3281,7 @@ static int check_modinfo(struct module *
mod->name);
add_taint_module(mod, TAINT_OOT_MODULE, LOCKDEP_STILL_OK);
}
diff --git a/target/linux/generic/hack-5.4/221-module_exports.patch b/target/linux/generic/hack-5.4/221-module_exports.patch
index ef6e980892..0f7840b8d8 100644
--- a/target/linux/generic/hack-5.4/221-module_exports.patch
+++ b/target/linux/generic/hack-5.4/221-module_exports.patch
@@ -98,7 +98,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
--- a/scripts/Makefile.build
+++ b/scripts/Makefile.build
-@@ -349,7 +349,7 @@ targets += $(extra-y) $(MAKECMDGOALS) $(
+@@ -350,7 +350,7 @@ targets += $(extra-y) $(MAKECMDGOALS) $(
# Linker scripts preprocessor (.lds.S -> .lds)
# ---------------------------------------------------------------------------
quiet_cmd_cpp_lds_S = LDS $@
diff --git a/target/linux/generic/hack-5.4/661-use_fq_codel_by_default.patch b/target/linux/generic/hack-5.4/661-use_fq_codel_by_default.patch
index 6d0a54c01d..cdeac45f86 100644
--- a/target/linux/generic/hack-5.4/661-use_fq_codel_by_default.patch
+++ b/target/linux/generic/hack-5.4/661-use_fq_codel_by_default.patch
@@ -14,7 +14,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
--- a/include/net/sch_generic.h
+++ b/include/net/sch_generic.h
-@@ -603,12 +603,13 @@ extern struct Qdisc_ops noop_qdisc_ops;
+@@ -615,12 +615,13 @@ extern struct Qdisc_ops noop_qdisc_ops;
extern struct Qdisc_ops pfifo_fast_ops;
extern struct Qdisc_ops mq_qdisc_ops;
extern struct Qdisc_ops noqueue_qdisc_ops;