aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic/hack-5.4
diff options
context:
space:
mode:
authorRui Salvaterra <rsalvaterra@gmail.com>2021-04-08 23:57:48 +0100
committerKevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk>2021-04-22 09:11:14 +0100
commit6f053e5b4f65080a476541bb45c4781f38f9411f (patch)
tree9a6bd8aa9a1f9f644a4dad52804cd72b9d3a9ef9 /target/linux/generic/hack-5.4
parent15cd9a5d5ced0da521895e0758da56b7d85d92ab (diff)
downloadupstream-6f053e5b4f65080a476541bb45c4781f38f9411f.tar.gz
upstream-6f053e5b4f65080a476541bb45c4781f38f9411f.tar.bz2
upstream-6f053e5b4f65080a476541bb45c4781f38f9411f.zip
kernel: drop the conntrack rtcache patch
It's in backports-5.4, but it wasn't ever merged. Upstream followed another approach, with flow offloading, which has much better performance. Drop this obsolete patch and refresh the kernel patches. Signed-off-by: Rui Salvaterra <rsalvaterra@gmail.com> Acked-by: Stijn Tintel <stijn@linux-ipv6.be> Acked-by: Felix Fietkau <nbd@nbd.name> (cherry picked from commit 17576b1b2aeacf0a23bb9a911d675bd324754745)
Diffstat (limited to 'target/linux/generic/hack-5.4')
-rw-r--r--target/linux/generic/hack-5.4/250-netfilter_depends.patch4
-rw-r--r--target/linux/generic/hack-5.4/650-netfilter-add-xt_OFFLOAD-target.patch8
2 files changed, 6 insertions, 6 deletions
diff --git a/target/linux/generic/hack-5.4/250-netfilter_depends.patch b/target/linux/generic/hack-5.4/250-netfilter_depends.patch
index 512e58efcf..d03cb53180 100644
--- a/target/linux/generic/hack-5.4/250-netfilter_depends.patch
+++ b/target/linux/generic/hack-5.4/250-netfilter_depends.patch
@@ -9,7 +9,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
--- a/net/netfilter/Kconfig
+++ b/net/netfilter/Kconfig
-@@ -240,7 +240,6 @@ config NF_CONNTRACK_FTP
+@@ -228,7 +228,6 @@ config NF_CONNTRACK_FTP
config NF_CONNTRACK_H323
tristate "H.323 protocol support"
@@ -17,7 +17,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
depends on NETFILTER_ADVANCED
help
H.323 is a VoIP signalling protocol from ITU-T. As one of the most
-@@ -1100,7 +1099,6 @@ config NETFILTER_XT_TARGET_SECMARK
+@@ -1088,7 +1087,6 @@ config NETFILTER_XT_TARGET_SECMARK
config NETFILTER_XT_TARGET_TCPMSS
tristate '"TCPMSS" target support'
diff --git a/target/linux/generic/hack-5.4/650-netfilter-add-xt_OFFLOAD-target.patch b/target/linux/generic/hack-5.4/650-netfilter-add-xt_OFFLOAD-target.patch
index 737392b1f3..d584cb5c6c 100644
--- a/target/linux/generic/hack-5.4/650-netfilter-add-xt_OFFLOAD-target.patch
+++ b/target/linux/generic/hack-5.4/650-netfilter-add-xt_OFFLOAD-target.patch
@@ -47,7 +47,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
depends on !NF_CONNTRACK || NF_CONNTRACK
--- a/net/netfilter/Kconfig
+++ b/net/netfilter/Kconfig
-@@ -702,8 +702,6 @@ config NFT_FIB_NETDEV
+@@ -690,8 +690,6 @@ config NFT_FIB_NETDEV
endif # NF_TABLES_NETDEV
@@ -56,7 +56,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
config NF_FLOW_TABLE_INET
tristate "Netfilter flow table mixed IPv4/IPv6 module"
depends on NF_FLOW_TABLE
-@@ -712,11 +710,12 @@ config NF_FLOW_TABLE_INET
+@@ -700,11 +698,12 @@ config NF_FLOW_TABLE_INET
To compile it as a module, choose M here.
@@ -70,7 +70,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
help
This option adds the flow table core infrastructure.
-@@ -1005,6 +1004,15 @@ config NETFILTER_XT_TARGET_NOTRACK
+@@ -993,6 +992,15 @@ config NETFILTER_XT_TARGET_NOTRACK
depends on NETFILTER_ADVANCED
select NETFILTER_XT_TARGET_CT
@@ -88,7 +88,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
depends on NETFILTER_ADVANCED
--- a/net/netfilter/Makefile
+++ b/net/netfilter/Makefile
-@@ -144,6 +144,7 @@ obj-$(CONFIG_NETFILTER_XT_TARGET_CLASSIF
+@@ -141,6 +141,7 @@ obj-$(CONFIG_NETFILTER_XT_TARGET_CLASSIF
obj-$(CONFIG_NETFILTER_XT_TARGET_CONNSECMARK) += xt_CONNSECMARK.o
obj-$(CONFIG_NETFILTER_XT_TARGET_CT) += xt_CT.o
obj-$(CONFIG_NETFILTER_XT_TARGET_DSCP) += xt_DSCP.o