aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic/hack-5.15/700-swconfig_switch_drivers.patch
diff options
context:
space:
mode:
authorChristian 'Ansuel' Marangi <ansuelsmth@gmail.com>2022-01-22 02:03:18 +0100
committerChristian 'Ansuel' Marangi <ansuelsmth@gmail.com>2022-06-05 16:58:48 +0200
commit156488d1d6bf4480e6c15594ba5ee8689c189b20 (patch)
tree9d17bfc6fcffdc54e93f87f698614854610b1d54 /target/linux/generic/hack-5.15/700-swconfig_switch_drivers.patch
parent1d910fa85224f25218d2a411db1937fb57930fe0 (diff)
downloadupstream-156488d1d6bf4480e6c15594ba5ee8689c189b20.tar.gz
upstream-156488d1d6bf4480e6c15594ba5ee8689c189b20.tar.bz2
upstream-156488d1d6bf4480e6c15594ba5ee8689c189b20.zip
kernel: modules: make ar8216/8327 modularizable
Make ar8216/8327 swconfig driver modularizable and add entry to the netdevices.mk kernel modules file. Signed-off-by: Christian 'Ansuel' Marangi <ansuelsmth@gmail.com>
Diffstat (limited to 'target/linux/generic/hack-5.15/700-swconfig_switch_drivers.patch')
-rw-r--r--target/linux/generic/hack-5.15/700-swconfig_switch_drivers.patch8
1 files changed, 5 insertions, 3 deletions
diff --git a/target/linux/generic/hack-5.15/700-swconfig_switch_drivers.patch b/target/linux/generic/hack-5.15/700-swconfig_switch_drivers.patch
index b90e1fc441..48be440025 100644
--- a/target/linux/generic/hack-5.15/700-swconfig_switch_drivers.patch
+++ b/target/linux/generic/hack-5.15/700-swconfig_switch_drivers.patch
@@ -36,7 +36,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
+ Support for FC is very limited.
+
+config AR8216_PHY
-+ tristate "Driver for Atheros AR8216 switches"
++ tristate "Driver for Atheros AR8216/8327 switches"
+ select SWCONFIG
+ select ETHERNET_PACKET_MANGLE
+
@@ -95,13 +95,15 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
config AMD_PHY
--- a/drivers/net/phy/Makefile
+++ b/drivers/net/phy/Makefile
-@@ -24,6 +24,19 @@ libphy-$(CONFIG_LED_TRIGGER_PHY) += phy_
+@@ -24,6 +24,21 @@ libphy-$(CONFIG_LED_TRIGGER_PHY) += phy_
obj-$(CONFIG_PHYLINK) += phylink.o
obj-$(CONFIG_PHYLIB) += libphy.o
+obj-$(CONFIG_SWCONFIG) += swconfig.o
+obj-$(CONFIG_ADM6996_PHY) += adm6996.o
-+obj-$(CONFIG_AR8216_PHY) += ar8216.o ar8327.o
++obj-$(CONFIG_AR8216_PHY) += ar8xxx.o
++ar8xxx-y += ar8216.o
++ar8xxx-y += ar8327.o
+obj-$(CONFIG_SWCONFIG_B53) += b53/
+obj-$(CONFIG_IP17XX_PHY) += ip17xx.o
+obj-$(CONFIG_PSB6970_PHY) += psb6970.o