aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic/hack-5.10
diff options
context:
space:
mode:
authorOlliver Schinagl <oliver@schinagl.nl>2022-09-20 12:01:48 +0200
committerChristian Marangi <ansuelsmth@gmail.com>2022-10-01 02:47:56 +0200
commitd5bf46bbe8f425182ea07787ae5d92145715da1b (patch)
tree2400e91eaba3059f12e39574f0e5fb3a62bb351f /target/linux/generic/hack-5.10
parent5d09118f8e60fa151e03916f255f5511e197af68 (diff)
downloadupstream-d5bf46bbe8f425182ea07787ae5d92145715da1b.tar.gz
upstream-d5bf46bbe8f425182ea07787ae5d92145715da1b.tar.bz2
upstream-d5bf46bbe8f425182ea07787ae5d92145715da1b.zip
generic: Convert incorrect generic/5.10 patches
OpenWRT's developer guide prefers having actual patches so they an be sent upstream more easily. However, in this case, Adding proper fields also allows for `git am` to properly function. Some of these patches are quite old, and lack much traceable history. This commit tries to rectify that, by digging in the history to find where and how it was first added. It is by no means perfect and also shows some patches that should have been long gone. Signed-off-by: Olliver Schinagl <oliver@schinagl.nl>
Diffstat (limited to 'target/linux/generic/hack-5.10')
-rw-r--r--target/linux/generic/hack-5.10/205-kconfig-exit.patch17
-rw-r--r--target/linux/generic/hack-5.10/253-ksmbd-config.patch13
-rw-r--r--target/linux/generic/hack-5.10/261-lib-arc4-unhide.patch13
-rw-r--r--target/linux/generic/hack-5.10/410-block-fit-partition-parser.patch28
-rw-r--r--target/linux/generic/hack-5.10/430-mtk-bmt-support.patch11
-rw-r--r--target/linux/generic/hack-5.10/600-bridge_offload.patch28
-rw-r--r--target/linux/generic/hack-5.10/711-net-dsa-mv88e6xxx-disable-ATU-violation.patch29
-rw-r--r--target/linux/generic/hack-5.10/760-net-usb-r8152-add-LED-configuration-from-OF.patch2
-rw-r--r--target/linux/generic/hack-5.10/780-usb-net-MeigLink_modem_support.patch14
-rw-r--r--target/linux/generic/hack-5.10/901-debloat_sock_diag.patch2
-rw-r--r--target/linux/generic/hack-5.10/920-device_tree_cmdline.patch16
11 files changed, 169 insertions, 4 deletions
diff --git a/target/linux/generic/hack-5.10/205-kconfig-exit.patch b/target/linux/generic/hack-5.10/205-kconfig-exit.patch
index c3fb7a1f99..591daf624a 100644
--- a/target/linux/generic/hack-5.10/205-kconfig-exit.patch
+++ b/target/linux/generic/hack-5.10/205-kconfig-exit.patch
@@ -1,3 +1,20 @@
+From: David Bauer <mail@david-bauer.net>
+Subject: Kconfig: exit on unset symbol
+
+When a target configuration has unset Kconfig symbols, the build will
+fail when OpenWrt is compiled with V=s and stdin is connected to a tty.
+
+In case OpenWrt is compiled without either of these preconditions, the
+build will succeed with the symbols in question being unset.
+
+Modify the kernel configuration in a way it fails on unset symbols
+regardless of the aforementioned preconditions.
+
+Submitted-by: David Bauer <mail@david-bauer.net>
+---
+ scripts/kconfig/conf.c | 2 +
+ 1 files changed, 2 insertions(+)
+
--- a/scripts/kconfig/conf.c
+++ b/scripts/kconfig/conf.c
@@ -215,6 +215,8 @@ static int conf_sym(struct menu *menu)
diff --git a/target/linux/generic/hack-5.10/253-ksmbd-config.patch b/target/linux/generic/hack-5.10/253-ksmbd-config.patch
index 4d07c1c00e..2992dbeda0 100644
--- a/target/linux/generic/hack-5.10/253-ksmbd-config.patch
+++ b/target/linux/generic/hack-5.10/253-ksmbd-config.patch
@@ -1,3 +1,15 @@
+From: Rosen Penev <rosenp@gmail.com>
+Subject: Kconfig: add help text to kernel config
+
+These options will be used for ksmbd. Once kernel 5.15
+makes it in, this patch can go away.
+
+Submitted-by: Rosen Penev <rosenp@gmail.com>
+---
+ init/Kconfig | 2 +-
+ lib/Kconfig | 2 +-
+ 2 files changed, 2 insertions(+), 2 deletions(-)
+
--- a/init/Kconfig
+++ b/init/Kconfig
@@ -2384,7 +2384,7 @@ config PADATA
@@ -19,4 +31,3 @@
+ tristate "OID"
help
Enable fast lookup object identifier registry.
-
diff --git a/target/linux/generic/hack-5.10/261-lib-arc4-unhide.patch b/target/linux/generic/hack-5.10/261-lib-arc4-unhide.patch
index 4ffd8cfa37..b61dd269a4 100644
--- a/target/linux/generic/hack-5.10/261-lib-arc4-unhide.patch
+++ b/target/linux/generic/hack-5.10/261-lib-arc4-unhide.patch
@@ -1,7 +1,20 @@
+From: Koen Vandeputte <koen.vandeputte@ncentric.com>
+Subject: crypto: arc4 unhide
+
This makes it possible to select CONFIG_CRYPTO_LIB_ARC4 directly. We
need this to be able to compile this into the kernel and make use of it
from backports.
+Submitted-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
+Submitted-by: David Bauer <mail@david-bauer.net>
+Submitted-by: Christian Lamparter <chunkeey@gmail.com>
+Submitted-by: Ansuel Smith <ansuelsmth@gmail.com>
+Submitted-by: Robert Marko <robimarko@gmail.com>
+Submitted-by: Hauke Mehrtens <hauke@hauke-m.de>
+---
+ lib/crypto/Kconfig | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
--- a/lib/crypto/Kconfig
+++ b/lib/crypto/Kconfig
@@ -6,7 +6,7 @@ config CRYPTO_LIB_AES
diff --git a/target/linux/generic/hack-5.10/410-block-fit-partition-parser.patch b/target/linux/generic/hack-5.10/410-block-fit-partition-parser.patch
index 7816356227..00c8d255fc 100644
--- a/target/linux/generic/hack-5.10/410-block-fit-partition-parser.patch
+++ b/target/linux/generic/hack-5.10/410-block-fit-partition-parser.patch
@@ -1,3 +1,30 @@
+From: Daniel Golle <daniel@makrotopia.org>
+Subject: [PATCH] kernel: fix FIT partition parser compatibility issues
+
+The uImage.FIT partition parser used to squeeze in FIT partitions in
+the range where partition editor tools (fdisk and such) expect the
+regular partition. This is confusing people and tools when adding
+additional partitions on top of the partition used for OpenWrt's
+uImage.FIT.
+Instead of squeezing in the additional partitions, rather start with
+all uImage.FIT partitions at offset 64.
+
+Submitted-by: Daniel Golle <daniel@makrotopia.org>
+---
+ block/blk.h | 2 ++
+ block/partitions/Kconfig | 7 +++
+ block/partitions/Makefile | 1 +
+ block/partitions/check.h | 3 ++
+ block/partitions/core.c | 15 +++++++
+ drivers/mtd/ubi/block.c | 7 +++
+ block/partitions/efi.c | 8 +++++++
+ block/partitions/efi.h | 3 ++
+ drivers/mtd/mtdblock.c | 4 +++
+ drivers/mtd/mtd_blkdevs.c | 14 +------
+ block/partitions/msdos.c | 10 ++++++
+ include/linux/msdos_partition.h | 1 +
+ 12 files changed, 52 insertions(+), 13 deletions(-)
+
--- a/block/blk.h
+++ b/block/blk.h
@@ -361,6 +361,8 @@ char *disk_name(struct gendisk *hd, int
@@ -221,4 +248,3 @@
+ FIT_PARTITION = 0x2e, /* U-Boot uImage.FIT */
SOLARIS_X86_PARTITION = 0x82, /* also Linux swap partitions */
NEW_SOLARIS_X86_PARTITION = 0xbf,
-
diff --git a/target/linux/generic/hack-5.10/430-mtk-bmt-support.patch b/target/linux/generic/hack-5.10/430-mtk-bmt-support.patch
index 62ddd66bf2..b18df7584d 100644
--- a/target/linux/generic/hack-5.10/430-mtk-bmt-support.patch
+++ b/target/linux/generic/hack-5.10/430-mtk-bmt-support.patch
@@ -1,3 +1,14 @@
+From 11425c9de29c8b9c5e4d7eec163a6afbb7fbdce2 Mon Sep 17 00:00:00 2001
+From: Felix Fietkau <nbd@nbd.name>
+Date: Thu, 9 Apr 2020 09:53:24 +0200
+Subject: mediatek: Implement bad-block management table support
+
+Submitted-by: Felix Fietkau <nbd@nbd.name>
+---
+ drivers/mtd/nand/Kconfig | 4 ++++
+ drivers/mtd/nand/Makefile | 1 +
+ 2 files changed, 5 insertions(+)
+
--- a/drivers/mtd/nand/Kconfig
+++ b/drivers/mtd/nand/Kconfig
@@ -15,6 +15,10 @@ config MTD_NAND_ECC
diff --git a/target/linux/generic/hack-5.10/600-bridge_offload.patch b/target/linux/generic/hack-5.10/600-bridge_offload.patch
index b704c98dc8..82282627ea 100644
--- a/target/linux/generic/hack-5.10/600-bridge_offload.patch
+++ b/target/linux/generic/hack-5.10/600-bridge_offload.patch
@@ -1,3 +1,31 @@
+From: Felix Fietkau <nbd@nbd.name>
+Subject: bridge: Add a fast path for the bridge code
+
+This caches flows between MAC addresses on separate ports, including their VLAN
+in order to bypass the normal bridge forwarding code.
+In my test on MT7622, this reduces LAN->WLAN bridging CPU usage by 6-10%,
+potentially even more on weaker platforms
+
+Submitted-by: Felix Fietkau <nbd@nbd.name>
+---
+ include/linux/if_bridge.h | 1 +
+ net/bridge/Makefile | 2 +-
+ net/bridge/br.c | 8 +++
+ net/bridge/br_device.c | 7 +++
+ net/bridge/br_forward.c | 3 ++
+ net/bridge/br_if.c | 7 ++-
+ net/bridge/br_input.c | 5 ++
+ net/bridge/br_offload.c | 436 +++++++++++++++
+ net/bridge/br_private.h | 22 ++++-
+ net/bridge/br_private_offload.h | 21 +++++
+ net/bridge/br_stp.c | 3 +
+ net/bridge/br_sysfs_br.c | 35 ++++++
+ net/bridge/br_sysfs_if.c | 2 +
+ net/bridge/br_vlan_tunnel.c | 3 ++
+ 14 files changed, 552 insertions(+), 3 deletions(-)
+ create mode 100644 net/bridge/br_offload.c
+ create mode 100644 net/bridge/br_private_offload.h
+
--- a/include/linux/if_bridge.h
+++ b/include/linux/if_bridge.h
@@ -57,6 +57,7 @@ struct br_ip_list {
diff --git a/target/linux/generic/hack-5.10/711-net-dsa-mv88e6xxx-disable-ATU-violation.patch b/target/linux/generic/hack-5.10/711-net-dsa-mv88e6xxx-disable-ATU-violation.patch
index e69113d3c1..4fc6e355cb 100644
--- a/target/linux/generic/hack-5.10/711-net-dsa-mv88e6xxx-disable-ATU-violation.patch
+++ b/target/linux/generic/hack-5.10/711-net-dsa-mv88e6xxx-disable-ATU-violation.patch
@@ -1,3 +1,32 @@
+From: DENG Qingfang <dqfext@gmail.com>
+Subject: DSA: roaming fix for Marvell mv88e6xxx
+
+Marvell mv88e6xxx switch series cannot perform MAC learning from
+CPU-injected (FROM_CPU) DSA frames, which results in 2 issues.
+- excessive flooding, due to the fact that DSA treats those addresses
+as unknown
+- the risk of stale routes, which can lead to temporary packet loss
+
+Backport those patch series from netdev mailing list, which solve these
+issues by adding and clearing static entries to the switch's FDB.
+
+Add a hack patch to set default VID to 1 in port_fdb_{add,del}. Otherwise
+the static entries will be added to the switch's private FDB if VLAN
+filtering disabled, which will not work.
+
+The switch may generate an "ATU violation" warning when a client moves
+from the CPU port to a switch port because the static ATU entry added by
+DSA core still points to the CPU port. DSA core will then clear the static
+entry so it is not fatal. Disable the warning so it will not confuse users.
+
+Link: https://lore.kernel.org/netdev/20210106095136.224739-1-olteanv@gmail.com/
+Link: https://lore.kernel.org/netdev/20210116012515.3152-1-tobias@waldekranz.com/
+Ref: https://gitlab.nic.cz/turris/turris-build/-/issues/165
+Submitted-by: DENG Qingfang <dqfext@gmail.com>
+---
+ drivers/net/dsa/mv88e6xxx/chip.c | 3 +++
+ 3 files changed, 3 insertions(+)
+
--- a/drivers/net/dsa/mv88e6xxx/chip.c
+++ b/drivers/net/dsa/mv88e6xxx/chip.c
@@ -2705,6 +2705,9 @@ static int mv88e6xxx_setup_port(struct m
diff --git a/target/linux/generic/hack-5.10/760-net-usb-r8152-add-LED-configuration-from-OF.patch b/target/linux/generic/hack-5.10/760-net-usb-r8152-add-LED-configuration-from-OF.patch
index 79e8f55e5b..1e9d5a288f 100644
--- a/target/linux/generic/hack-5.10/760-net-usb-r8152-add-LED-configuration-from-OF.patch
+++ b/target/linux/generic/hack-5.10/760-net-usb-r8152-add-LED-configuration-from-OF.patch
@@ -36,7 +36,7 @@ Signed-off-by: David Bauer <mail@david-bauer.net>
+
+ if (ret)
+ return ret;
-+
++
+ ocp_write_word(tp, MCU_TYPE_PLA, PLA_LEDSEL, led_data);
+
+ return 0;
diff --git a/target/linux/generic/hack-5.10/780-usb-net-MeigLink_modem_support.patch b/target/linux/generic/hack-5.10/780-usb-net-MeigLink_modem_support.patch
index 0c0739e7eb..37dfe86075 100644
--- a/target/linux/generic/hack-5.10/780-usb-net-MeigLink_modem_support.patch
+++ b/target/linux/generic/hack-5.10/780-usb-net-MeigLink_modem_support.patch
@@ -1,3 +1,17 @@
+From: Daniel Golle <daniel@makrotopia.org>
+Subject: wwan: Add MeigLink SLM750 modem support
+
+Add patch found in Teltonika RUT9_R_00.07.01.4 GPL SDK download[1]
+adding USB IDs of the MeigLink SLM750 to the relevant kernel drivers.
+Newer versions of Teltonika's 2G/3G/4G RUT9XX WWAN router series come
+with this kind of modem.
+
+[1]: https://wiki.teltonika-networks.com/view/GPL
+Submitted-by: Daniel Golle <daniel@makrotopia.org>
+---
+ drivers/net/usb/qmi_wwan.c | 8 ++++++
+ 1 file changed, 8 insertions(+)
+
--- a/drivers/net/usb/qmi_wwan.c
+++ b/drivers/net/usb/qmi_wwan.c
@@ -1024,6 +1024,7 @@ static const struct usb_device_id produc
diff --git a/target/linux/generic/hack-5.10/901-debloat_sock_diag.patch b/target/linux/generic/hack-5.10/901-debloat_sock_diag.patch
index 247b50d536..5302c793de 100644
--- a/target/linux/generic/hack-5.10/901-debloat_sock_diag.patch
+++ b/target/linux/generic/hack-5.10/901-debloat_sock_diag.patch
@@ -33,7 +33,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
obj-y += dev.o dev_addr_lists.o dst.o netevent.o \
neighbour.o rtnetlink.o utils.o link_watch.o filter.o \
- sock_diag.o dev_ioctl.o tso.o sock_reuseport.o \
-+ dev_ioctl.o tso.o sock_reuseport.o \
++ dev_ioctl.o tso.o sock_reuseport.o \
fib_notifier.o xdp.o flow_offload.o
+obj-$(CONFIG_SOCK_DIAG) += sock_diag.o
diff --git a/target/linux/generic/hack-5.10/920-device_tree_cmdline.patch b/target/linux/generic/hack-5.10/920-device_tree_cmdline.patch
index 27d4d7f1e5..17d3f2ffd5 100644
--- a/target/linux/generic/hack-5.10/920-device_tree_cmdline.patch
+++ b/target/linux/generic/hack-5.10/920-device_tree_cmdline.patch
@@ -1,3 +1,19 @@
+From a9968d9cb8cb10030491fa05e24b00bd42f6d3a9 Mon Sep 17 00:00:00 2001
+From: John Crispin <john@openwrt.org>
+Date: Thu, 30 May 2013 16:00:42 +0000
+Subject: fdt: enable retrieving kernel args from bootloader
+
+This patch is a device tree enhancement that IMHO is worthy of mainline.
+It allows the bootloader's commandline to be preserved even when the
+device tree specifies one.
+
+Submitted-by: Daniel Gimpelevich <daniel@gimpelevich.san-francisco.ca.us>
+
+SVN-Revision: 36780
+---
+ drivers/of/fdt.c | 3 +++
+ 1 file changed, 3 insertions(+)
+
--- a/drivers/of/fdt.c
+++ b/drivers/of/fdt.c
@@ -1055,6 +1055,9 @@ int __init early_init_dt_scan_chosen(uns