aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic/hack-4.9
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@hauke-m.de>2017-12-16 21:09:41 +0100
committerHauke Mehrtens <hauke@hauke-m.de>2017-12-19 22:45:27 +0100
commitf704b643b9cab8fa6d3eb7c33a7fbd117ecd821a (patch)
tree4ba50f0c0cea60c564d9b76b49ac2985386c4d56 /target/linux/generic/hack-4.9
parente80ab48777d83d8c24fcd397a85649f08b6b5f87 (diff)
downloadupstream-f704b643b9cab8fa6d3eb7c33a7fbd117ecd821a.tar.gz
upstream-f704b643b9cab8fa6d3eb7c33a7fbd117ecd821a.tar.bz2
upstream-f704b643b9cab8fa6d3eb7c33a7fbd117ecd821a.zip
kernel: Update kernel 4.9 to 4.9.70
Runtime tested on lantiq. Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
Diffstat (limited to 'target/linux/generic/hack-4.9')
-rw-r--r--target/linux/generic/hack-4.9/202-reduce_module_size.patch6
-rw-r--r--target/linux/generic/hack-4.9/207-disable-modorder.patch4
-rw-r--r--target/linux/generic/hack-4.9/220-gc_sections.patch6
-rw-r--r--target/linux/generic/hack-4.9/301-mips_image_cmdline_hack.patch2
-rw-r--r--target/linux/generic/hack-4.9/321-powerpc_crtsavres_prereq.patch2
5 files changed, 10 insertions, 10 deletions
diff --git a/target/linux/generic/hack-4.9/202-reduce_module_size.patch b/target/linux/generic/hack-4.9/202-reduce_module_size.patch
index 1b4e19a4a6..6e5fc9cd46 100644
--- a/target/linux/generic/hack-4.9/202-reduce_module_size.patch
+++ b/target/linux/generic/hack-4.9/202-reduce_module_size.patch
@@ -13,12 +13,12 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
--- a/Makefile
+++ b/Makefile
-@@ -407,7 +407,7 @@ KBUILD_CFLAGS_KERNEL :=
- KBUILD_AFLAGS := -D__ASSEMBLY__ $(call cc-option,-fno-PIE)
+@@ -401,7 +401,7 @@ KBUILD_AFLAGS_KERNEL :=
+ KBUILD_CFLAGS_KERNEL :=
KBUILD_AFLAGS_MODULE := -DMODULE
KBUILD_CFLAGS_MODULE := -DMODULE
-KBUILD_LDFLAGS_MODULE := -T $(srctree)/scripts/module-common.lds
+KBUILD_LDFLAGS_MODULE = -T $(srctree)/scripts/module-common.lds $(if $(CONFIG_PROFILING),,-s)
+ GCC_PLUGINS_CFLAGS :=
# Read KERNELRELEASE from include/config/kernel.release (if it exists)
- KERNELRELEASE = $(shell cat include/config/kernel.release 2> /dev/null)
diff --git a/target/linux/generic/hack-4.9/207-disable-modorder.patch b/target/linux/generic/hack-4.9/207-disable-modorder.patch
index 354052d8b4..1b0262a06f 100644
--- a/target/linux/generic/hack-4.9/207-disable-modorder.patch
+++ b/target/linux/generic/hack-4.9/207-disable-modorder.patch
@@ -15,7 +15,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
--- a/Makefile
+++ b/Makefile
-@@ -1196,7 +1196,6 @@ all: modules
+@@ -1197,7 +1197,6 @@ all: modules
PHONY += modules
modules: $(vmlinux-dirs) $(if $(KBUILD_BUILTIN),vmlinux) modules.builtin
@@ -23,7 +23,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
@$(kecho) ' Building modules, stage 2.';
$(Q)$(MAKE) -f $(srctree)/scripts/Makefile.modpost
$(Q)$(MAKE) -f $(srctree)/scripts/Makefile.fwinst obj=firmware __fw_modbuild
-@@ -1226,7 +1225,6 @@ _modinst_:
+@@ -1227,7 +1226,6 @@ _modinst_:
rm -f $(MODLIB)/build ; \
ln -s $(CURDIR) $(MODLIB)/build ; \
fi
diff --git a/target/linux/generic/hack-4.9/220-gc_sections.patch b/target/linux/generic/hack-4.9/220-gc_sections.patch
index eda8bb8b2b..e39f0f5f44 100644
--- a/target/linux/generic/hack-4.9/220-gc_sections.patch
+++ b/target/linux/generic/hack-4.9/220-gc_sections.patch
@@ -21,9 +21,9 @@ Signed-off-by: Gabor Juhos <juhosg@openwrt.org>
--- a/Makefile
+++ b/Makefile
-@@ -409,6 +409,11 @@ KBUILD_AFLAGS_MODULE := -DMODULE
- KBUILD_CFLAGS_MODULE := -DMODULE
+@@ -404,6 +404,11 @@ KBUILD_CFLAGS_MODULE := -DMODULE
KBUILD_LDFLAGS_MODULE = -T $(srctree)/scripts/module-common.lds $(if $(CONFIG_PROFILING),,-s)
+ GCC_PLUGINS_CFLAGS :=
+ifdef CONFIG_LD_DEAD_CODE_DATA_ELIMINATION
+KBUILD_CFLAGS_KERNEL += $(call cc-option,-ffunction-sections,)
@@ -33,7 +33,7 @@ Signed-off-by: Gabor Juhos <juhosg@openwrt.org>
# Read KERNELRELEASE from include/config/kernel.release (if it exists)
KERNELRELEASE = $(shell cat include/config/kernel.release 2> /dev/null)
KERNELVERSION = $(VERSION)$(if $(PATCHLEVEL),.$(PATCHLEVEL)$(if $(SUBLEVEL),.$(SUBLEVEL)))$(EXTRAVERSION)
-@@ -633,11 +638,6 @@ KBUILD_CFLAGS += $(call cc-disable-warni
+@@ -634,11 +639,6 @@ KBUILD_CFLAGS += $(call cc-disable-warni
KBUILD_CFLAGS += $(call cc-disable-warning, format-overflow)
KBUILD_CFLAGS += $(call cc-disable-warning, int-in-bool-context)
diff --git a/target/linux/generic/hack-4.9/301-mips_image_cmdline_hack.patch b/target/linux/generic/hack-4.9/301-mips_image_cmdline_hack.patch
index a3df4fbe3a..7c3e38efcf 100644
--- a/target/linux/generic/hack-4.9/301-mips_image_cmdline_hack.patch
+++ b/target/linux/generic/hack-4.9/301-mips_image_cmdline_hack.patch
@@ -10,7 +10,7 @@ Signed-off-by: Gabor Juhos <juhosg@openwrt.org>
--- a/arch/mips/Kconfig
+++ b/arch/mips/Kconfig
-@@ -1150,6 +1150,10 @@ config SYNC_R4K
+@@ -1155,6 +1155,10 @@ config SYNC_R4K
config MIPS_MACHINE
def_bool n
diff --git a/target/linux/generic/hack-4.9/321-powerpc_crtsavres_prereq.patch b/target/linux/generic/hack-4.9/321-powerpc_crtsavres_prereq.patch
index c22a4823fe..8c6ed8c207 100644
--- a/target/linux/generic/hack-4.9/321-powerpc_crtsavres_prereq.patch
+++ b/target/linux/generic/hack-4.9/321-powerpc_crtsavres_prereq.patch
@@ -16,7 +16,7 @@ Signed-off-by: Alexandros C. Couloumbis <alex@ozo.com>
--- a/arch/powerpc/Makefile
+++ b/arch/powerpc/Makefile
-@@ -179,7 +179,6 @@ else
+@@ -188,7 +188,6 @@ else
CHECKFLAGS += -D__LITTLE_ENDIAN__
endif