aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic/hack-4.9
diff options
context:
space:
mode:
authorKoen Vandeputte <koen.vandeputte@ncentric.com>2018-12-06 10:48:21 +0100
committerKoen Vandeputte <koen.vandeputte@ncentric.com>2018-12-10 11:48:44 +0100
commitdfbf836a52e451f98e90dcf567c107062e2d7048 (patch)
tree4e3e867a73b54be0ce3dda99e96f14979c31ab8c /target/linux/generic/hack-4.9
parent4e38fc824c8ed69fd0adbcc5a98b9a6476dde657 (diff)
downloadupstream-dfbf836a52e451f98e90dcf567c107062e2d7048.tar.gz
upstream-dfbf836a52e451f98e90dcf567c107062e2d7048.tar.bz2
upstream-dfbf836a52e451f98e90dcf567c107062e2d7048.zip
kernel: bump 4.9 to 4.9.143
Refreshed all patches. Altered patches: - 950-0063-Improve-__copy_to_user-and-__copy_from_user-performa.patch - 201-extra_optimization.patch New symbol: - CONFIG_HARDEN_BRANCH_PREDICTOR Compile-tested on: ar7, at91, brcm2708, ixp4xx, layerscape, orion Runtime-tested on: none Signed-off-by: Koen Vandeputte <koen.vandeputte@ncentric.com> [fix brcm2708/950-0149-Update-vfpmodule.c.patch] Signed-off-by: Stijn Tintel <stijn@linux-ipv6.be>
Diffstat (limited to 'target/linux/generic/hack-4.9')
-rw-r--r--target/linux/generic/hack-4.9/207-disable-modorder.patch4
-rw-r--r--target/linux/generic/hack-4.9/220-gc_sections.patch6
-rw-r--r--target/linux/generic/hack-4.9/221-module_exports.patch2
3 files changed, 6 insertions, 6 deletions
diff --git a/target/linux/generic/hack-4.9/207-disable-modorder.patch b/target/linux/generic/hack-4.9/207-disable-modorder.patch
index 22e863c286..e92f4fa0bf 100644
--- a/target/linux/generic/hack-4.9/207-disable-modorder.patch
+++ b/target/linux/generic/hack-4.9/207-disable-modorder.patch
@@ -15,7 +15,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
--- a/Makefile
+++ b/Makefile
-@@ -1213,7 +1213,6 @@ all: modules
+@@ -1226,7 +1226,6 @@ all: modules
PHONY += modules
modules: $(vmlinux-dirs) $(if $(KBUILD_BUILTIN),vmlinux) modules.builtin
@@ -23,7 +23,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
@$(kecho) ' Building modules, stage 2.';
$(Q)$(MAKE) -f $(srctree)/scripts/Makefile.modpost
$(Q)$(MAKE) -f $(srctree)/scripts/Makefile.fwinst obj=firmware __fw_modbuild
-@@ -1243,7 +1242,6 @@ _modinst_:
+@@ -1256,7 +1255,6 @@ _modinst_:
rm -f $(MODLIB)/build ; \
ln -s $(CURDIR) $(MODLIB)/build ; \
fi
diff --git a/target/linux/generic/hack-4.9/220-gc_sections.patch b/target/linux/generic/hack-4.9/220-gc_sections.patch
index 3131744899..ea80509035 100644
--- a/target/linux/generic/hack-4.9/220-gc_sections.patch
+++ b/target/linux/generic/hack-4.9/220-gc_sections.patch
@@ -33,7 +33,7 @@ Signed-off-by: Gabor Juhos <juhosg@openwrt.org>
# Read KERNELRELEASE from include/config/kernel.release (if it exists)
KERNELRELEASE = $(shell cat include/config/kernel.release 2> /dev/null)
KERNELVERSION = $(VERSION)$(if $(PATCHLEVEL),.$(PATCHLEVEL)$(if $(SUBLEVEL),.$(SUBLEVEL)))$(EXTRAVERSION)
-@@ -638,11 +643,6 @@ KBUILD_CFLAGS += $(call cc-disable-warni
+@@ -671,11 +676,6 @@ KBUILD_CFLAGS += $(call cc-disable-warni
KBUILD_CFLAGS += $(call cc-disable-warning, int-in-bool-context)
KBUILD_CFLAGS += $(call cc-disable-warning, attribute-alias)
@@ -43,8 +43,8 @@ Signed-off-by: Gabor Juhos <juhosg@openwrt.org>
-endif
-
ifdef CONFIG_CC_OPTIMIZE_FOR_SIZE
- KBUILD_CFLAGS += -Os $(call cc-disable-warning,maybe-uninitialized,) $(EXTRA_OPTIMIZATION)
- else
+ KBUILD_CFLAGS += $(call cc-option,-Oz,-Os)
+ KBUILD_CFLAGS += $(call cc-disable-warning,maybe-uninitialized,) $(EXTRA_OPTIMIZATION)
--- a/arch/arm/Kconfig
+++ b/arch/arm/Kconfig
@@ -81,6 +81,7 @@ config ARM
diff --git a/target/linux/generic/hack-4.9/221-module_exports.patch b/target/linux/generic/hack-4.9/221-module_exports.patch
index a2027d0d5a..f357d73d6a 100644
--- a/target/linux/generic/hack-4.9/221-module_exports.patch
+++ b/target/linux/generic/hack-4.9/221-module_exports.patch
@@ -90,7 +90,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
__used \
--- a/scripts/Makefile.build
+++ b/scripts/Makefile.build
-@@ -401,7 +401,7 @@ targets += $(extra-y) $(MAKECMDGOALS) $(
+@@ -409,7 +409,7 @@ targets += $(extra-y) $(MAKECMDGOALS) $(
# Linker scripts preprocessor (.lds.S -> .lds)
# ---------------------------------------------------------------------------
quiet_cmd_cpp_lds_S = LDS $@