aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic/hack-4.9/901-debloat_sock_diag.patch
diff options
context:
space:
mode:
authorStijn Tintel <stijn@linux-ipv6.be>2017-08-17 10:51:05 +0200
committerStijn Tintel <stijn@linux-ipv6.be>2017-08-17 12:34:34 +0200
commit2d02a4f5bda4a5ff392286360ec7d1129bd77d25 (patch)
treec243a9231fd508b585c2711e8b691e8ca06d2988 /target/linux/generic/hack-4.9/901-debloat_sock_diag.patch
parentd9564d79b8e91eed23c45afd2eb4a71a97c922eb (diff)
downloadupstream-2d02a4f5bda4a5ff392286360ec7d1129bd77d25.tar.gz
upstream-2d02a4f5bda4a5ff392286360ec7d1129bd77d25.tar.bz2
upstream-2d02a4f5bda4a5ff392286360ec7d1129bd77d25.zip
kernel: update 4.9 to 4.9.44
Refresh patches. Adapt 704-phy-no-genphy-soft-reset.patch. Remove brcm2708/950-0005-mm-Remove-the-PFN-busy-warning.patch. Compile-tested on brcm2708/bcm2708 and x86/64. Runtime-tested on brcm2708/bcm2708 and x86/64. Fixes the following vulnerabilities: - CVE-2017-7533 - CVE-2017-1000111 - CVE-2017-1000112 Signed-off-by: Stijn Tintel <stijn@linux-ipv6.be>
Diffstat (limited to 'target/linux/generic/hack-4.9/901-debloat_sock_diag.patch')
-rw-r--r--target/linux/generic/hack-4.9/901-debloat_sock_diag.patch19
1 files changed, 1 insertions, 18 deletions
diff --git a/target/linux/generic/hack-4.9/901-debloat_sock_diag.patch b/target/linux/generic/hack-4.9/901-debloat_sock_diag.patch
index d46e2ca1e7..98ac5afea6 100644
--- a/target/linux/generic/hack-4.9/901-debloat_sock_diag.patch
+++ b/target/linux/generic/hack-4.9/901-debloat_sock_diag.patch
@@ -14,8 +14,6 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
net/unix/Kconfig | 1 +
7 files changed, 11 insertions(+), 1 deletion(-)
-diff --git a/net/Kconfig b/net/Kconfig
-index 38a0c857eb52..b4621e1f3470 100644
--- a/net/Kconfig
+++ b/net/Kconfig
@@ -95,6 +95,9 @@ source "net/netlabel/Kconfig"
@@ -28,11 +26,9 @@ index 38a0c857eb52..b4621e1f3470 100644
config NETWORK_SECMARK
bool "Security Marking"
help
-diff --git a/net/core/Makefile b/net/core/Makefile
-index d6508c2ddca5..bee4adde14d8 100644
--- a/net/core/Makefile
+++ b/net/core/Makefile
-@@ -9,8 +9,9 @@ obj-$(CONFIG_SYSCTL) += sysctl_net_core.o
+@@ -9,8 +9,9 @@ obj-$(CONFIG_SYSCTL) += sysctl_net_core.
obj-y += dev.o ethtool.o dev_addr_lists.o dst.o netevent.o \
neighbour.o rtnetlink.o utils.o link_watch.o filter.o \
@@ -43,8 +39,6 @@ index d6508c2ddca5..bee4adde14d8 100644
obj-$(CONFIG_XFRM) += flow.o
obj-y += net-sysfs.o
obj-$(CONFIG_PROC_FS) += net-procfs.o
-diff --git a/net/core/sock.c b/net/core/sock.c
-index 1989b3dd6d17..d4ca8db4166a 100644
--- a/net/core/sock.c
+++ b/net/core/sock.c
@@ -1457,9 +1457,11 @@ void sk_destruct(struct sock *sk)
@@ -59,8 +53,6 @@ index 1989b3dd6d17..d4ca8db4166a 100644
sk_destruct(sk);
}
-diff --git a/net/ipv4/Kconfig b/net/ipv4/Kconfig
-index b54b3ca939db..74ecf598622c 100644
--- a/net/ipv4/Kconfig
+++ b/net/ipv4/Kconfig
@@ -408,6 +408,7 @@ config INET_XFRM_MODE_BEET
@@ -71,8 +63,6 @@ index b54b3ca939db..74ecf598622c 100644
default y
---help---
Support for INET (TCP, DCCP, etc) socket monitoring interface used by
-diff --git a/net/netlink/Kconfig b/net/netlink/Kconfig
-index 5d6e8c05b3d4..8a2696d66c20 100644
--- a/net/netlink/Kconfig
+++ b/net/netlink/Kconfig
@@ -4,6 +4,7 @@
@@ -83,8 +73,6 @@ index 5d6e8c05b3d4..8a2696d66c20 100644
default n
---help---
Support for NETLINK socket monitoring interface used by the ss tool.
-diff --git a/net/packet/Kconfig b/net/packet/Kconfig
-index cc55b35f80e5..9a83c86f5480 100644
--- a/net/packet/Kconfig
+++ b/net/packet/Kconfig
@@ -18,6 +18,7 @@ config PACKET
@@ -95,8 +83,6 @@ index cc55b35f80e5..9a83c86f5480 100644
default n
---help---
Support for PF_PACKET sockets monitoring interface used by the ss tool.
-diff --git a/net/unix/Kconfig b/net/unix/Kconfig
-index 8b31ab85d050..6548cf3ea7f1 100644
--- a/net/unix/Kconfig
+++ b/net/unix/Kconfig
@@ -22,6 +22,7 @@ config UNIX
@@ -107,6 +93,3 @@ index 8b31ab85d050..6548cf3ea7f1 100644
default n
---help---
Support for UNIX socket monitoring interface used by the ss tool.
---
-2.11.0
-