aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic/hack-4.9/259-regmap_dynamic.patch
diff options
context:
space:
mode:
authorStijn Tintel <stijn@linux-ipv6.be>2017-08-17 10:51:05 +0200
committerStijn Tintel <stijn@linux-ipv6.be>2017-08-17 12:34:34 +0200
commit2d02a4f5bda4a5ff392286360ec7d1129bd77d25 (patch)
treec243a9231fd508b585c2711e8b691e8ca06d2988 /target/linux/generic/hack-4.9/259-regmap_dynamic.patch
parentd9564d79b8e91eed23c45afd2eb4a71a97c922eb (diff)
downloadupstream-2d02a4f5bda4a5ff392286360ec7d1129bd77d25.tar.gz
upstream-2d02a4f5bda4a5ff392286360ec7d1129bd77d25.tar.bz2
upstream-2d02a4f5bda4a5ff392286360ec7d1129bd77d25.zip
kernel: update 4.9 to 4.9.44
Refresh patches. Adapt 704-phy-no-genphy-soft-reset.patch. Remove brcm2708/950-0005-mm-Remove-the-PFN-busy-warning.patch. Compile-tested on brcm2708/bcm2708 and x86/64. Runtime-tested on brcm2708/bcm2708 and x86/64. Fixes the following vulnerabilities: - CVE-2017-7533 - CVE-2017-1000111 - CVE-2017-1000112 Signed-off-by: Stijn Tintel <stijn@linux-ipv6.be>
Diffstat (limited to 'target/linux/generic/hack-4.9/259-regmap_dynamic.patch')
-rw-r--r--target/linux/generic/hack-4.9/259-regmap_dynamic.patch11
1 files changed, 0 insertions, 11 deletions
diff --git a/target/linux/generic/hack-4.9/259-regmap_dynamic.patch b/target/linux/generic/hack-4.9/259-regmap_dynamic.patch
index a6801125b4..85c9d79159 100644
--- a/target/linux/generic/hack-4.9/259-regmap_dynamic.patch
+++ b/target/linux/generic/hack-4.9/259-regmap_dynamic.patch
@@ -12,8 +12,6 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
include/linux/regmap.h | 2 +-
4 files changed, 22 insertions(+), 10 deletions(-)
-diff --git a/drivers/base/regmap/Kconfig b/drivers/base/regmap/Kconfig
-index 48b3fc1ee514..c4cb7592392b 100644
--- a/drivers/base/regmap/Kconfig
+++ b/drivers/base/regmap/Kconfig
@@ -3,9 +3,8 @@
@@ -56,8 +54,6 @@ index 48b3fc1ee514..c4cb7592392b 100644
config REGMAP_IRQ
+ select REGMAP
bool
-diff --git a/drivers/base/regmap/Makefile b/drivers/base/regmap/Makefile
-index 6271ea9b758a..f23c58a050aa 100644
--- a/drivers/base/regmap/Makefile
+++ b/drivers/base/regmap/Makefile
@@ -1,10 +1,14 @@
@@ -79,8 +75,6 @@ index 6271ea9b758a..f23c58a050aa 100644
obj-$(CONFIG_REGMAP_AC97) += regmap-ac97.o
obj-$(CONFIG_REGMAP_I2C) += regmap-i2c.o
obj-$(CONFIG_REGMAP_SPI) += regmap-spi.o
-diff --git a/drivers/base/regmap/regmap.c b/drivers/base/regmap/regmap.c
-index ae63bb0875ea..2ac56b4f525e 100644
--- a/drivers/base/regmap/regmap.c
+++ b/drivers/base/regmap/regmap.c
@@ -13,6 +13,7 @@
@@ -97,8 +91,6 @@ index ae63bb0875ea..2ac56b4f525e 100644
postcore_initcall(regmap_initcall);
+
+MODULE_LICENSE("GPL");
-diff --git a/include/linux/regmap.h b/include/linux/regmap.h
-index f6673132431d..95c7db29448b 100644
--- a/include/linux/regmap.h
+++ b/include/linux/regmap.h
@@ -135,7 +135,7 @@ struct reg_sequence {
@@ -110,6 +102,3 @@ index f6673132431d..95c7db29448b 100644
enum regmap_endian {
/* Unspecified -> 0 -> Backwards compatible default */
---
-2.11.0
-