aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic/files/drivers/net/phy/b53/Makefile
diff options
context:
space:
mode:
authorJonas Gorski <jogo@openwrt.org>2013-01-23 10:12:33 +0000
committerJonas Gorski <jogo@openwrt.org>2013-01-23 10:12:33 +0000
commit793f269e52d31fdbfc83d319a6c7598673f9722b (patch)
tree66097161c6a6f9962a5f8156a61c2ca6a1261c6d /target/linux/generic/files/drivers/net/phy/b53/Makefile
parent4257876e46d9d4329770e72e9aa16599597878fa (diff)
downloadupstream-793f269e52d31fdbfc83d319a6c7598673f9722b.tar.gz
upstream-793f269e52d31fdbfc83d319a6c7598673f9722b.tar.bz2
upstream-793f269e52d31fdbfc83d319a6c7598673f9722b.zip
generic: add b53 swconfig switch driver
Add swconfig switch driver for Broadcom BCM53XX switch chips. Supports switches connected through MDIO, SPI or memory mapped registers, and supports BCM5325, BCM539x, BCM531x5 and the BCM63XX internal switch chips. Tested are BCM5325 trough MDIO, BCM53115 through SPI, and BCM6328. Signed-off-by: Jonas Gorski <jogo@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@35305 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/generic/files/drivers/net/phy/b53/Makefile')
-rw-r--r--target/linux/generic/files/drivers/net/phy/b53/Makefile9
1 files changed, 9 insertions, 0 deletions
diff --git a/target/linux/generic/files/drivers/net/phy/b53/Makefile b/target/linux/generic/files/drivers/net/phy/b53/Makefile
new file mode 100644
index 0000000000..146196e088
--- /dev/null
+++ b/target/linux/generic/files/drivers/net/phy/b53/Makefile
@@ -0,0 +1,9 @@
+obj-$(CONFIG_B53) += b53_common.o
+
+obj-$(CONFIG_B53_PHY_FIXUP) += b53_phy_fixup.o
+
+obj-$(CONFIG_B53_MMAP_DRIVER) += b53_mmap.o
+obj-$(CONFIG_B53_PHY_DRIVER) += b53_mdio.o
+obj-$(CONFIG_B53_SPI_DRIVER) += b53_spi.o
+
+ccflags-y += -Werror