aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic/backport-5.10
diff options
context:
space:
mode:
authorChristian Marangi <ansuelsmth@gmail.com>2022-10-16 20:36:03 +0200
committerChristian Marangi <ansuelsmth@gmail.com>2022-10-16 20:36:03 +0200
commit6b4bdab91820f2346988e937a554921d8b234406 (patch)
treeb0c761d82869d94b3ee12c595bec5430b8e185c0 /target/linux/generic/backport-5.10
parent6893dd48034ceedcb8212befb5fbb70c15b83154 (diff)
downloadupstream-6b4bdab91820f2346988e937a554921d8b234406.tar.gz
upstream-6b4bdab91820f2346988e937a554921d8b234406.tar.bz2
upstream-6b4bdab91820f2346988e937a554921d8b234406.zip
generic: 5.10: refresh backport patches
Refresh backport patches for kernel 5.10. Signed-off-by: Christian Marangi <ansuelsmth@gmail.com>
Diffstat (limited to 'target/linux/generic/backport-5.10')
-rw-r--r--target/linux/generic/backport-5.10/005-v5.17-01-Kbuild-use-Wdeclaration-after-statement.patch16
-rw-r--r--target/linux/generic/backport-5.10/005-v5.17-02-Kbuild-move-to-std-gnu11.patch6
-rw-r--r--target/linux/generic/backport-5.10/005-v5.17-03-Kbuild-use-std-gnu11-for-KBUILD_USERCFLAGS.patch5
-rw-r--r--target/linux/generic/backport-5.10/011-kbuild-export-SUBARCH.patch2
4 files changed, 15 insertions, 14 deletions
diff --git a/target/linux/generic/backport-5.10/005-v5.17-01-Kbuild-use-Wdeclaration-after-statement.patch b/target/linux/generic/backport-5.10/005-v5.17-01-Kbuild-use-Wdeclaration-after-statement.patch
index dd8a1b445d..b01507e653 100644
--- a/target/linux/generic/backport-5.10/005-v5.17-01-Kbuild-use-Wdeclaration-after-statement.patch
+++ b/target/linux/generic/backport-5.10/005-v5.17-01-Kbuild-use-Wdeclaration-after-statement.patch
@@ -39,13 +39,13 @@ Signed-off-by: Masahiro Yamada <masahiroy@kernel.org>
+++ b/Makefile
@@ -416,7 +416,8 @@ HOSTCXX = g++
endif
-
+
export KBUILD_USERCFLAGS := -Wall -Wmissing-prototypes -Wstrict-prototypes \
- -O2 -fomit-frame-pointer -std=gnu89
+ -O2 -fomit-frame-pointer -std=gnu89 \
+ -Wdeclaration-after-statement
export KBUILD_USERLDFLAGS :=
-
+
KBUILD_HOSTCFLAGS := $(KBUILD_USERCFLAGS) $(HOST_LFS_CFLAGS) $(HOSTCFLAGS)
--- a/arch/arm64/kernel/vdso32/Makefile
+++ b/arch/arm64/kernel/vdso32/Makefile
@@ -61,13 +61,13 @@ Signed-off-by: Masahiro Yamada <masahiroy@kernel.org>
+++ b/scripts/mod/modpost.c
@@ -844,8 +844,10 @@ static int match(const char *sym, const
{
- const char *p;
- while (*pat) {
+ const char *p;
+ while (*pat) {
+ const char *endp;
+
- p = *pat++;
+ p = *pat++;
- const char *endp = p + strlen(p) - 1;
+ endp = p + strlen(p) - 1;
-
- /* "*foo*" */
- if (*p == '*' && *endp == '*') {
+
+ /* "*foo*" */
+ if (*p == '*' && *endp == '*') {
diff --git a/target/linux/generic/backport-5.10/005-v5.17-02-Kbuild-move-to-std-gnu11.patch b/target/linux/generic/backport-5.10/005-v5.17-02-Kbuild-move-to-std-gnu11.patch
index 7938fe5026..c56cecfb71 100644
--- a/target/linux/generic/backport-5.10/005-v5.17-02-Kbuild-move-to-std-gnu11.patch
+++ b/target/linux/generic/backport-5.10/005-v5.17-02-Kbuild-move-to-std-gnu11.patch
@@ -50,9 +50,9 @@ Signed-off-by: Masahiro Yamada <masahiroy@kernel.org>
--- a/Makefile
+++ b/Makefile
@@ -498,7 +498,7 @@ KBUILD_CFLAGS := -Wall -Wundef -Werror
- -fno-strict-aliasing -fno-common -fshort-wchar -fno-PIE \
- -Werror=implicit-function-declaration -Werror=implicit-int \
- -Werror=return-type -Wno-format-security \
+ -fno-strict-aliasing -fno-common -fshort-wchar -fno-PIE \
+ -Werror=implicit-function-declaration -Werror=implicit-int \
+ -Werror=return-type -Wno-format-security \
- -std=gnu89
+ -std=gnu11
KBUILD_CPPFLAGS := -D__KERNEL__
diff --git a/target/linux/generic/backport-5.10/005-v5.17-03-Kbuild-use-std-gnu11-for-KBUILD_USERCFLAGS.patch b/target/linux/generic/backport-5.10/005-v5.17-03-Kbuild-use-std-gnu11-for-KBUILD_USERCFLAGS.patch
index 34b5b653ae..e8d7c40d11 100644
--- a/target/linux/generic/backport-5.10/005-v5.17-03-Kbuild-use-std-gnu11-for-KBUILD_USERCFLAGS.patch
+++ b/target/linux/generic/backport-5.10/005-v5.17-03-Kbuild-use-std-gnu11-for-KBUILD_USERCFLAGS.patch
@@ -34,9 +34,10 @@ Signed-off-by: Masahiro Yamada <masahiroy@kernel.org>
+++ b/Makefile
@@ -416,7 +416,7 @@ HOSTCXX = g++
endif
-
+
export KBUILD_USERCFLAGS := -Wall -Wmissing-prototypes -Wstrict-prototypes \
- -O2 -fomit-frame-pointer -std=gnu89 \
+ -O2 -fomit-frame-pointer -std=gnu11 \
- -Wdeclaration-after-statement
+ -Wdeclaration-after-statement
export KBUILD_USERLDFLAGS :=
+
diff --git a/target/linux/generic/backport-5.10/011-kbuild-export-SUBARCH.patch b/target/linux/generic/backport-5.10/011-kbuild-export-SUBARCH.patch
index bb99e4ddbf..f7e2d207cc 100644
--- a/target/linux/generic/backport-5.10/011-kbuild-export-SUBARCH.patch
+++ b/target/linux/generic/backport-5.10/011-kbuild-export-SUBARCH.patch
@@ -10,7 +10,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
--- a/Makefile
+++ b/Makefile
-@@ -507,7 +507,7 @@ KBUILD_LDFLAGS_MODULE :=
+@@ -508,7 +508,7 @@ KBUILD_LDFLAGS_MODULE :=
KBUILD_LDFLAGS :=
CLANG_FLAGS :=