aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic-2.6
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2006-05-30 19:38:38 +0000
committerFelix Fietkau <nbd@openwrt.org>2006-05-30 19:38:38 +0000
commit340f1875ed67c4df30612f9fcd86b6fe9307c77a (patch)
treeeb392a5dc848616550a5c47b5a2481f8e6b8bc1f /target/linux/generic-2.6
parentf45baccdc5081fc6245c9d567ddb47518f3dc84b (diff)
downloadupstream-340f1875ed67c4df30612f9fcd86b6fe9307c77a.tar.gz
upstream-340f1875ed67c4df30612f9fcd86b6fe9307c77a.tar.bz2
upstream-340f1875ed67c4df30612f9fcd86b6fe9307c77a.zip
resync with kamikaze
git-svn-id: svn://svn.openwrt.org/openwrt/branches/buildroot-ng/openwrt@3844 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/generic-2.6')
-rw-r--r--target/linux/generic-2.6/modules.mk6
-rw-r--r--target/linux/generic-2.6/patches/005-gcc4_fix.patch14
2 files changed, 18 insertions, 2 deletions
diff --git a/target/linux/generic-2.6/modules.mk b/target/linux/generic-2.6/modules.mk
index ab8a5f5d51..b582400bd6 100644
--- a/target/linux/generic-2.6/modules.mk
+++ b/target/linux/generic-2.6/modules.mk
@@ -14,10 +14,14 @@ $(eval $(call KMOD_template,GRE,gre,\
,CONFIG_NET_IPGRE))
$(eval $(call KMOD_template,IMQ,imq,\
- $(MODULES_DIR)/kernel/net/*/netfilter/*IMQ*.ko \
+ $(MODULES_DIR)/kernel/net/ipv4/netfilter/*IMQ*.ko \
$(MODULES_DIR)/kernel/drivers/net/imq.ko \
))
+$(eval $(call KMOD_template,IPIP,ipip,\
+ $(MODULES_DIR)/kernel/net/ipv4/ipip.ko \
+,CONFIG_NET_IPIP,,60,ipip))
+
$(eval $(call KMOD_template,IPV6,ipv6,\
$(MODULES_DIR)/kernel/net/ipv6/ipv6.ko \
,CONFIG_IPV6,,20,ipv6))
diff --git a/target/linux/generic-2.6/patches/005-gcc4_fix.patch b/target/linux/generic-2.6/patches/005-gcc4_fix.patch
index 91da40ac37..72df58184d 100644
--- a/target/linux/generic-2.6/patches/005-gcc4_fix.patch
+++ b/target/linux/generic-2.6/patches/005-gcc4_fix.patch
@@ -179,7 +179,19 @@ diff -Nur linux-2.6.15.1/lib/Makefile linux-2.6.15.1-openwrt/lib/Makefile
sha1.o
lib-y += kobject.o kref.o kobject_uevent.o klist.o
-+lib-y += ashldi3.o ashrdi3.o lshrdi3.o
++obj-y += ashldi3.o ashrdi3.o lshrdi3.o
obj-y += sort.o parser.o halfmd4.o
+diff -Nur linux-2.6.15.1/include/asm-arm/libgcc.h linux-2.6.15.1-openwrt/include/asm-arm/libgcc.h
+--- linux-2.6.15.1/include/asm-arm/libgcc.h 1970-01-01 01:00:00.000000000 +0100
++++ linux-2.6.15.1-openwrt/include/asm-arm/libgcc.h 2006-04-12 23:01:18.000000000 +0200
+@@ -0,0 +1,8 @@
++#ifndef __ASM_LIBGCC_H
++#define __ASM_LIBGCC_H
++
++#undef ARCH_NEEDS_ashldi3
++#undef ARCH_NEEDS_ashrdi3
++#undef ARCH_NEEDS_lshrdi3
++
++#endif /* __ASM_LIBGCC_H */