aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic-2.6/patches/902-darwin_scripts_include.patch
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2008-09-21 11:25:17 +0000
committerFelix Fietkau <nbd@openwrt.org>2008-09-21 11:25:17 +0000
commit4296e978da0ab4198aa7f3d823690ee452e300c6 (patch)
treea5e666785df63064d1322e25030732622082b073 /target/linux/generic-2.6/patches/902-darwin_scripts_include.patch
parente5dc717d220534bd61ee53c010ad050f648170c3 (diff)
downloadupstream-4296e978da0ab4198aa7f3d823690ee452e300c6.tar.gz
upstream-4296e978da0ab4198aa7f3d823690ee452e300c6.tar.bz2
upstream-4296e978da0ab4198aa7f3d823690ee452e300c6.zip
rename generic-2.6/patches to generic-2.6/patches-2.6.21
SVN-Revision: 12636
Diffstat (limited to 'target/linux/generic-2.6/patches/902-darwin_scripts_include.patch')
-rw-r--r--target/linux/generic-2.6/patches/902-darwin_scripts_include.patch154
1 files changed, 0 insertions, 154 deletions
diff --git a/target/linux/generic-2.6/patches/902-darwin_scripts_include.patch b/target/linux/generic-2.6/patches/902-darwin_scripts_include.patch
deleted file mode 100644
index 0e981def57..0000000000
--- a/target/linux/generic-2.6/patches/902-darwin_scripts_include.patch
+++ /dev/null
@@ -1,154 +0,0 @@
-Index: linux-2.6.21.7/scripts/genksyms/parse.c_shipped
-===================================================================
---- linux-2.6.21.7.orig/scripts/genksyms/parse.c_shipped
-+++ linux-2.6.21.7/scripts/genksyms/parse.c_shipped
-@@ -144,7 +144,9 @@
-
-
- #include <assert.h>
-+#ifndef __APPLE__
- #include <malloc.h>
-+#endif
- #include "genksyms.h"
-
- static int is_typedef;
-Index: linux-2.6.21.7/scripts/genksyms/parse.y
-===================================================================
---- linux-2.6.21.7.orig/scripts/genksyms/parse.y
-+++ linux-2.6.21.7/scripts/genksyms/parse.y
-@@ -24,7 +24,9 @@
- %{
-
- #include <assert.h>
-+#ifndef __APPLE__
- #include <malloc.h>
-+#endif
- #include "genksyms.h"
-
- static int is_typedef;
-Index: linux-2.6.21.7/scripts/kallsyms.c
-===================================================================
---- linux-2.6.21.7.orig/scripts/kallsyms.c
-+++ linux-2.6.21.7/scripts/kallsyms.c
-@@ -30,6 +30,35 @@
- #include <stdlib.h>
- #include <string.h>
- #include <ctype.h>
-+#ifdef __APPLE__
-+/* Darwin has no memmem implementation, this one is ripped of the uClibc-0.9.28 source */
-+void *memmem (const void *haystack, size_t haystack_len,
-+ const void *needle, size_t needle_len)
-+{
-+ const char *begin;
-+ const char *const last_possible
-+ = (const char *) haystack + haystack_len - needle_len;
-+
-+ if (needle_len == 0)
-+ /* The first occurrence of the empty string is deemed to occur at
-+ the beginning of the string. */
-+ return (void *) haystack;
-+
-+ /* Sanity check, otherwise the loop might search through the whole
-+ memory. */
-+ if (__builtin_expect (haystack_len < needle_len, 0))
-+ return NULL;
-+
-+ for (begin = (const char *) haystack; begin <= last_possible; ++begin)
-+ if (begin[0] == ((const char *) needle)[0] &&
-+ !memcmp ((const void *) &begin[1],
-+ (const void *) ((const char *) needle + 1),
-+ needle_len - 1))
-+ return (void *) begin;
-+
-+ return NULL;
-+}
-+#endif
-
- #define KSYM_NAME_LEN 127
-
-Index: linux-2.6.21.7/scripts/kconfig/Makefile
-===================================================================
---- linux-2.6.21.7.orig/scripts/kconfig/Makefile
-+++ linux-2.6.21.7/scripts/kconfig/Makefile
-@@ -87,6 +87,9 @@ check-lxdialog := $(srctree)/$(src)/lxd
- # we really need to do so. (Do not call gcc as part of make mrproper)
- HOST_EXTRACFLAGS = $(shell $(CONFIG_SHELL) $(check-lxdialog) -ccflags)
- HOST_LOADLIBES = $(shell $(CONFIG_SHELL) $(check-lxdialog) -ldflags $(HOSTCC))
-+ifeq ($(shell uname -s),Darwin)
-+HOST_LOADLIBES += -lncurses
-+endif
-
- HOST_EXTRACFLAGS += -DLOCALE
-
-Index: linux-2.6.21.7/scripts/mod/file2alias.c
-===================================================================
---- linux-2.6.21.7.orig/scripts/mod/file2alias.c
-+++ linux-2.6.21.7/scripts/mod/file2alias.c
-@@ -37,7 +37,21 @@ typedef unsigned char __u8;
- * even potentially has different endianness and word sizes, since
- * we handle those differences explicitly below */
- #include "../../include/linux/mod_devicetable.h"
-+#ifndef __APPLE__
- #include "../../include/linux/input.h"
-+#else
-+#define EV_MAX 0x1f
-+#define KEY_MUTE 113
-+#define KEY_MIN_INTERESTING KEY_MUTE
-+#define KEY_MAX 0x1ff
-+#define REL_MAX 0x0f
-+#define ABS_MAX 0x3f
-+#define MSC_MAX 0x07
-+#define LED_MAX 0x0f
-+#define SND_MAX 0x07
-+#define FF_MAX 0x7f
-+#define SW_MAX 0x0f
-+#endif
-
- #define ADD(str, sep, cond, field) \
- do { \
-Index: linux-2.6.21.7/scripts/mod/mk_elfconfig.c
-===================================================================
---- linux-2.6.21.7.orig/scripts/mod/mk_elfconfig.c
-+++ linux-2.6.21.7/scripts/mod/mk_elfconfig.c
-@@ -1,7 +1,11 @@
- #include <stdio.h>
- #include <stdlib.h>
- #include <string.h>
-+#ifndef __APPLE__
- #include <elf.h>
-+#else
-+#include "../../../../../tools/sstrip/include/elf.h"
-+#endif
-
- int
- main(int argc, char **argv)
-Index: linux-2.6.21.7/scripts/mod/modpost.h
-===================================================================
---- linux-2.6.21.7.orig/scripts/mod/modpost.h
-+++ linux-2.6.21.7/scripts/mod/modpost.h
-@@ -7,7 +7,11 @@
- #include <sys/mman.h>
- #include <fcntl.h>
- #include <unistd.h>
-+#ifndef __APPLE__
- #include <elf.h>
-+#else
-+#include "../../../../../tools/sstrip/include/elf.h"
-+#endif
-
- #include "elfconfig.h"
-
-Index: linux-2.6.21.7/scripts/mod/sumversion.c
-===================================================================
---- linux-2.6.21.7.orig/scripts/mod/sumversion.c
-+++ linux-2.6.21.7/scripts/mod/sumversion.c
-@@ -8,6 +8,9 @@
- #include <errno.h>
- #include <string.h>
- #include "modpost.h"
-+#ifdef __APPLE__
-+#include <limits.h>
-+#endif
-
- /*
- * Stolen form Cryptographic API.