aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic-2.6/patches-2.6.35/660-phy_mvswitch.patch
diff options
context:
space:
mode:
authorAlexandros C. Couloumbis <alex@ozo.com>2010-06-07 05:56:49 +0000
committerAlexandros C. Couloumbis <alex@ozo.com>2010-06-07 05:56:49 +0000
commit4503e77b0d53f912cbf9b32a14df71f61a9b1609 (patch)
tree14fd49a64056b8b9c39a14b92e06242d7801bc45 /target/linux/generic-2.6/patches-2.6.35/660-phy_mvswitch.patch
parenta2225b8b293cd71d420b96d46c88ad612f3637be (diff)
downloadupstream-4503e77b0d53f912cbf9b32a14df71f61a9b1609.tar.gz
upstream-4503e77b0d53f912cbf9b32a14df71f61a9b1609.tar.bz2
upstream-4503e77b0d53f912cbf9b32a14df71f61a9b1609.zip
generic-2.6: add kernel 2.6.35 preliminary support (patches)
SVN-Revision: 21696
Diffstat (limited to 'target/linux/generic-2.6/patches-2.6.35/660-phy_mvswitch.patch')
-rw-r--r--target/linux/generic-2.6/patches-2.6.35/660-phy_mvswitch.patch22
1 files changed, 22 insertions, 0 deletions
diff --git a/target/linux/generic-2.6/patches-2.6.35/660-phy_mvswitch.patch b/target/linux/generic-2.6/patches-2.6.35/660-phy_mvswitch.patch
new file mode 100644
index 0000000000..f5ff558b0f
--- /dev/null
+++ b/target/linux/generic-2.6/patches-2.6.35/660-phy_mvswitch.patch
@@ -0,0 +1,22 @@
+--- a/drivers/net/phy/Kconfig
++++ b/drivers/net/phy/Kconfig
+@@ -104,6 +104,9 @@ config ADM6996_PHY
+ ---help---
+ Currently supports the ADM6996F switch
+
++config MVSWITCH_PHY
++ tristate "Driver for Marvell 88E6060 switches"
++
+ config FIXED_PHY
+ bool "Driver for MDIO Bus/PHY emulation with fixed speed/link PHYs"
+ depends on PHYLIB=y
+--- a/drivers/net/phy/Makefile
++++ b/drivers/net/phy/Makefile
+@@ -15,6 +15,7 @@ obj-$(CONFIG_BROADCOM_PHY) += broadcom.o
+ obj-$(CONFIG_BCM63XX_PHY) += bcm63xx.o
+ obj-$(CONFIG_ICPLUS_PHY) += icplus.o
+ obj-$(CONFIG_ADM6996_PHY) += adm6996.o
++obj-$(CONFIG_MVSWITCH_PHY) += mvswitch.o
+ obj-$(CONFIG_REALTEK_PHY) += realtek.o
+ obj-$(CONFIG_LSI_ET1011C_PHY) += et1011c.o
+ obj-$(CONFIG_FIXED_PHY) += fixed.o