aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic-2.6/patches-2.6.35/012-extra_optimization.patch
diff options
context:
space:
mode:
authorAlexandros C. Couloumbis <alex@ozo.com>2010-06-07 05:56:49 +0000
committerAlexandros C. Couloumbis <alex@ozo.com>2010-06-07 05:56:49 +0000
commit4503e77b0d53f912cbf9b32a14df71f61a9b1609 (patch)
tree14fd49a64056b8b9c39a14b92e06242d7801bc45 /target/linux/generic-2.6/patches-2.6.35/012-extra_optimization.patch
parenta2225b8b293cd71d420b96d46c88ad612f3637be (diff)
downloadupstream-4503e77b0d53f912cbf9b32a14df71f61a9b1609.tar.gz
upstream-4503e77b0d53f912cbf9b32a14df71f61a9b1609.tar.bz2
upstream-4503e77b0d53f912cbf9b32a14df71f61a9b1609.zip
generic-2.6: add kernel 2.6.35 preliminary support (patches)
SVN-Revision: 21696
Diffstat (limited to 'target/linux/generic-2.6/patches-2.6.35/012-extra_optimization.patch')
-rw-r--r--target/linux/generic-2.6/patches-2.6.35/012-extra_optimization.patch21
1 files changed, 21 insertions, 0 deletions
diff --git a/target/linux/generic-2.6/patches-2.6.35/012-extra_optimization.patch b/target/linux/generic-2.6/patches-2.6.35/012-extra_optimization.patch
new file mode 100644
index 0000000000..0b5174cbbd
--- /dev/null
+++ b/target/linux/generic-2.6/patches-2.6.35/012-extra_optimization.patch
@@ -0,0 +1,21 @@
+--- a/Makefile
++++ b/Makefile
+@@ -529,7 +529,7 @@ all: vmlinux
+ ifdef CONFIG_CC_OPTIMIZE_FOR_SIZE
+ KBUILD_CFLAGS += -Os
+ else
+-KBUILD_CFLAGS += -O2
++KBUILD_CFLAGS += -O2 -fno-reorder-blocks -fno-tree-ch
+ endif
+
+ include $(srctree)/arch/$(SRCARCH)/Makefile
+@@ -567,6 +567,9 @@ endif
+ NOSTDINC_FLAGS += -nostdinc -isystem $(shell $(CC) -print-file-name=include)
+ CHECKFLAGS += $(NOSTDINC_FLAGS)
+
++# improve gcc optimization
++CFLAGS += $(call cc-option,-funit-at-a-time,)
++
+ # warn about C99 declaration after statement
+ KBUILD_CFLAGS += $(call cc-option,-Wdeclaration-after-statement,)
+