aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic-2.6/patches-2.6.34/921-gpio_spi_driver.patch
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@openwrt.org>2010-04-18 18:35:47 +0000
committerHauke Mehrtens <hauke@openwrt.org>2010-04-18 18:35:47 +0000
commitbef7d3cd16f55a817b810454500ca06ab8eb57b2 (patch)
treec752890e176316502ae064e00342c64d54ffc8c8 /target/linux/generic-2.6/patches-2.6.34/921-gpio_spi_driver.patch
parent7905b3032af87a2cf2d7907af16a455d33a80887 (diff)
downloadupstream-bef7d3cd16f55a817b810454500ca06ab8eb57b2.tar.gz
upstream-bef7d3cd16f55a817b810454500ca06ab8eb57b2.tar.bz2
upstream-bef7d3cd16f55a817b810454500ca06ab8eb57b2.zip
kernel: refresh patches with 2.6.34-rc4
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@20999 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/generic-2.6/patches-2.6.34/921-gpio_spi_driver.patch')
-rw-r--r--target/linux/generic-2.6/patches-2.6.34/921-gpio_spi_driver.patch6
1 files changed, 3 insertions, 3 deletions
diff --git a/target/linux/generic-2.6/patches-2.6.34/921-gpio_spi_driver.patch b/target/linux/generic-2.6/patches-2.6.34/921-gpio_spi_driver.patch
index c37bb2280f..65f17b49eb 100644
--- a/target/linux/generic-2.6/patches-2.6.34/921-gpio_spi_driver.patch
+++ b/target/linux/generic-2.6/patches-2.6.34/921-gpio_spi_driver.patch
@@ -338,7 +338,7 @@ Please use the new mainline SPI-GPIO driver, as of 2.6.29.
+MODULE_LICENSE("GPL v2");
--- a/drivers/spi/Kconfig
+++ b/drivers/spi/Kconfig
-@@ -116,6 +116,15 @@ config SPI_GPIO
+@@ -133,6 +133,15 @@ config SPI_GPIO
GPIO operations, you should be able to leverage that for better
speed with a custom version of this driver; see the source code.
@@ -356,9 +356,9 @@ Please use the new mainline SPI-GPIO driver, as of 2.6.29.
depends on ARCH_MXC
--- a/drivers/spi/Makefile
+++ b/drivers/spi/Makefile
-@@ -19,6 +19,7 @@ obj-$(CONFIG_SPI_BUTTERFLY) += spi_butt
- obj-$(CONFIG_SPI_DESIGNWARE) += dw_spi.o
+@@ -22,6 +22,7 @@ obj-$(CONFIG_SPI_DESIGNWARE) += dw_spi.
obj-$(CONFIG_SPI_DW_PCI) += dw_spi_pci.o
+ obj-$(CONFIG_SPI_DW_MMIO) += dw_spi_mmio.o
obj-$(CONFIG_SPI_GPIO) += spi_gpio.o
+obj-$(CONFIG_SPI_GPIO_OLD) += spi_gpio_old.o
obj-$(CONFIG_SPI_IMX) += spi_imx.o