aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic-2.6/patches-2.6.34/100-netfilter_layer7_2.21.patch
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@openwrt.org>2010-04-18 18:35:47 +0000
committerHauke Mehrtens <hauke@openwrt.org>2010-04-18 18:35:47 +0000
commitbef7d3cd16f55a817b810454500ca06ab8eb57b2 (patch)
treec752890e176316502ae064e00342c64d54ffc8c8 /target/linux/generic-2.6/patches-2.6.34/100-netfilter_layer7_2.21.patch
parent7905b3032af87a2cf2d7907af16a455d33a80887 (diff)
downloadupstream-bef7d3cd16f55a817b810454500ca06ab8eb57b2.tar.gz
upstream-bef7d3cd16f55a817b810454500ca06ab8eb57b2.tar.bz2
upstream-bef7d3cd16f55a817b810454500ca06ab8eb57b2.zip
kernel: refresh patches with 2.6.34-rc4
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@20999 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/generic-2.6/patches-2.6.34/100-netfilter_layer7_2.21.patch')
-rw-r--r--target/linux/generic-2.6/patches-2.6.34/100-netfilter_layer7_2.21.patch8
1 files changed, 4 insertions, 4 deletions
diff --git a/target/linux/generic-2.6/patches-2.6.34/100-netfilter_layer7_2.21.patch b/target/linux/generic-2.6/patches-2.6.34/100-netfilter_layer7_2.21.patch
index be7d97fe12..ce8853396a 100644
--- a/target/linux/generic-2.6/patches-2.6.34/100-netfilter_layer7_2.21.patch
+++ b/target/linux/generic-2.6/patches-2.6.34/100-netfilter_layer7_2.21.patch
@@ -41,7 +41,7 @@
--- a/net/netfilter/Kconfig
+++ b/net/netfilter/Kconfig
-@@ -858,6 +858,27 @@ config NETFILTER_XT_MATCH_STATE
+@@ -883,6 +883,27 @@ config NETFILTER_XT_MATCH_STATE
To compile it as a module, choose M here. If unsure, say N.
@@ -71,7 +71,7 @@
depends on NETFILTER_ADVANCED
--- a/net/netfilter/Makefile
+++ b/net/netfilter/Makefile
-@@ -89,6 +89,7 @@ obj-$(CONFIG_NETFILTER_XT_MATCH_RECENT)
+@@ -90,6 +90,7 @@ obj-$(CONFIG_NETFILTER_XT_MATCH_RECENT)
obj-$(CONFIG_NETFILTER_XT_MATCH_SCTP) += xt_sctp.o
obj-$(CONFIG_NETFILTER_XT_MATCH_SOCKET) += xt_socket.o
obj-$(CONFIG_NETFILTER_XT_MATCH_STATE) += xt_state.o
@@ -81,7 +81,7 @@
obj-$(CONFIG_NETFILTER_XT_MATCH_TCPMSS) += xt_tcpmss.o
--- a/net/netfilter/nf_conntrack_core.c
+++ b/net/netfilter/nf_conntrack_core.c
-@@ -201,6 +201,14 @@ destroy_conntrack(struct nf_conntrack *n
+@@ -202,6 +202,14 @@ destroy_conntrack(struct nf_conntrack *n
* too. */
nf_ct_remove_expectations(ct);
@@ -98,7 +98,7 @@
BUG_ON(hlist_nulls_unhashed(&ct->tuplehash[IP_CT_DIR_ORIGINAL].hnnode));
--- a/net/netfilter/nf_conntrack_standalone.c
+++ b/net/netfilter/nf_conntrack_standalone.c
-@@ -171,6 +171,12 @@ static int ct_seq_show(struct seq_file *
+@@ -178,6 +178,12 @@ static int ct_seq_show(struct seq_file *
goto release;
#endif