aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic-2.6/patches-2.6.33/012-extra_optimization.patch
diff options
context:
space:
mode:
authorMatteo Croce <matteo@openwrt.org>2010-02-28 15:20:00 +0000
committerMatteo Croce <matteo@openwrt.org>2010-02-28 15:20:00 +0000
commit7cce85a44a0cdf826c5f1850c0465e51c6b346a2 (patch)
treec49ac1a86a7262dd17d7b4c0af3c151c37338619 /target/linux/generic-2.6/patches-2.6.33/012-extra_optimization.patch
parent4c71989564cb66bffc1cd9f075f0c776282b61e4 (diff)
downloadupstream-7cce85a44a0cdf826c5f1850c0465e51c6b346a2.tar.gz
upstream-7cce85a44a0cdf826c5f1850c0465e51c6b346a2.tar.bz2
upstream-7cce85a44a0cdf826c5f1850c0465e51c6b346a2.zip
kernel: add 2.6.33 patches
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@19905 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/generic-2.6/patches-2.6.33/012-extra_optimization.patch')
-rw-r--r--target/linux/generic-2.6/patches-2.6.33/012-extra_optimization.patch21
1 files changed, 21 insertions, 0 deletions
diff --git a/target/linux/generic-2.6/patches-2.6.33/012-extra_optimization.patch b/target/linux/generic-2.6/patches-2.6.33/012-extra_optimization.patch
new file mode 100644
index 0000000000..0b5174cbbd
--- /dev/null
+++ b/target/linux/generic-2.6/patches-2.6.33/012-extra_optimization.patch
@@ -0,0 +1,21 @@
+--- a/Makefile
++++ b/Makefile
+@@ -529,7 +529,7 @@ all: vmlinux
+ ifdef CONFIG_CC_OPTIMIZE_FOR_SIZE
+ KBUILD_CFLAGS += -Os
+ else
+-KBUILD_CFLAGS += -O2
++KBUILD_CFLAGS += -O2 -fno-reorder-blocks -fno-tree-ch
+ endif
+
+ include $(srctree)/arch/$(SRCARCH)/Makefile
+@@ -567,6 +567,9 @@ endif
+ NOSTDINC_FLAGS += -nostdinc -isystem $(shell $(CC) -print-file-name=include)
+ CHECKFLAGS += $(NOSTDINC_FLAGS)
+
++# improve gcc optimization
++CFLAGS += $(call cc-option,-funit-at-a-time,)
++
+ # warn about C99 declaration after statement
+ KBUILD_CFLAGS += $(call cc-option,-Wdeclaration-after-statement,)
+