aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic-2.6/patches-2.6.31
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2010-01-25 15:13:38 +0000
committerGabor Juhos <juhosg@openwrt.org>2010-01-25 15:13:38 +0000
commit49c4df54876253b4f3c3d74f788c947c4982bc4c (patch)
treedb8df3176012b2fed18e120d665e02bc5ef4bba1 /target/linux/generic-2.6/patches-2.6.31
parentaa196516d5d51cef19f4ccd5f8c68c028b14eb8f (diff)
downloadupstream-49c4df54876253b4f3c3d74f788c947c4982bc4c.tar.gz
upstream-49c4df54876253b4f3c3d74f788c947c4982bc4c.tar.bz2
upstream-49c4df54876253b4f3c3d74f788c947c4982bc4c.zip
rtl8366: make it available on all platforms
SVN-Revision: 19329
Diffstat (limited to 'target/linux/generic-2.6/patches-2.6.31')
-rw-r--r--target/linux/generic-2.6/patches-2.6.31/691-phy_rtl8366.patch39
1 files changed, 39 insertions, 0 deletions
diff --git a/target/linux/generic-2.6/patches-2.6.31/691-phy_rtl8366.patch b/target/linux/generic-2.6/patches-2.6.31/691-phy_rtl8366.patch
new file mode 100644
index 0000000000..6223f00fe7
--- /dev/null
+++ b/target/linux/generic-2.6/patches-2.6.31/691-phy_rtl8366.patch
@@ -0,0 +1,39 @@
+--- a/drivers/net/phy/Kconfig
++++ b/drivers/net/phy/Kconfig
+@@ -135,4 +135,25 @@ config MDIO_GPIO
+ To compile this driver as a module, choose M here: the module
+ will be called mdio-gpio.
+
++config RTL8366_SMI
++ tristate "Driver for the RTL8366 SMI interface"
++ depends on GENERIC_GPIO
++ ---help---
++ This module implements the SMI interface protocol which is used
++ by some RTL8366 ethernet switch devices via the generic GPIO API.
++
++if RTL8366_SMI
++
++config RTL8366S_PHY
++ tristate "Driver for the Realtek RTL8366S switch"
++ select SWCONFIG
++
++config RTL8366S_PHY_DEBUG_FS
++ bool "RTL8366S switch driver DEBUG_FS support"
++ depends on RTL8366S_PHY
++ depends on DEBUG_FS
++ default n
++
++endif # RTL8366_SMI
++
+ endif # PHYLIB
+--- a/drivers/net/phy/Makefile
++++ b/drivers/net/phy/Makefile
+@@ -19,6 +19,8 @@ obj-$(CONFIG_IP175C_PHY) += ip175c.o
+ obj-$(CONFIG_REALTEK_PHY) += realtek.o
+ obj-$(CONFIG_AR8216_PHY) += ar8216.o
+ obj-$(CONFIG_RTL8306_PHY) += rtl8306.o
++obj-$(CONFIG_RTL8366_SMI) += rtl8366_smi.o
++obj-$(CONFIG_RTL8366S_PHY) += rtl8366s.o
+ obj-$(CONFIG_LSI_ET1011C_PHY) += et1011c.o
+ obj-$(CONFIG_FIXED_PHY) += fixed.o
+ obj-$(CONFIG_MDIO_BITBANG) += mdio-bitbang.o