aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic-2.6/patches-2.6.31/690-phy_rtl8306.patch
diff options
context:
space:
mode:
authorMirko Vogt <mirko@openwrt.org>2009-08-22 12:46:12 +0000
committerMirko Vogt <mirko@openwrt.org>2009-08-22 12:46:12 +0000
commit6e2a58ac3bdec3315fd9934cf46746143243594f (patch)
tree2e86c133fcec02de817a54513c897f0580600950 /target/linux/generic-2.6/patches-2.6.31/690-phy_rtl8306.patch
parent75ee3370d9bedff6be7a12431ceef5606252e90a (diff)
downloadupstream-6e2a58ac3bdec3315fd9934cf46746143243594f.tar.gz
upstream-6e2a58ac3bdec3315fd9934cf46746143243594f.tar.bz2
upstream-6e2a58ac3bdec3315fd9934cf46746143243594f.zip
add generic patchset levelled up to 2.6.31-rc6
SVN-Revision: 17351
Diffstat (limited to 'target/linux/generic-2.6/patches-2.6.31/690-phy_rtl8306.patch')
-rw-r--r--target/linux/generic-2.6/patches-2.6.31/690-phy_rtl8306.patch23
1 files changed, 23 insertions, 0 deletions
diff --git a/target/linux/generic-2.6/patches-2.6.31/690-phy_rtl8306.patch b/target/linux/generic-2.6/patches-2.6.31/690-phy_rtl8306.patch
new file mode 100644
index 0000000000..bfebbcff51
--- /dev/null
+++ b/target/linux/generic-2.6/patches-2.6.31/690-phy_rtl8306.patch
@@ -0,0 +1,23 @@
+--- a/drivers/net/phy/Kconfig
++++ b/drivers/net/phy/Kconfig
+@@ -104,6 +104,10 @@ config AR8216_PHY
+ tristate "Driver for Atheros AR8216 switches"
+ select SWCONFIG
+
++config RTL8306_PHY
++ tristate "Driver for Realtek RTL8306S switches"
++ select SWCONFIG
++
+ config FIXED_PHY
+ bool "Driver for MDIO Bus/PHY emulation with fixed speed/link PHYs"
+ depends on PHYLIB=y
+--- a/drivers/net/phy/Makefile
++++ b/drivers/net/phy/Makefile
+@@ -18,6 +18,7 @@ obj-$(CONFIG_MVSWITCH_PHY) += mvswitch.o
+ obj-$(CONFIG_IP175C_PHY) += ip175c.o
+ obj-$(CONFIG_REALTEK_PHY) += realtek.o
+ obj-$(CONFIG_AR8216_PHY) += ar8216.o
++obj-$(CONFIG_RTL8306_PHY) += rtl8306.o
+ obj-$(CONFIG_LSI_ET1011C_PHY) += et1011c.o
+ obj-$(CONFIG_FIXED_PHY) += fixed.o
+ obj-$(CONFIG_MDIO_BITBANG) += mdio-bitbang.o