aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic-2.6/patches-2.6.29/970-ocf_kbuild_integration.patch
diff options
context:
space:
mode:
authorHamish Guthrie <hcg@openwrt.org>2009-05-28 10:00:48 +0000
committerHamish Guthrie <hcg@openwrt.org>2009-05-28 10:00:48 +0000
commit9a3d875aac7e3011bb4cceb9f70c1d4fe65fd69a (patch)
tree6527b3196b8418cb3359748a798c79644d18faf8 /target/linux/generic-2.6/patches-2.6.29/970-ocf_kbuild_integration.patch
parent2c8109cadb574dc5db1b912a708933f1ff3baf56 (diff)
downloadupstream-9a3d875aac7e3011bb4cceb9f70c1d4fe65fd69a.tar.gz
upstream-9a3d875aac7e3011bb4cceb9f70c1d4fe65fd69a.tar.bz2
upstream-9a3d875aac7e3011bb4cceb9f70c1d4fe65fd69a.zip
[kernel] revert 15922 - add back 2.6.29 kernel support
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@16127 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/generic-2.6/patches-2.6.29/970-ocf_kbuild_integration.patch')
-rw-r--r--target/linux/generic-2.6/patches-2.6.29/970-ocf_kbuild_integration.patch25
1 files changed, 25 insertions, 0 deletions
diff --git a/target/linux/generic-2.6/patches-2.6.29/970-ocf_kbuild_integration.patch b/target/linux/generic-2.6/patches-2.6.29/970-ocf_kbuild_integration.patch
new file mode 100644
index 0000000000..e994ff713c
--- /dev/null
+++ b/target/linux/generic-2.6/patches-2.6.29/970-ocf_kbuild_integration.patch
@@ -0,0 +1,25 @@
+--- a/crypto/Kconfig
++++ b/crypto/Kconfig
+@@ -734,6 +734,8 @@ config CRYPTO_ANSI_CPRNG
+ for cryptographic modules. Uses the Algorithm specified in
+ ANSI X9.31 A.2.4
+
++source "crypto/ocf/Kconfig"
++
+ source "drivers/crypto/Kconfig"
+
+ endif # if CRYPTO
+--- a/crypto/Makefile
++++ b/crypto/Makefile
+@@ -80,6 +80,11 @@ obj-$(CONFIG_CRYPTO_ANSI_CPRNG) += ansi_
+ obj-$(CONFIG_CRYPTO_TEST) += tcrypt.o
+
+ #
++# OCF
++#
++obj-$(CONFIG_OCF_OCF) += ocf/
++
++#
+ # generic algorithms and the async_tx api
+ #
+ obj-$(CONFIG_XOR_BLOCKS) += xor.o