aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic-2.6/patches-2.6.28/620-phy_adm6996.patch
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2008-12-08 13:23:09 +0000
committerImre Kaloz <kaloz@openwrt.org>2008-12-08 13:23:09 +0000
commitf21f51d858ab97a4784f76481c336613abc127f6 (patch)
treee1d1a3380f15b3a411c3eeffb9adea9f6f82628b /target/linux/generic-2.6/patches-2.6.28/620-phy_adm6996.patch
parent206ccdf4ae2f236a752950a701bb3eacbdaf2cc8 (diff)
downloadupstream-f21f51d858ab97a4784f76481c336613abc127f6.tar.gz
upstream-f21f51d858ab97a4784f76481c336613abc127f6.tar.bz2
upstream-f21f51d858ab97a4784f76481c336613abc127f6.zip
add generic 2.6.28 patches
SVN-Revision: 13546
Diffstat (limited to 'target/linux/generic-2.6/patches-2.6.28/620-phy_adm6996.patch')
-rw-r--r--target/linux/generic-2.6/patches-2.6.28/620-phy_adm6996.patch24
1 files changed, 24 insertions, 0 deletions
diff --git a/target/linux/generic-2.6/patches-2.6.28/620-phy_adm6996.patch b/target/linux/generic-2.6/patches-2.6.28/620-phy_adm6996.patch
new file mode 100644
index 0000000000..7c98a0f51f
--- /dev/null
+++ b/target/linux/generic-2.6/patches-2.6.28/620-phy_adm6996.patch
@@ -0,0 +1,24 @@
+--- a/drivers/net/phy/Kconfig
++++ b/drivers/net/phy/Kconfig
+@@ -66,6 +66,11 @@ config REALTEK_PHY
+ ---help---
+ Supports the Realtek 821x PHY.
+
++config ADM6996_PHY
++ tristate "Driver for ADM6996 switches"
++ ---help---
++ Currently supports the ADM6996F switch
++
+ config FIXED_PHY
+ bool "Driver for MDIO Bus/PHY emulation with fixed speed/link PHYs"
+ depends on PHYLIB=y
+--- a/drivers/net/phy/Makefile
++++ b/drivers/net/phy/Makefile
+@@ -12,6 +12,7 @@ obj-$(CONFIG_SMSC_PHY) += smsc.o
+ obj-$(CONFIG_VITESSE_PHY) += vitesse.o
+ obj-$(CONFIG_BROADCOM_PHY) += broadcom.o
+ obj-$(CONFIG_ICPLUS_PHY) += icplus.o
++obj-$(CONFIG_ADM6996_PHY) += adm6996.o
+ obj-$(CONFIG_REALTEK_PHY) += realtek.o
+ obj-$(CONFIG_FIXED_PHY) += fixed.o
+ obj-$(CONFIG_MDIO_BITBANG) += mdio-bitbang.o