aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic-2.6/patches-2.6.28/420-gpiodev.patch
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2008-12-08 13:23:09 +0000
committerImre Kaloz <kaloz@openwrt.org>2008-12-08 13:23:09 +0000
commite5206f9754e62fdbdb54d1998e74cf0d921359f6 (patch)
tree0cb3e4ccf62f00cbc257d6b2d4156e02c342b551 /target/linux/generic-2.6/patches-2.6.28/420-gpiodev.patch
parentdf84ce6c3a2f713403d8cc3cb679d4619302464c (diff)
downloadupstream-e5206f9754e62fdbdb54d1998e74cf0d921359f6.tar.gz
upstream-e5206f9754e62fdbdb54d1998e74cf0d921359f6.tar.bz2
upstream-e5206f9754e62fdbdb54d1998e74cf0d921359f6.zip
add generic 2.6.28 patches
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@13546 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/generic-2.6/patches-2.6.28/420-gpiodev.patch')
-rw-r--r--target/linux/generic-2.6/patches-2.6.28/420-gpiodev.patch26
1 files changed, 26 insertions, 0 deletions
diff --git a/target/linux/generic-2.6/patches-2.6.28/420-gpiodev.patch b/target/linux/generic-2.6/patches-2.6.28/420-gpiodev.patch
new file mode 100644
index 0000000000..c7b665a67a
--- /dev/null
+++ b/target/linux/generic-2.6/patches-2.6.28/420-gpiodev.patch
@@ -0,0 +1,26 @@
+--- a/drivers/char/Kconfig
++++ b/drivers/char/Kconfig
+@@ -988,6 +988,13 @@ config CS5535_GPIO
+
+ If compiled as a module, it will be called cs5535_gpio.
+
++config GPIO_DEVICE
++ tristate "GPIO device support"
++ depends on GENERIC_GPIO
++ help
++ Say Y to enable Linux GPIO device support. This allows control of
++ GPIO pins using a character device
++
+ config GPIO_VR41XX
+ tristate "NEC VR4100 series General-purpose I/O Unit support"
+ depends on CPU_VR41XX
+--- a/drivers/char/Makefile
++++ b/drivers/char/Makefile
+@@ -92,6 +92,7 @@ obj-$(CONFIG_SCx200_GPIO) += scx200_gpio
+ obj-$(CONFIG_PC8736x_GPIO) += pc8736x_gpio.o
+ obj-$(CONFIG_NSC_GPIO) += nsc_gpio.o
+ obj-$(CONFIG_CS5535_GPIO) += cs5535_gpio.o
++obj-$(CONFIG_GPIO_DEVICE) += gpio_dev.o
+ obj-$(CONFIG_GPIO_VR41XX) += vr41xx_giu.o
+ obj-$(CONFIG_GPIO_TB0219) += tb0219.o
+ obj-$(CONFIG_TELCLOCK) += tlclk.o