aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic-2.6/patches-2.6.27/400-ledtrig_morse.patch
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2008-09-29 01:08:17 +0000
committerFelix Fietkau <nbd@openwrt.org>2008-09-29 01:08:17 +0000
commit15f17fcf7e6d0430b701f34b8db63435754d2e45 (patch)
treecd04d6e88ffc7cca75a9ad1040caa9417253b4f7 /target/linux/generic-2.6/patches-2.6.27/400-ledtrig_morse.patch
parent9d792824bce6ddd5aed83ec1a384da204db30f1a (diff)
downloadupstream-15f17fcf7e6d0430b701f34b8db63435754d2e45.tar.gz
upstream-15f17fcf7e6d0430b701f34b8db63435754d2e45.tar.bz2
upstream-15f17fcf7e6d0430b701f34b8db63435754d2e45.zip
port generic and ixp4xx kernel patches to 2.6.27 (compiles except for iptables, but otherwise completely untested)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@12790 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/generic-2.6/patches-2.6.27/400-ledtrig_morse.patch')
-rw-r--r--target/linux/generic-2.6/patches-2.6.27/400-ledtrig_morse.patch18
1 files changed, 18 insertions, 0 deletions
diff --git a/target/linux/generic-2.6/patches-2.6.27/400-ledtrig_morse.patch b/target/linux/generic-2.6/patches-2.6.27/400-ledtrig_morse.patch
new file mode 100644
index 0000000000..b0a3b2a68f
--- /dev/null
+++ b/target/linux/generic-2.6/patches-2.6.27/400-ledtrig_morse.patch
@@ -0,0 +1,18 @@
+--- a/drivers/leds/Kconfig
++++ b/drivers/leds/Kconfig
+@@ -206,4 +206,8 @@
+ This allows LEDs to be initialised in the ON state.
+ If unsure, say Y.
+
++config LEDS_TRIGGER_MORSE
++ tristate "LED Morse Trigger"
++ depends on LEDS_TRIGGERS
++
+ endif # NEW_LEDS
+--- a/drivers/leds/Makefile
++++ b/drivers/leds/Makefile
+@@ -29,3 +29,4 @@
+ obj-$(CONFIG_LEDS_TRIGGER_IDE_DISK) += ledtrig-ide-disk.o
+ obj-$(CONFIG_LEDS_TRIGGER_HEARTBEAT) += ledtrig-heartbeat.o
+ obj-$(CONFIG_LEDS_TRIGGER_DEFAULT_ON) += ledtrig-default-on.o
++obj-$(CONFIG_LEDS_TRIGGER_MORSE) += ledtrig-morse.o