aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic-2.6/patches-2.6.26
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2008-08-04 14:05:04 +0000
committerJohn Crispin <blogic@openwrt.org>2008-08-04 14:05:04 +0000
commitc85677ecc1327515780b8dac25ea3b7dc9c305af (patch)
tree0dcc2606f148db3a5c0305877a6c072348129b4b /target/linux/generic-2.6/patches-2.6.26
parent275038cae7e3e363c1e0062d0639749178659a8b (diff)
downloadupstream-c85677ecc1327515780b8dac25ea3b7dc9c305af.tar.gz
upstream-c85677ecc1327515780b8dac25ea3b7dc9c305af.tar.bz2
upstream-c85677ecc1327515780b8dac25ea3b7dc9c305af.zip
makes ledtrignetdev work on .26 and fix whitespaces
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@12090 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/generic-2.6/patches-2.6.26')
-rw-r--r--target/linux/generic-2.6/patches-2.6.26/402-ledtrig_netdev.patch25
1 files changed, 25 insertions, 0 deletions
diff --git a/target/linux/generic-2.6/patches-2.6.26/402-ledtrig_netdev.patch b/target/linux/generic-2.6/patches-2.6.26/402-ledtrig_netdev.patch
new file mode 100644
index 0000000000..1dcdad6583
--- /dev/null
+++ b/target/linux/generic-2.6/patches-2.6.26/402-ledtrig_netdev.patch
@@ -0,0 +1,25 @@
+Index: linux-2.6.26/drivers/leds/Kconfig
+===================================================================
+--- linux-2.6.26.orig/drivers/leds/Kconfig 2008-08-04 15:03:44.000000000 +0200
++++ linux-2.6.26/drivers/leds/Kconfig 2008-08-04 15:04:18.000000000 +0200
+@@ -200,4 +200,11 @@
+ tristate "LED Morse Trigger"
+ depends on LEDS_TRIGGERS
+
++config LEDS_TRIGGER_NETDEV
++ tristate "LED Netdev Trigger"
++ depends on LEDS_TRIGGERS
++ help
++ This allows LEDs to be controlled by network device activity.
++ If unsure, say Y.
++
+ endif # NEW_LEDS
+Index: linux-2.6.26/drivers/leds/Makefile
+===================================================================
+--- linux-2.6.26.orig/drivers/leds/Makefile 2008-08-04 15:03:40.000000000 +0200
++++ linux-2.6.26/drivers/leds/Makefile 2008-08-04 15:04:29.000000000 +0200
+@@ -29,3 +29,4 @@
+ obj-$(CONFIG_LEDS_TRIGGER_HEARTBEAT) += ledtrig-heartbeat.o
+ obj-$(CONFIG_LEDS_TRIGGER_DEFAULT_ON) += ledtrig-default-on.o
+ obj-$(CONFIG_LEDS_TRIGGER_MORSE) += ledtrig-morse.o
++obj-$(CONFIG_LEDS_TRIGGER_NETDEV) += ledtrig-netdev.o