aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic-2.6/patches-2.6.26/420-gpiodev.patch
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2008-06-02 08:22:56 +0000
committerImre Kaloz <kaloz@openwrt.org>2008-06-02 08:22:56 +0000
commit7cce2d8fc39a7bbcdcf8755ad331409b0a103103 (patch)
treec5089f65708dd1656748c8079574e68096d53242 /target/linux/generic-2.6/patches-2.6.26/420-gpiodev.patch
parent40720b6d2027e49c59718c3650c93bc6771a38b3 (diff)
downloadupstream-7cce2d8fc39a7bbcdcf8755ad331409b0a103103.tar.gz
upstream-7cce2d8fc39a7bbcdcf8755ad331409b0a103103.tar.bz2
upstream-7cce2d8fc39a7bbcdcf8755ad331409b0a103103.zip
add generic 2.6.26 patches/files
SVN-Revision: 11323
Diffstat (limited to 'target/linux/generic-2.6/patches-2.6.26/420-gpiodev.patch')
-rw-r--r--target/linux/generic-2.6/patches-2.6.26/420-gpiodev.patch26
1 files changed, 26 insertions, 0 deletions
diff --git a/target/linux/generic-2.6/patches-2.6.26/420-gpiodev.patch b/target/linux/generic-2.6/patches-2.6.26/420-gpiodev.patch
new file mode 100644
index 0000000000..5eecc61ae5
--- /dev/null
+++ b/target/linux/generic-2.6/patches-2.6.26/420-gpiodev.patch
@@ -0,0 +1,26 @@
+--- a/drivers/char/Kconfig
++++ b/drivers/char/Kconfig
+@@ -955,6 +955,13 @@
+
+ If compiled as a module, it will be called cs5535_gpio.
+
++config GPIO_DEVICE
++ tristate "GPIO device support"
++ depends on GENERIC_GPIO
++ help
++ Say Y to enable Linux GPIO device support. This allows control of
++ GPIO pins using a character device
++
+ config GPIO_VR41XX
+ tristate "NEC VR4100 series General-purpose I/O Unit support"
+ depends on CPU_VR41XX
+--- a/drivers/char/Makefile
++++ b/drivers/char/Makefile
+@@ -94,6 +94,7 @@
+ obj-$(CONFIG_PC8736x_GPIO) += pc8736x_gpio.o
+ obj-$(CONFIG_NSC_GPIO) += nsc_gpio.o
+ obj-$(CONFIG_CS5535_GPIO) += cs5535_gpio.o
++obj-$(CONFIG_GPIO_DEVICE) += gpio_dev.o
+ obj-$(CONFIG_GPIO_VR41XX) += vr41xx_giu.o
+ obj-$(CONFIG_GPIO_TB0219) += tb0219.o
+ obj-$(CONFIG_TELCLOCK) += tlclk.o