aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic-2.6/patches-2.6.26/410-gpio_buttons.patch
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2008-06-02 08:22:56 +0000
committerImre Kaloz <kaloz@openwrt.org>2008-06-02 08:22:56 +0000
commit7cce2d8fc39a7bbcdcf8755ad331409b0a103103 (patch)
treec5089f65708dd1656748c8079574e68096d53242 /target/linux/generic-2.6/patches-2.6.26/410-gpio_buttons.patch
parent40720b6d2027e49c59718c3650c93bc6771a38b3 (diff)
downloadupstream-7cce2d8fc39a7bbcdcf8755ad331409b0a103103.tar.gz
upstream-7cce2d8fc39a7bbcdcf8755ad331409b0a103103.tar.bz2
upstream-7cce2d8fc39a7bbcdcf8755ad331409b0a103103.zip
add generic 2.6.26 patches/files
SVN-Revision: 11323
Diffstat (limited to 'target/linux/generic-2.6/patches-2.6.26/410-gpio_buttons.patch')
-rw-r--r--target/linux/generic-2.6/patches-2.6.26/410-gpio_buttons.patch30
1 files changed, 30 insertions, 0 deletions
diff --git a/target/linux/generic-2.6/patches-2.6.26/410-gpio_buttons.patch b/target/linux/generic-2.6/patches-2.6.26/410-gpio_buttons.patch
new file mode 100644
index 0000000000..6ae2cd7df5
--- /dev/null
+++ b/target/linux/generic-2.6/patches-2.6.26/410-gpio_buttons.patch
@@ -0,0 +1,30 @@
+--- a/drivers/input/misc/Kconfig
++++ b/drivers/input/misc/Kconfig
+@@ -197,4 +197,20 @@
+ Say Y here if you want to support the built-in real time clock
+ of the HP SDC controller.
+
++config INPUT_GPIO_BUTTONS
++ tristate "Polled GPIO buttons interface"
++ depends on GENERIC_GPIO
++ select INPUT_POLLDEV
++ help
++ This driver implements support for buttons connected
++ to GPIO pins of various CPUs (and some other chips).
++
++ Say Y here if your device has buttons connected
++ directly to such GPIO pins. Your board-specific
++ setup logic must also provide a platform device,
++ with configuration data saying which GPIOs are used.
++
++ To compile this driver as a module, choose M here: the
++ module will be called gpio-buttons.
++
+ endif
+--- a/drivers/input/misc/Makefile
++++ b/drivers/input/misc/Makefile
+@@ -19,3 +19,4 @@
+ obj-$(CONFIG_HP_SDC_RTC) += hp_sdc_rtc.o
+ obj-$(CONFIG_INPUT_UINPUT) += uinput.o
+ obj-$(CONFIG_INPUT_APANEL) += apanel.o
++obj-$(CONFIG_INPUT_GPIO_BUTTONS) += gpio_buttons.o