aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic-2.6/patches-2.6.26/170-netfilter_chaostables_0.8.patch
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2008-11-06 20:55:33 +0000
committerGabor Juhos <juhosg@openwrt.org>2008-11-06 20:55:33 +0000
commitd9d70c2ebb0ad11fc61be3e9bc7148fe2106ab76 (patch)
tree902ba8bee0eeb73fdb63e9402112c8c0ff4fb12f /target/linux/generic-2.6/patches-2.6.26/170-netfilter_chaostables_0.8.patch
parent226d8cb16579aecaaf52228177a795e276bf8f06 (diff)
downloadupstream-d9d70c2ebb0ad11fc61be3e9bc7148fe2106ab76.tar.gz
upstream-d9d70c2ebb0ad11fc61be3e9bc7148fe2106ab76.tar.bz2
upstream-d9d70c2ebb0ad11fc61be3e9bc7148fe2106ab76.zip
[kernel] refresh 2.6.26 patches
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@13135 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/generic-2.6/patches-2.6.26/170-netfilter_chaostables_0.8.patch')
-rw-r--r--target/linux/generic-2.6/patches-2.6.26/170-netfilter_chaostables_0.8.patch12
1 files changed, 6 insertions, 6 deletions
diff --git a/target/linux/generic-2.6/patches-2.6.26/170-netfilter_chaostables_0.8.patch b/target/linux/generic-2.6/patches-2.6.26/170-netfilter_chaostables_0.8.patch
index 9c69385dfb..6357f6df91 100644
--- a/target/linux/generic-2.6/patches-2.6.26/170-netfilter_chaostables_0.8.patch
+++ b/target/linux/generic-2.6/patches-2.6.26/170-netfilter_chaostables_0.8.patch
@@ -95,7 +95,7 @@
+#define xt_request_find_match xt_request_find_match_lo
--- a/net/netfilter/Kconfig
+++ b/net/netfilter/Kconfig
-@@ -288,6 +288,14 @@
+@@ -288,6 +288,14 @@ config NETFILTER_XTABLES
# alphabetically ordered list of targets
@@ -110,7 +110,7 @@
config NETFILTER_XT_TARGET_CLASSIFY
tristate '"CLASSIFY" target support'
depends on NETFILTER_XTABLES
-@@ -317,6 +325,14 @@
+@@ -317,6 +325,14 @@ config NETFILTER_XT_TARGET_CONNMARK
<file:Documentation/kbuild/modules.txt>. The module will be called
ipt_CONNMARK.ko. If unsure, say `N'.
@@ -125,7 +125,7 @@
config NETFILTER_XT_TARGET_DSCP
tristate '"DSCP" and "TOS" target support'
depends on NETFILTER_XTABLES
-@@ -653,6 +669,14 @@
+@@ -653,6 +669,14 @@ config NETFILTER_XT_MATCH_POLICY
To compile it as a module, choose M here. If unsure, say N.
@@ -142,7 +142,7 @@
depends on NETFILTER_XTABLES
--- a/net/netfilter/Makefile
+++ b/net/netfilter/Makefile
-@@ -51,6 +51,8 @@
+@@ -51,6 +51,8 @@ obj-$(CONFIG_NETFILTER_XT_TARGET_SECMARK
obj-$(CONFIG_NETFILTER_XT_TARGET_TCPMSS) += xt_TCPMSS.o
obj-$(CONFIG_NETFILTER_XT_TARGET_TCPOPTSTRIP) += xt_TCPOPTSTRIP.o
obj-$(CONFIG_NETFILTER_XT_TARGET_TRACE) += xt_TRACE.o
@@ -151,7 +151,7 @@
# matches
obj-$(CONFIG_NETFILTER_XT_MATCH_COMMENT) += xt_comment.o
-@@ -84,3 +86,4 @@
+@@ -84,3 +86,4 @@ obj-$(CONFIG_NETFILTER_XT_MATCH_STRING)
obj-$(CONFIG_NETFILTER_XT_MATCH_TCPMSS) += xt_tcpmss.o
obj-$(CONFIG_NETFILTER_XT_MATCH_TIME) += xt_time.o
obj-$(CONFIG_NETFILTER_XT_MATCH_U32) += xt_u32.o
@@ -833,7 +833,7 @@
+MODULE_ALIAS("ipt_portscan");
--- a/drivers/char/random.c
+++ b/drivers/char/random.c
-@@ -1554,6 +1554,8 @@
+@@ -1554,6 +1554,8 @@ __u32 secure_tcp_sequence_number(__be32
return seq;
}