aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic-2.6/patches-2.6.25/171-netfilter_tarpit.patch
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2008-05-18 20:26:43 +0000
committerGabor Juhos <juhosg@openwrt.org>2008-05-18 20:26:43 +0000
commit4503efda2da6e5868bbbd274c042622dc03edd8e (patch)
tree3678d3fa5a554dcf4f4295ab9dcb5ab026240683 /target/linux/generic-2.6/patches-2.6.25/171-netfilter_tarpit.patch
parente582f614b6e15517a9207b0a96a72b68f7a254df (diff)
downloadupstream-4503efda2da6e5868bbbd274c042622dc03edd8e.tar.gz
upstream-4503efda2da6e5868bbbd274c042622dc03edd8e.tar.bz2
upstream-4503efda2da6e5868bbbd274c042622dc03edd8e.zip
refresh generic 2.6.25 patches
SVN-Revision: 11189
Diffstat (limited to 'target/linux/generic-2.6/patches-2.6.25/171-netfilter_tarpit.patch')
-rw-r--r--target/linux/generic-2.6/patches-2.6.25/171-netfilter_tarpit.patch16
1 files changed, 8 insertions, 8 deletions
diff --git a/target/linux/generic-2.6/patches-2.6.25/171-netfilter_tarpit.patch b/target/linux/generic-2.6/patches-2.6.25/171-netfilter_tarpit.patch
index 0b47b1f22e..7add5f5b93 100644
--- a/target/linux/generic-2.6/patches-2.6.25/171-netfilter_tarpit.patch
+++ b/target/linux/generic-2.6/patches-2.6.25/171-netfilter_tarpit.patch
@@ -1,7 +1,7 @@
-Index: linux-2.6.25.1/net/netfilter/Kconfig
+Index: linux-2.6.25.4/net/netfilter/Kconfig
===================================================================
---- linux-2.6.25.1.orig/net/netfilter/Kconfig
-+++ linux-2.6.25.1/net/netfilter/Kconfig
+--- linux-2.6.25.4.orig/net/netfilter/Kconfig
++++ linux-2.6.25.4/net/netfilter/Kconfig
@@ -437,6 +437,23 @@ config NETFILTER_XT_TARGET_CONNSECMARK
To compile it as a module, choose M here. If unsure, say N.
@@ -26,10 +26,10 @@ Index: linux-2.6.25.1/net/netfilter/Kconfig
config NETFILTER_XT_TARGET_TCPMSS
tristate '"TCPMSS" target support'
depends on NETFILTER_XTABLES && (IPV6 || IPV6=n)
-Index: linux-2.6.25.1/net/netfilter/Makefile
+Index: linux-2.6.25.4/net/netfilter/Makefile
===================================================================
---- linux-2.6.25.1.orig/net/netfilter/Makefile
-+++ linux-2.6.25.1/net/netfilter/Makefile
+--- linux-2.6.25.4.orig/net/netfilter/Makefile
++++ linux-2.6.25.4/net/netfilter/Makefile
@@ -47,6 +47,7 @@ obj-$(CONFIG_NETFILTER_XT_TARGET_NFQUEUE
obj-$(CONFIG_NETFILTER_XT_TARGET_NOTRACK) += xt_NOTRACK.o
obj-$(CONFIG_NETFILTER_XT_TARGET_RATEEST) += xt_RATEEST.o
@@ -38,10 +38,10 @@ Index: linux-2.6.25.1/net/netfilter/Makefile
obj-$(CONFIG_NETFILTER_XT_TARGET_TCPMSS) += xt_TCPMSS.o
obj-$(CONFIG_NETFILTER_XT_TARGET_TCPOPTSTRIP) += xt_TCPOPTSTRIP.o
obj-$(CONFIG_NETFILTER_XT_TARGET_TRACE) += xt_TRACE.o
-Index: linux-2.6.25.1/net/netfilter/xt_TARPIT.c
+Index: linux-2.6.25.4/net/netfilter/xt_TARPIT.c
===================================================================
--- /dev/null
-+++ linux-2.6.25.1/net/netfilter/xt_TARPIT.c
++++ linux-2.6.25.4/net/netfilter/xt_TARPIT.c
@@ -0,0 +1,279 @@
+/*
+ * Kernel module to capture and hold incoming TCP connections using