aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic-2.6/patches-2.6.25/002-lzma_decompress.patch
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2008-05-30 16:30:51 +0000
committerImre Kaloz <kaloz@openwrt.org>2008-05-30 16:30:51 +0000
commit0d62d39c21daa3d3ee6f974ccf3e3ab3008d79c2 (patch)
tree5e3bc42552316a5cdaf8eee331305ff7b55c7bad /target/linux/generic-2.6/patches-2.6.25/002-lzma_decompress.patch
parent2004a63a81f73ab8d3b926815a11119b5b81c071 (diff)
downloadupstream-0d62d39c21daa3d3ee6f974ccf3e3ab3008d79c2.tar.gz
upstream-0d62d39c21daa3d3ee6f974ccf3e3ab3008d79c2.tar.bz2
upstream-0d62d39c21daa3d3ee6f974ccf3e3ab3008d79c2.zip
refresh generic 2.6.25 patches to match upstream style
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@11296 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/generic-2.6/patches-2.6.25/002-lzma_decompress.patch')
-rw-r--r--target/linux/generic-2.6/patches-2.6.25/002-lzma_decompress.patch16
1 files changed, 5 insertions, 11 deletions
diff --git a/target/linux/generic-2.6/patches-2.6.25/002-lzma_decompress.patch b/target/linux/generic-2.6/patches-2.6.25/002-lzma_decompress.patch
index 73cf22a9b4..fdc3039863 100644
--- a/target/linux/generic-2.6/patches-2.6.25/002-lzma_decompress.patch
+++ b/target/linux/generic-2.6/patches-2.6.25/002-lzma_decompress.patch
@@ -1,7 +1,5 @@
-Index: linux-2.6.25.4/include/linux/LzmaDecode.h
-===================================================================
--- /dev/null
-+++ linux-2.6.25.4/include/linux/LzmaDecode.h
++++ b/include/linux/LzmaDecode.h
@@ -0,0 +1,100 @@
+/*
+ LzmaDecode.h
@@ -103,10 +101,8 @@ Index: linux-2.6.25.4/include/linux/LzmaDecode.h
+ UInt32 *outSizeProcessed);
+
+#endif
-Index: linux-2.6.25.4/lib/LzmaDecode.c
-===================================================================
--- /dev/null
-+++ linux-2.6.25.4/lib/LzmaDecode.c
++++ b/lib/LzmaDecode.c
@@ -0,0 +1,663 @@
+/*
+ LzmaDecode.c
@@ -771,11 +767,9 @@ Index: linux-2.6.25.4/lib/LzmaDecode.c
+ *outSizeProcessed = nowPos;
+ return LZMA_RESULT_OK;
+}
-Index: linux-2.6.25.4/lib/Makefile
-===================================================================
---- linux-2.6.25.4.orig/lib/Makefile
-+++ linux-2.6.25.4/lib/Makefile
-@@ -14,7 +14,7 @@ lib-$(CONFIG_SMP) += cpumask.o
+--- a/lib/Makefile
++++ b/lib/Makefile
+@@ -14,7 +14,7 @@
lib-y += kobject.o kref.o klist.o
obj-y += div64.o sort.o parser.o halfmd4.o debug_locks.o random32.o \