aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic-2.6/patches-2.6.24/420-gpiodev.patch
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2008-08-05 09:52:23 +0000
committerGabor Juhos <juhosg@openwrt.org>2008-08-05 09:52:23 +0000
commit3527e7a64951f7af020dc5b5d4e588e5f33d136e (patch)
tree0e353626dea485fc8996c6e0763d2a70547e9592 /target/linux/generic-2.6/patches-2.6.24/420-gpiodev.patch
parentcf8eecaad5c5987f1c44c51209589f4cceb8df48 (diff)
downloadupstream-3527e7a64951f7af020dc5b5d4e588e5f33d136e.tar.gz
upstream-3527e7a64951f7af020dc5b5d4e588e5f33d136e.tar.bz2
upstream-3527e7a64951f7af020dc5b5d4e588e5f33d136e.zip
modules/gpio_dev: move to drivers/char/ on older kernels as well, and create a package for it
SVN-Revision: 12133
Diffstat (limited to 'target/linux/generic-2.6/patches-2.6.24/420-gpiodev.patch')
-rw-r--r--target/linux/generic-2.6/patches-2.6.24/420-gpiodev.patch26
1 files changed, 26 insertions, 0 deletions
diff --git a/target/linux/generic-2.6/patches-2.6.24/420-gpiodev.patch b/target/linux/generic-2.6/patches-2.6.24/420-gpiodev.patch
new file mode 100644
index 0000000000..98187413b3
--- /dev/null
+++ b/target/linux/generic-2.6/patches-2.6.24/420-gpiodev.patch
@@ -0,0 +1,26 @@
+--- a/drivers/char/Kconfig
++++ b/drivers/char/Kconfig
+@@ -946,6 +946,13 @@
+
+ If compiled as a module, it will be called cs5535_gpio.
+
++config GPIO_DEVICE
++ tristate "GPIO device support"
++ depends on GENERIC_GPIO
++ help
++ Say Y to enable Linux GPIO device support. This allows control of
++ GPIO pins using a character device
++
+ config GPIO_VR41XX
+ tristate "NEC VR4100 series General-purpose I/O Unit support"
+ depends on CPU_VR41XX
+--- a/drivers/char/Makefile
++++ b/drivers/char/Makefile
+@@ -93,6 +93,7 @@
+ obj-$(CONFIG_PC8736x_GPIO) += pc8736x_gpio.o
+ obj-$(CONFIG_NSC_GPIO) += nsc_gpio.o
+ obj-$(CONFIG_CS5535_GPIO) += cs5535_gpio.o
++obj-$(CONFIG_GPIO_DEVICE) += gpio_dev.o
+ obj-$(CONFIG_GPIO_VR41XX) += vr41xx_giu.o
+ obj-$(CONFIG_GPIO_TB0219) += tb0219.o
+ obj-$(CONFIG_TELCLOCK) += tlclk.o