aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic-2.6/patches-2.6.24/400-ledtrig_morse.patch
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2008-01-28 13:36:09 +0000
committerImre Kaloz <kaloz@openwrt.org>2008-01-28 13:36:09 +0000
commit5303deecf170c291df307f23480590b53f8287e5 (patch)
treec19d3bb7b0ac1d963bf2a2875e3456f5872d9ae5 /target/linux/generic-2.6/patches-2.6.24/400-ledtrig_morse.patch
parentf66f06c1894b7becb24cad683f10201e04d60724 (diff)
downloadupstream-5303deecf170c291df307f23480590b53f8287e5.tar.gz
upstream-5303deecf170c291df307f23480590b53f8287e5.tar.bz2
upstream-5303deecf170c291df307f23480590b53f8287e5.zip
generic 2.6.24 support
SVN-Revision: 10291
Diffstat (limited to 'target/linux/generic-2.6/patches-2.6.24/400-ledtrig_morse.patch')
-rw-r--r--target/linux/generic-2.6/patches-2.6.24/400-ledtrig_morse.patch22
1 files changed, 22 insertions, 0 deletions
diff --git a/target/linux/generic-2.6/patches-2.6.24/400-ledtrig_morse.patch b/target/linux/generic-2.6/patches-2.6.24/400-ledtrig_morse.patch
new file mode 100644
index 0000000000..780fd34a5c
--- /dev/null
+++ b/target/linux/generic-2.6/patches-2.6.24/400-ledtrig_morse.patch
@@ -0,0 +1,22 @@
+Index: linux-2.6.23-rc9/drivers/leds/Kconfig
+===================================================================
+--- linux-2.6.23-rc9.orig/drivers/leds/Kconfig 2007-10-02 12:51:05.000000000 +0800
++++ linux-2.6.23-rc9/drivers/leds/Kconfig 2007-10-03 23:43:31.000000000 +0800
+@@ -133,4 +133,8 @@
+ load average.
+ If unsure, say Y.
+
++config LEDS_TRIGGER_MORSE
++ tristate "LED Morse Trigger"
++ depends on LEDS_TRIGGERS
++
+ endif # NEW_LEDS
+Index: linux-2.6.23-rc9/drivers/leds/Makefile
+===================================================================
+--- linux-2.6.23-rc9.orig/drivers/leds/Makefile 2007-10-02 12:51:05.000000000 +0800
++++ linux-2.6.23-rc9/drivers/leds/Makefile 2007-10-03 23:42:24.000000000 +0800
+@@ -22,3 +22,4 @@
+ obj-$(CONFIG_LEDS_TRIGGER_TIMER) += ledtrig-timer.o
+ obj-$(CONFIG_LEDS_TRIGGER_IDE_DISK) += ledtrig-ide-disk.o
+ obj-$(CONFIG_LEDS_TRIGGER_HEARTBEAT) += ledtrig-heartbeat.o
++obj-$(CONFIG_LEDS_TRIGGER_MORSE) += ledtrig-morse.o