aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic-2.6/patches-2.6.24/150-netfilter_imq.patch
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2008-05-30 17:19:24 +0000
committerImre Kaloz <kaloz@openwrt.org>2008-05-30 17:19:24 +0000
commitf6d815a2839a1dcecba7132ce8499e41fc878dfc (patch)
tree253cbe10bc6569ef56223632eed27a179e447946 /target/linux/generic-2.6/patches-2.6.24/150-netfilter_imq.patch
parent41ccd65d1af59a115e5e03c995f69966ef19d66c (diff)
downloadupstream-f6d815a2839a1dcecba7132ce8499e41fc878dfc.tar.gz
upstream-f6d815a2839a1dcecba7132ce8499e41fc878dfc.tar.bz2
upstream-f6d815a2839a1dcecba7132ce8499e41fc878dfc.zip
refresh generic 2.6.24 patches to match upstream style
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@11302 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/generic-2.6/patches-2.6.24/150-netfilter_imq.patch')
-rw-r--r--target/linux/generic-2.6/patches-2.6.24/150-netfilter_imq.patch98
1 files changed, 34 insertions, 64 deletions
diff --git a/target/linux/generic-2.6/patches-2.6.24/150-netfilter_imq.patch b/target/linux/generic-2.6/patches-2.6.24/150-netfilter_imq.patch
index f4b00b1b2a..ec6dfc682a 100644
--- a/target/linux/generic-2.6/patches-2.6.24/150-netfilter_imq.patch
+++ b/target/linux/generic-2.6/patches-2.6.24/150-netfilter_imq.patch
@@ -1,7 +1,5 @@
-Index: linux-2.6.24.7/drivers/net/imq.c
-===================================================================
--- /dev/null
-+++ linux-2.6.24.7/drivers/net/imq.c
++++ b/drivers/net/imq.c
@@ -0,0 +1,409 @@
+/*
+ * Pseudo-driver for the intermediate queue device.
@@ -412,11 +410,9 @@ Index: linux-2.6.24.7/drivers/net/imq.c
+MODULE_AUTHOR("http://www.linuximq.net");
+MODULE_DESCRIPTION("Pseudo-driver for the intermediate queue device. See http://www.linuximq.net/ for more information.");
+MODULE_LICENSE("GPL");
-Index: linux-2.6.24.7/drivers/net/Kconfig
-===================================================================
---- linux-2.6.24.7.orig/drivers/net/Kconfig
-+++ linux-2.6.24.7/drivers/net/Kconfig
-@@ -112,6 +112,129 @@ config EQUALIZER
+--- a/drivers/net/Kconfig
++++ b/drivers/net/Kconfig
+@@ -112,6 +112,129 @@
To compile this driver as a module, choose M here: the module
will be called eql. If unsure, say N.
@@ -546,11 +542,9 @@ Index: linux-2.6.24.7/drivers/net/Kconfig
config TUN
tristate "Universal TUN/TAP device driver support"
select CRC32
-Index: linux-2.6.24.7/drivers/net/Makefile
-===================================================================
---- linux-2.6.24.7.orig/drivers/net/Makefile
-+++ linux-2.6.24.7/drivers/net/Makefile
-@@ -139,6 +139,7 @@ obj-$(CONFIG_SLHC) += slhc.o
+--- a/drivers/net/Makefile
++++ b/drivers/net/Makefile
+@@ -139,6 +139,7 @@
obj-$(CONFIG_XEN_NETDEV_FRONTEND) += xen-netfront.o
obj-$(CONFIG_DUMMY) += dummy.o
@@ -558,10 +552,8 @@ Index: linux-2.6.24.7/drivers/net/Makefile
obj-$(CONFIG_IFB) += ifb.o
obj-$(CONFIG_MACVLAN) += macvlan.o
obj-$(CONFIG_DE600) += de600.o
-Index: linux-2.6.24.7/include/linux/imq.h
-===================================================================
--- /dev/null
-+++ linux-2.6.24.7/include/linux/imq.h
++++ b/include/linux/imq.h
@@ -0,0 +1,9 @@
+#ifndef _IMQ_H
+#define _IMQ_H
@@ -572,10 +564,8 @@ Index: linux-2.6.24.7/include/linux/imq.h
+#define IMQ_F_ENQUEUE 0x80
+
+#endif /* _IMQ_H */
-Index: linux-2.6.24.7/include/linux/netfilter_ipv4/ipt_IMQ.h
-===================================================================
--- /dev/null
-+++ linux-2.6.24.7/include/linux/netfilter_ipv4/ipt_IMQ.h
++++ b/include/linux/netfilter_ipv4/ipt_IMQ.h
@@ -0,0 +1,8 @@
+#ifndef _IPT_IMQ_H
+#define _IPT_IMQ_H
@@ -585,10 +575,8 @@ Index: linux-2.6.24.7/include/linux/netfilter_ipv4/ipt_IMQ.h
+};
+
+#endif /* _IPT_IMQ_H */
-Index: linux-2.6.24.7/include/linux/netfilter_ipv6/ip6t_IMQ.h
-===================================================================
--- /dev/null
-+++ linux-2.6.24.7/include/linux/netfilter_ipv6/ip6t_IMQ.h
++++ b/include/linux/netfilter_ipv6/ip6t_IMQ.h
@@ -0,0 +1,8 @@
+#ifndef _IP6T_IMQ_H
+#define _IP6T_IMQ_H
@@ -598,11 +586,9 @@ Index: linux-2.6.24.7/include/linux/netfilter_ipv6/ip6t_IMQ.h
+};
+
+#endif /* _IP6T_IMQ_H */
-Index: linux-2.6.24.7/include/linux/skbuff.h
-===================================================================
---- linux-2.6.24.7.orig/include/linux/skbuff.h
-+++ linux-2.6.24.7/include/linux/skbuff.h
-@@ -295,6 +295,10 @@ struct sk_buff {
+--- a/include/linux/skbuff.h
++++ b/include/linux/skbuff.h
+@@ -295,6 +295,10 @@
struct nf_conntrack *nfct;
struct sk_buff *nfct_reasm;
#endif
@@ -613,7 +599,7 @@ Index: linux-2.6.24.7/include/linux/skbuff.h
#ifdef CONFIG_BRIDGE_NETFILTER
struct nf_bridge_info *nf_bridge;
#endif
-@@ -1728,6 +1732,10 @@ static inline void __nf_copy(struct sk_b
+@@ -1728,6 +1732,10 @@
dst->nfct_reasm = src->nfct_reasm;
nf_conntrack_get_reasm(src->nfct_reasm);
#endif
@@ -624,10 +610,8 @@ Index: linux-2.6.24.7/include/linux/skbuff.h
#ifdef CONFIG_BRIDGE_NETFILTER
dst->nf_bridge = src->nf_bridge;
nf_bridge_get(src->nf_bridge);
-Index: linux-2.6.24.7/net/core/dev.c
-===================================================================
---- linux-2.6.24.7.orig/net/core/dev.c
-+++ linux-2.6.24.7/net/core/dev.c
+--- a/net/core/dev.c
++++ b/net/core/dev.c
@@ -95,6 +95,9 @@
#include <net/net_namespace.h>
#include <net/sock.h>
@@ -638,7 +622,7 @@ Index: linux-2.6.24.7/net/core/dev.c
#include <linux/proc_fs.h>
#include <linux/seq_file.h>
#include <linux/stat.h>
-@@ -1533,7 +1536,11 @@ static int dev_gso_segment(struct sk_buf
+@@ -1533,7 +1536,11 @@
int dev_hard_start_xmit(struct sk_buff *skb, struct net_device *dev)
{
if (likely(!skb->next)) {
@@ -651,10 +635,8 @@ Index: linux-2.6.24.7/net/core/dev.c
dev_queue_xmit_nit(skb, dev);
if (netif_needs_gso(dev, skb)) {
-Index: linux-2.6.24.7/net/ipv4/netfilter/ipt_IMQ.c
-===================================================================
--- /dev/null
-+++ linux-2.6.24.7/net/ipv4/netfilter/ipt_IMQ.c
++++ b/net/ipv4/netfilter/ipt_IMQ.c
@@ -0,0 +1,69 @@
+/*
+ * This target marks packets to be enqueued to an imq device
@@ -725,11 +707,9 @@ Index: linux-2.6.24.7/net/ipv4/netfilter/ipt_IMQ.c
+MODULE_AUTHOR("http://www.linuximq.net");
+MODULE_DESCRIPTION("Pseudo-driver for the intermediate queue device. See http://www.linuximq.net/ for more information.");
+MODULE_LICENSE("GPL");
-Index: linux-2.6.24.7/net/ipv4/netfilter/Kconfig
-===================================================================
---- linux-2.6.24.7.orig/net/ipv4/netfilter/Kconfig
-+++ linux-2.6.24.7/net/ipv4/netfilter/Kconfig
-@@ -333,6 +333,17 @@ config IP_NF_MANGLE
+--- a/net/ipv4/netfilter/Kconfig
++++ b/net/ipv4/netfilter/Kconfig
+@@ -333,6 +333,17 @@
To compile it as a module, choose M here. If unsure, say N.
@@ -747,11 +727,9 @@ Index: linux-2.6.24.7/net/ipv4/netfilter/Kconfig
config IP_NF_TARGET_TOS
tristate "TOS target support"
depends on IP_NF_MANGLE
-Index: linux-2.6.24.7/net/ipv4/netfilter/Makefile
-===================================================================
---- linux-2.6.24.7.orig/net/ipv4/netfilter/Makefile
-+++ linux-2.6.24.7/net/ipv4/netfilter/Makefile
-@@ -58,6 +58,7 @@ obj-$(CONFIG_IP_NF_MATCH_IPP2P) += ipt_i
+--- a/net/ipv4/netfilter/Makefile
++++ b/net/ipv4/netfilter/Makefile
+@@ -58,6 +58,7 @@
obj-$(CONFIG_IP_NF_TARGET_CLUSTERIP) += ipt_CLUSTERIP.o
obj-$(CONFIG_IP_NF_TARGET_ECN) += ipt_ECN.o
obj-$(CONFIG_IP_NF_TARGET_LOG) += ipt_LOG.o
@@ -759,10 +737,8 @@ Index: linux-2.6.24.7/net/ipv4/netfilter/Makefile
obj-$(CONFIG_IP_NF_TARGET_MASQUERADE) += ipt_MASQUERADE.o
obj-$(CONFIG_IP_NF_TARGET_NETMAP) += ipt_NETMAP.o
obj-$(CONFIG_IP_NF_TARGET_REDIRECT) += ipt_REDIRECT.o
-Index: linux-2.6.24.7/net/ipv6/netfilter/ip6t_IMQ.c
-===================================================================
--- /dev/null
-+++ linux-2.6.24.7/net/ipv6/netfilter/ip6t_IMQ.c
++++ b/net/ipv6/netfilter/ip6t_IMQ.c
@@ -0,0 +1,69 @@
+/*
+ * This target marks packets to be enqueued to an imq device
@@ -833,11 +809,9 @@ Index: linux-2.6.24.7/net/ipv6/netfilter/ip6t_IMQ.c
+MODULE_AUTHOR("http://www.linuximq.net");
+MODULE_DESCRIPTION("Pseudo-driver for the intermediate queue device. See http://www.linuximq.net/ for more information.");
+MODULE_LICENSE("GPL");
-Index: linux-2.6.24.7/net/ipv6/netfilter/Kconfig
-===================================================================
---- linux-2.6.24.7.orig/net/ipv6/netfilter/Kconfig
-+++ linux-2.6.24.7/net/ipv6/netfilter/Kconfig
-@@ -173,6 +173,15 @@ config IP6_NF_MANGLE
+--- a/net/ipv6/netfilter/Kconfig
++++ b/net/ipv6/netfilter/Kconfig
+@@ -173,6 +173,15 @@
To compile it as a module, choose M here. If unsure, say N.
@@ -853,10 +827,8 @@ Index: linux-2.6.24.7/net/ipv6/netfilter/Kconfig
config IP6_NF_TARGET_HL
tristate 'HL (hoplimit) target support'
depends on IP6_NF_MANGLE
-Index: linux-2.6.24.7/net/ipv6/netfilter/Makefile
-===================================================================
---- linux-2.6.24.7.orig/net/ipv6/netfilter/Makefile
-+++ linux-2.6.24.7/net/ipv6/netfilter/Makefile
+--- a/net/ipv6/netfilter/Makefile
++++ b/net/ipv6/netfilter/Makefile
@@ -6,6 +6,7 @@
obj-$(CONFIG_IP6_NF_IPTABLES) += ip6_tables.o
obj-$(CONFIG_IP6_NF_FILTER) += ip6table_filter.o
@@ -865,11 +837,9 @@ Index: linux-2.6.24.7/net/ipv6/netfilter/Makefile
obj-$(CONFIG_IP6_NF_QUEUE) += ip6_queue.o
obj-$(CONFIG_IP6_NF_RAW) += ip6table_raw.o
-Index: linux-2.6.24.7/net/sched/sch_generic.c
-===================================================================
---- linux-2.6.24.7.orig/net/sched/sch_generic.c
-+++ linux-2.6.24.7/net/sched/sch_generic.c
-@@ -176,6 +176,11 @@ static inline int qdisc_restart(struct n
+--- a/net/sched/sch_generic.c
++++ b/net/sched/sch_generic.c
+@@ -176,6 +176,11 @@
return ret;
}
@@ -881,7 +851,7 @@ Index: linux-2.6.24.7/net/sched/sch_generic.c
void __qdisc_run(struct net_device *dev)
{
unsigned long start_time = jiffies;
-@@ -650,3 +655,4 @@ EXPORT_SYMBOL(qdisc_destroy);
+@@ -650,3 +655,4 @@
EXPORT_SYMBOL(qdisc_reset);
EXPORT_SYMBOL(qdisc_lock_tree);
EXPORT_SYMBOL(qdisc_unlock_tree);