aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic-2.6/patches-2.6.24/140-netfilter_time.patch
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2008-05-30 17:19:24 +0000
committerImre Kaloz <kaloz@openwrt.org>2008-05-30 17:19:24 +0000
commitf6d815a2839a1dcecba7132ce8499e41fc878dfc (patch)
tree253cbe10bc6569ef56223632eed27a179e447946 /target/linux/generic-2.6/patches-2.6.24/140-netfilter_time.patch
parent41ccd65d1af59a115e5e03c995f69966ef19d66c (diff)
downloadupstream-f6d815a2839a1dcecba7132ce8499e41fc878dfc.tar.gz
upstream-f6d815a2839a1dcecba7132ce8499e41fc878dfc.tar.bz2
upstream-f6d815a2839a1dcecba7132ce8499e41fc878dfc.zip
refresh generic 2.6.24 patches to match upstream style
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@11302 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/generic-2.6/patches-2.6.24/140-netfilter_time.patch')
-rw-r--r--target/linux/generic-2.6/patches-2.6.24/140-netfilter_time.patch24
1 files changed, 8 insertions, 16 deletions
diff --git a/target/linux/generic-2.6/patches-2.6.24/140-netfilter_time.patch b/target/linux/generic-2.6/patches-2.6.24/140-netfilter_time.patch
index 0f8d4cd19d..b29c064346 100644
--- a/target/linux/generic-2.6/patches-2.6.24/140-netfilter_time.patch
+++ b/target/linux/generic-2.6/patches-2.6.24/140-netfilter_time.patch
@@ -1,7 +1,5 @@
-Index: linux-2.6.24.7/include/linux/netfilter_ipv4/ipt_time.h
-===================================================================
--- /dev/null
-+++ linux-2.6.24.7/include/linux/netfilter_ipv4/ipt_time.h
++++ b/include/linux/netfilter_ipv4/ipt_time.h
@@ -0,0 +1,18 @@
+#ifndef __ipt_time_h_included__
+#define __ipt_time_h_included__
@@ -21,10 +19,8 @@ Index: linux-2.6.24.7/include/linux/netfilter_ipv4/ipt_time.h
+
+
+#endif /* __ipt_time_h_included__ */
-Index: linux-2.6.24.7/net/ipv4/netfilter/ipt_time.c
-===================================================================
--- /dev/null
-+++ linux-2.6.24.7/net/ipv4/netfilter/ipt_time.c
++++ b/net/ipv4/netfilter/ipt_time.c
@@ -0,0 +1,180 @@
+/*
+ This is a module which is used for time matching
@@ -206,11 +202,9 @@ Index: linux-2.6.24.7/net/ipv4/netfilter/ipt_time.c
+ r->tm_mon=i;
+ r->tm_mday=work-__spm[i]+1;
+}
-Index: linux-2.6.24.7/net/ipv4/netfilter/Kconfig
-===================================================================
---- linux-2.6.24.7.orig/net/ipv4/netfilter/Kconfig
-+++ linux-2.6.24.7/net/ipv4/netfilter/Kconfig
-@@ -78,6 +78,22 @@ config IP_NF_MATCH_TOS
+--- a/net/ipv4/netfilter/Kconfig
++++ b/net/ipv4/netfilter/Kconfig
+@@ -78,6 +78,22 @@
To compile it as a module, choose M here. If unsure, say N.
@@ -233,11 +227,9 @@ Index: linux-2.6.24.7/net/ipv4/netfilter/Kconfig
config IP_NF_MATCH_RECENT
tristate "recent match support"
depends on IP_NF_IPTABLES
-Index: linux-2.6.24.7/net/ipv4/netfilter/Makefile
-===================================================================
---- linux-2.6.24.7.orig/net/ipv4/netfilter/Makefile
-+++ linux-2.6.24.7/net/ipv4/netfilter/Makefile
-@@ -50,6 +50,7 @@ obj-$(CONFIG_IP_NF_MATCH_RECENT) += ipt_
+--- a/net/ipv4/netfilter/Makefile
++++ b/net/ipv4/netfilter/Makefile
+@@ -50,6 +50,7 @@
obj-$(CONFIG_IP_NF_MATCH_TOS) += ipt_tos.o
obj-$(CONFIG_IP_NF_MATCH_TTL) += ipt_ttl.o
obj-$(CONFIG_IP_NF_MATCH_SET) += ipt_set.o