aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic-2.6/patches-2.6.24/100-netfilter_layer7_2.17.patch
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2009-02-08 19:16:45 +0000
committerGabor Juhos <juhosg@openwrt.org>2009-02-08 19:16:45 +0000
commit6006245685bfec8fce3f869ca5b6f8402da93fad (patch)
tree4cb2f87be022976e427d16f1411dc66c06fd5a51 /target/linux/generic-2.6/patches-2.6.24/100-netfilter_layer7_2.17.patch
parentdf0aa190378480fbc8d69b140b945a766917635c (diff)
downloadupstream-6006245685bfec8fce3f869ca5b6f8402da93fad.tar.gz
upstream-6006245685bfec8fce3f869ca5b6f8402da93fad.tar.bz2
upstream-6006245685bfec8fce3f869ca5b6f8402da93fad.zip
[kernel] generic-2.6/2.6.24: refresh patches
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@14450 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/generic-2.6/patches-2.6.24/100-netfilter_layer7_2.17.patch')
-rw-r--r--target/linux/generic-2.6/patches-2.6.24/100-netfilter_layer7_2.17.patch10
1 files changed, 5 insertions, 5 deletions
diff --git a/target/linux/generic-2.6/patches-2.6.24/100-netfilter_layer7_2.17.patch b/target/linux/generic-2.6/patches-2.6.24/100-netfilter_layer7_2.17.patch
index cbe6d813a1..9315486308 100644
--- a/target/linux/generic-2.6/patches-2.6.24/100-netfilter_layer7_2.17.patch
+++ b/target/linux/generic-2.6/patches-2.6.24/100-netfilter_layer7_2.17.patch
@@ -1,6 +1,6 @@
--- a/net/netfilter/Kconfig
+++ b/net/netfilter/Kconfig
-@@ -633,6 +633,27 @@
+@@ -633,6 +633,27 @@ config NETFILTER_XT_MATCH_STATE
To compile it as a module, choose M here. If unsure, say N.
@@ -30,7 +30,7 @@
depends on NETFILTER_XTABLES
--- a/net/netfilter/Makefile
+++ b/net/netfilter/Makefile
-@@ -73,6 +73,7 @@
+@@ -73,6 +73,7 @@ obj-$(CONFIG_NETFILTER_XT_MATCH_QUOTA) +
obj-$(CONFIG_NETFILTER_XT_MATCH_REALM) += xt_realm.o
obj-$(CONFIG_NETFILTER_XT_MATCH_SCTP) += xt_sctp.o
obj-$(CONFIG_NETFILTER_XT_MATCH_STATE) += xt_state.o
@@ -2027,7 +2027,7 @@
+}
--- a/net/netfilter/nf_conntrack_core.c
+++ b/net/netfilter/nf_conntrack_core.c
-@@ -206,6 +206,14 @@
+@@ -206,6 +206,14 @@ destroy_conntrack(struct nf_conntrack *n
* too. */
nf_ct_remove_expectations(ct);
@@ -2044,7 +2044,7 @@
BUG_ON(hlist_unhashed(&ct->tuplehash[IP_CT_DIR_ORIGINAL].hnode));
--- a/net/netfilter/nf_conntrack_standalone.c
+++ b/net/netfilter/nf_conntrack_standalone.c
-@@ -180,7 +180,12 @@
+@@ -180,7 +180,12 @@ static int ct_seq_show(struct seq_file *
return -ENOSPC;
#endif
@@ -2060,7 +2060,7 @@
return 0;
--- a/include/net/netfilter/nf_conntrack.h
+++ b/include/net/netfilter/nf_conntrack.h
-@@ -124,6 +124,22 @@
+@@ -124,6 +124,22 @@ struct nf_conn
u_int32_t secmark;
#endif