aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic-2.6/patches-2.6.23/010-disable_old_squashfs_compatibility.patch
diff options
context:
space:
mode:
authorEugene Konev <ejka@openwrt.org>2007-10-04 02:26:27 +0000
committerEugene Konev <ejka@openwrt.org>2007-10-04 02:26:27 +0000
commite67681f875b27605167e27206d2e98a21ca3c639 (patch)
treee6e777d184165399c76baa4f28233349805df738 /target/linux/generic-2.6/patches-2.6.23/010-disable_old_squashfs_compatibility.patch
parent6693e40cb674cdee9e64964a60fbd78009445a7e (diff)
downloadupstream-e67681f875b27605167e27206d2e98a21ca3c639.tar.gz
upstream-e67681f875b27605167e27206d2e98a21ca3c639.tar.bz2
upstream-e67681f875b27605167e27206d2e98a21ca3c639.zip
add generic 2.6.23 patches and config
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@9114 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/generic-2.6/patches-2.6.23/010-disable_old_squashfs_compatibility.patch')
-rw-r--r--target/linux/generic-2.6/patches-2.6.23/010-disable_old_squashfs_compatibility.patch23
1 files changed, 23 insertions, 0 deletions
diff --git a/target/linux/generic-2.6/patches-2.6.23/010-disable_old_squashfs_compatibility.patch b/target/linux/generic-2.6/patches-2.6.23/010-disable_old_squashfs_compatibility.patch
new file mode 100644
index 0000000000..99c5e2ec33
--- /dev/null
+++ b/target/linux/generic-2.6/patches-2.6.23/010-disable_old_squashfs_compatibility.patch
@@ -0,0 +1,23 @@
+Index: linux-2.6.23-rc6/fs/squashfs/Makefile
+===================================================================
+--- linux-2.6.23-rc6.orig/fs/squashfs/Makefile 2007-09-21 16:23:55.000000000 +0800
++++ linux-2.6.23-rc6/fs/squashfs/Makefile 2007-09-21 16:23:58.000000000 +0800
+@@ -4,4 +4,3 @@
+
+ obj-$(CONFIG_SQUASHFS) += squashfs.o
+ squashfs-y += inode.o
+-squashfs-y += squashfs2_0.o
+Index: linux-2.6.23-rc6/fs/squashfs/squashfs.h
+===================================================================
+--- linux-2.6.23-rc6.orig/fs/squashfs/squashfs.h 2007-09-21 16:23:55.000000000 +0800
++++ linux-2.6.23-rc6/fs/squashfs/squashfs.h 2007-09-21 16:23:58.000000000 +0800
+@@ -24,6 +24,9 @@
+ #ifdef CONFIG_SQUASHFS_1_0_COMPATIBILITY
+ #undef CONFIG_SQUASHFS_1_0_COMPATIBILITY
+ #endif
++#ifdef CONFIG_SQUASHFS_2_0_COMPATIBILITY
++#undef CONFIG_SQUASHFS_2_0_COMPATIBILITY
++#endif
+
+ #ifdef SQUASHFS_TRACE
+ #define TRACE(s, args...) printk(KERN_NOTICE "SQUASHFS: "s, ## args)