aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic-2.6/patches-2.6.23/004-extra_optimization.patch
diff options
context:
space:
mode:
authorEugene Konev <ejka@imfi.kspu.ru>2007-10-04 02:26:27 +0000
committerEugene Konev <ejka@imfi.kspu.ru>2007-10-04 02:26:27 +0000
commit6efb8c8df8cd8ccef6866e5c1f5e8b008b1c1c3f (patch)
tree20d5f4376dfa44f938be51450650f55ab31cef3a /target/linux/generic-2.6/patches-2.6.23/004-extra_optimization.patch
parente12359aa29fcb7c3adc97264bcdc48b10c0472ec (diff)
downloadupstream-6efb8c8df8cd8ccef6866e5c1f5e8b008b1c1c3f.tar.gz
upstream-6efb8c8df8cd8ccef6866e5c1f5e8b008b1c1c3f.tar.bz2
upstream-6efb8c8df8cd8ccef6866e5c1f5e8b008b1c1c3f.zip
add generic 2.6.23 patches and config
SVN-Revision: 9114
Diffstat (limited to 'target/linux/generic-2.6/patches-2.6.23/004-extra_optimization.patch')
-rw-r--r--target/linux/generic-2.6/patches-2.6.23/004-extra_optimization.patch14
1 files changed, 14 insertions, 0 deletions
diff --git a/target/linux/generic-2.6/patches-2.6.23/004-extra_optimization.patch b/target/linux/generic-2.6/patches-2.6.23/004-extra_optimization.patch
new file mode 100644
index 0000000000..09248fcdac
--- /dev/null
+++ b/target/linux/generic-2.6/patches-2.6.23/004-extra_optimization.patch
@@ -0,0 +1,14 @@
+Index: linux-2.6.23-rc6/Makefile
+===================================================================
+--- linux-2.6.23-rc6.orig/Makefile 2007-09-21 16:23:55.000000000 +0800
++++ linux-2.6.23-rc6/Makefile 2007-09-21 16:23:56.000000000 +0800
+@@ -508,6 +508,9 @@
+ NOSTDINC_FLAGS += -nostdinc -isystem $(shell $(CC) -print-file-name=include)
+ CHECKFLAGS += $(NOSTDINC_FLAGS)
+
++# improve gcc optimization
++CFLAGS += $(call cc-option,-funit-at-a-time,)
++
+ # warn about C99 declaration after statement
+ CFLAGS += $(call cc-option,-Wdeclaration-after-statement,)
+