aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic-2.6/patches-2.6.22/171-netfilter_tarpit.patch
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2008-05-18 20:24:13 +0000
committerGabor Juhos <juhosg@openwrt.org>2008-05-18 20:24:13 +0000
commit56fc181f20196a0baa22154fd55bbccc870e709d (patch)
tree4f317d1f4de3bbec467b59bec12303115fe08497 /target/linux/generic-2.6/patches-2.6.22/171-netfilter_tarpit.patch
parent98e0d6316579fa6ec653208f640baf8411f91a6c (diff)
downloadupstream-56fc181f20196a0baa22154fd55bbccc870e709d.tar.gz
upstream-56fc181f20196a0baa22154fd55bbccc870e709d.tar.bz2
upstream-56fc181f20196a0baa22154fd55bbccc870e709d.zip
[kernel] refresh generic 2.6.22 patches
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@11186 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/generic-2.6/patches-2.6.22/171-netfilter_tarpit.patch')
-rw-r--r--target/linux/generic-2.6/patches-2.6.22/171-netfilter_tarpit.patch16
1 files changed, 8 insertions, 8 deletions
diff --git a/target/linux/generic-2.6/patches-2.6.22/171-netfilter_tarpit.patch b/target/linux/generic-2.6/patches-2.6.22/171-netfilter_tarpit.patch
index 2e5b9e813a..6e8c260a50 100644
--- a/target/linux/generic-2.6/patches-2.6.22/171-netfilter_tarpit.patch
+++ b/target/linux/generic-2.6/patches-2.6.22/171-netfilter_tarpit.patch
@@ -1,7 +1,7 @@
-Index: linux-2.6.22.18/net/netfilter/Kconfig
+Index: linux-2.6.22.19/net/netfilter/Kconfig
===================================================================
---- linux-2.6.22.18.orig/net/netfilter/Kconfig
-+++ linux-2.6.22.18/net/netfilter/Kconfig
+--- linux-2.6.22.19.orig/net/netfilter/Kconfig
++++ linux-2.6.22.19/net/netfilter/Kconfig
@@ -379,6 +379,23 @@ config NETFILTER_XT_TARGET_CONNSECMARK
To compile it as a module, choose M here. If unsure, say N.
@@ -26,10 +26,10 @@ Index: linux-2.6.22.18/net/netfilter/Kconfig
config NETFILTER_XT_TARGET_TCPMSS
tristate '"TCPMSS" target support'
depends on NETFILTER_XTABLES && (IPV6 || IPV6=n)
-Index: linux-2.6.22.18/net/netfilter/Makefile
+Index: linux-2.6.22.19/net/netfilter/Makefile
===================================================================
---- linux-2.6.22.18.orig/net/netfilter/Makefile
-+++ linux-2.6.22.18/net/netfilter/Makefile
+--- linux-2.6.22.19.orig/net/netfilter/Makefile
++++ linux-2.6.22.19/net/netfilter/Makefile
@@ -45,6 +45,7 @@ obj-$(CONFIG_NETFILTER_XT_TARGET_NFQUEUE
obj-$(CONFIG_NETFILTER_XT_TARGET_NFLOG) += xt_NFLOG.o
obj-$(CONFIG_NETFILTER_XT_TARGET_NOTRACK) += xt_NOTRACK.o
@@ -38,10 +38,10 @@ Index: linux-2.6.22.18/net/netfilter/Makefile
obj-$(CONFIG_NETFILTER_XT_TARGET_TCPMSS) += xt_TCPMSS.o
obj-$(CONFIG_NETFILTER_XT_TARGET_CONNSECMARK) += xt_CONNSECMARK.o
obj-$(CONFIG_NETFILTER_XT_TARGET_CHAOS) += xt_CHAOS.o
-Index: linux-2.6.22.18/net/netfilter/xt_TARPIT.c
+Index: linux-2.6.22.19/net/netfilter/xt_TARPIT.c
===================================================================
--- /dev/null
-+++ linux-2.6.22.18/net/netfilter/xt_TARPIT.c
++++ linux-2.6.22.19/net/netfilter/xt_TARPIT.c
@@ -0,0 +1,280 @@
+/*
+ * Kernel module to capture and hold incoming TCP connections using