aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic-2.6/patches-2.6.21/160-netfilter_route.patch
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@hauke-m.de>2009-11-08 21:56:59 +0000
committerHauke Mehrtens <hauke@hauke-m.de>2009-11-08 21:56:59 +0000
commit343e9ffa203702c68e846fd3618ed6b30c2a8713 (patch)
tree8970b881c98964509c8b6dc48a7c7b91095a5e92 /target/linux/generic-2.6/patches-2.6.21/160-netfilter_route.patch
parentae0457f76a2a1e67cd0231e978c19911fe386064 (diff)
downloadupstream-343e9ffa203702c68e846fd3618ed6b30c2a8713.tar.gz
upstream-343e9ffa203702c68e846fd3618ed6b30c2a8713.tar.bz2
upstream-343e9ffa203702c68e846fd3618ed6b30c2a8713.zip
Add some build fixes for kernel 2.6.21 and the infineon amazon target.
Now it compiles with the new toolchain. These are mostly backports from mainline linux and newer linux kernels from openwrt. SVN-Revision: 18345
Diffstat (limited to 'target/linux/generic-2.6/patches-2.6.21/160-netfilter_route.patch')
-rw-r--r--target/linux/generic-2.6/patches-2.6.21/160-netfilter_route.patch8
1 files changed, 4 insertions, 4 deletions
diff --git a/target/linux/generic-2.6/patches-2.6.21/160-netfilter_route.patch b/target/linux/generic-2.6/patches-2.6.21/160-netfilter_route.patch
index 0d305e3ddb..8fcec08fcf 100644
--- a/target/linux/generic-2.6/patches-2.6.21/160-netfilter_route.patch
+++ b/target/linux/generic-2.6/patches-2.6.21/160-netfilter_route.patch
@@ -538,9 +538,9 @@
+module_exit(fini);
--- a/net/ipv4/netfilter/Kconfig
+++ b/net/ipv4/netfilter/Kconfig
-@@ -825,5 +825,22 @@ config IP_NF_TARGET_SET
- To compile it as a module, choose M here. If unsure, say N.
-
+@@ -684,5 +684,22 @@ config IP_NF_ARP_MANGLE
+ Allows altering the ARP packet payload: source and destination
+ hardware and network addresses.
+config IP_NF_TARGET_ROUTE
+ tristate 'ROUTE target support'
@@ -563,7 +563,7 @@
--- a/net/ipv4/netfilter/Makefile
+++ b/net/ipv4/netfilter/Makefile
-@@ -101,6 +101,7 @@ obj-$(CONFIG_IP_NF_TARGET_ECN) += ipt_EC
+@@ -100,6 +100,7 @@ obj-$(CONFIG_IP_NF_TARGET_ECN) += ipt_EC
obj-$(CONFIG_IP_NF_TARGET_IMQ) += ipt_IMQ.o
obj-$(CONFIG_IP_NF_TARGET_MASQUERADE) += ipt_MASQUERADE.o
obj-$(CONFIG_IP_NF_TARGET_REDIRECT) += ipt_REDIRECT.o