aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic-2.6/patches-2.6.21/110-ipp2p_0.8.1rc1.patch
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2009-02-08 19:33:57 +0000
committerGabor Juhos <juhosg@openwrt.org>2009-02-08 19:33:57 +0000
commit29e1ac054cebd1b0309aaa1465bb04ebcad5d858 (patch)
tree7732dd7b35dd81e1c50f9b718b6112e6503c4e9b /target/linux/generic-2.6/patches-2.6.21/110-ipp2p_0.8.1rc1.patch
parent1200d62f668a1eac3123301eee1fc96613133409 (diff)
downloadupstream-29e1ac054cebd1b0309aaa1465bb04ebcad5d858.tar.gz
upstream-29e1ac054cebd1b0309aaa1465bb04ebcad5d858.tar.bz2
upstream-29e1ac054cebd1b0309aaa1465bb04ebcad5d858.zip
generic-2.6/2.6.21: refresh patches
SVN-Revision: 14453
Diffstat (limited to 'target/linux/generic-2.6/patches-2.6.21/110-ipp2p_0.8.1rc1.patch')
-rw-r--r--target/linux/generic-2.6/patches-2.6.21/110-ipp2p_0.8.1rc1.patch20
1 files changed, 6 insertions, 14 deletions
diff --git a/target/linux/generic-2.6/patches-2.6.21/110-ipp2p_0.8.1rc1.patch b/target/linux/generic-2.6/patches-2.6.21/110-ipp2p_0.8.1rc1.patch
index 5f202ca99e..0dce6d3147 100644
--- a/target/linux/generic-2.6/patches-2.6.21/110-ipp2p_0.8.1rc1.patch
+++ b/target/linux/generic-2.6/patches-2.6.21/110-ipp2p_0.8.1rc1.patch
@@ -1,7 +1,5 @@
-Index: linux-2.6.21.7/include/linux/netfilter_ipv4/ipt_ipp2p.h
-===================================================================
--- /dev/null
-+++ linux-2.6.21.7/include/linux/netfilter_ipv4/ipt_ipp2p.h
++++ b/include/linux/netfilter_ipv4/ipt_ipp2p.h
@@ -0,0 +1,31 @@
+#ifndef __IPT_IPP2P_H
+#define __IPT_IPP2P_H
@@ -34,10 +32,8 @@ Index: linux-2.6.21.7/include/linux/netfilter_ipv4/ipt_ipp2p.h
+#define IPP2P_MUTE (1 << 14)
+#define IPP2P_WASTE (1 << 15)
+#define IPP2P_XDCC (1 << 16)
-Index: linux-2.6.21.7/net/ipv4/netfilter/ipt_ipp2p.c
-===================================================================
--- /dev/null
-+++ linux-2.6.21.7/net/ipv4/netfilter/ipt_ipp2p.c
++++ b/net/ipv4/netfilter/ipt_ipp2p.c
@@ -0,0 +1,882 @@
+#if defined(MODVERSIONS)
+#include <linux/modversions.h>
@@ -921,10 +917,8 @@ Index: linux-2.6.21.7/net/ipv4/netfilter/ipt_ipp2p.c
+module_exit(fini);
+
+
-Index: linux-2.6.21.7/net/ipv4/netfilter/Kconfig
-===================================================================
---- linux-2.6.21.7.orig/net/ipv4/netfilter/Kconfig
-+++ linux-2.6.21.7/net/ipv4/netfilter/Kconfig
+--- a/net/ipv4/netfilter/Kconfig
++++ b/net/ipv4/netfilter/Kconfig
@@ -245,6 +245,12 @@ config IP_NF_MATCH_IPRANGE
To compile it as a module, choose M here. If unsure, say N.
@@ -938,10 +932,8 @@ Index: linux-2.6.21.7/net/ipv4/netfilter/Kconfig
config IP_NF_MATCH_TOS
tristate "TOS match support"
depends on IP_NF_IPTABLES
-Index: linux-2.6.21.7/net/ipv4/netfilter/Makefile
-===================================================================
---- linux-2.6.21.7.orig/net/ipv4/netfilter/Makefile
-+++ linux-2.6.21.7/net/ipv4/netfilter/Makefile
+--- a/net/ipv4/netfilter/Makefile
++++ b/net/ipv4/netfilter/Makefile
@@ -91,6 +91,7 @@ obj-$(CONFIG_IP_NF_MATCH_ECN) += ipt_ecn
obj-$(CONFIG_IP_NF_MATCH_AH) += ipt_ah.o
obj-$(CONFIG_IP_NF_MATCH_TTL) += ipt_ttl.o