aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic-2.6/patches-2.6.21/010-disable_old_squashfs_compatibility.patch
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2008-09-21 11:25:17 +0000
committerFelix Fietkau <nbd@openwrt.org>2008-09-21 11:25:17 +0000
commit4296e978da0ab4198aa7f3d823690ee452e300c6 (patch)
treea5e666785df63064d1322e25030732622082b073 /target/linux/generic-2.6/patches-2.6.21/010-disable_old_squashfs_compatibility.patch
parente5dc717d220534bd61ee53c010ad050f648170c3 (diff)
downloadupstream-4296e978da0ab4198aa7f3d823690ee452e300c6.tar.gz
upstream-4296e978da0ab4198aa7f3d823690ee452e300c6.tar.bz2
upstream-4296e978da0ab4198aa7f3d823690ee452e300c6.zip
rename generic-2.6/patches to generic-2.6/patches-2.6.21
SVN-Revision: 12636
Diffstat (limited to 'target/linux/generic-2.6/patches-2.6.21/010-disable_old_squashfs_compatibility.patch')
-rw-r--r--target/linux/generic-2.6/patches-2.6.21/010-disable_old_squashfs_compatibility.patch23
1 files changed, 23 insertions, 0 deletions
diff --git a/target/linux/generic-2.6/patches-2.6.21/010-disable_old_squashfs_compatibility.patch b/target/linux/generic-2.6/patches-2.6.21/010-disable_old_squashfs_compatibility.patch
new file mode 100644
index 0000000000..55498617af
--- /dev/null
+++ b/target/linux/generic-2.6/patches-2.6.21/010-disable_old_squashfs_compatibility.patch
@@ -0,0 +1,23 @@
+Index: linux-2.6.21.7/fs/squashfs/Makefile
+===================================================================
+--- linux-2.6.21.7.orig/fs/squashfs/Makefile
++++ linux-2.6.21.7/fs/squashfs/Makefile
+@@ -4,4 +4,3 @@
+
+ obj-$(CONFIG_SQUASHFS) += squashfs.o
+ squashfs-y += inode.o
+-squashfs-y += squashfs2_0.o
+Index: linux-2.6.21.7/fs/squashfs/squashfs.h
+===================================================================
+--- linux-2.6.21.7.orig/fs/squashfs/squashfs.h
++++ linux-2.6.21.7/fs/squashfs/squashfs.h
+@@ -24,6 +24,9 @@
+ #ifdef CONFIG_SQUASHFS_1_0_COMPATIBILITY
+ #undef CONFIG_SQUASHFS_1_0_COMPATIBILITY
+ #endif
++#ifdef CONFIG_SQUASHFS_2_0_COMPATIBILITY
++#undef CONFIG_SQUASHFS_2_0_COMPATIBILITY
++#endif
+
+ #ifdef SQUASHFS_TRACE
+ #define TRACE(s, args...) printk(KERN_NOTICE "SQUASHFS: "s, ## args)