aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic-2.6/image/lzma-loader/src/Makefile
diff options
context:
space:
mode:
authorEugene Konev <ejka@openwrt.org>2007-03-18 09:32:22 +0000
committerEugene Konev <ejka@openwrt.org>2007-03-18 09:32:22 +0000
commit32a9d477d5767a9e0e7f656bcb07395c5f40ca24 (patch)
tree1c2bbeec9500ad81826befec3da8aa0b6cb4ea6e /target/linux/generic-2.6/image/lzma-loader/src/Makefile
parentc21a30ecafde2b93c7f4d199eda556ac439b8eb4 (diff)
downloadupstream-32a9d477d5767a9e0e7f656bcb07395c5f40ca24.tar.gz
upstream-32a9d477d5767a9e0e7f656bcb07395c5f40ca24.tar.bz2
upstream-32a9d477d5767a9e0e7f656bcb07395c5f40ca24.zip
Make lzma-loader sdram mapping configurable (#1169)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@6598 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/generic-2.6/image/lzma-loader/src/Makefile')
-rw-r--r--target/linux/generic-2.6/image/lzma-loader/src/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/target/linux/generic-2.6/image/lzma-loader/src/Makefile b/target/linux/generic-2.6/image/lzma-loader/src/Makefile
index dbe9019f2b..13ed96213e 100644
--- a/target/linux/generic-2.6/image/lzma-loader/src/Makefile
+++ b/target/linux/generic-2.6/image/lzma-loader/src/Makefile
@@ -4,15 +4,16 @@
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
#
+RAMSTART = 0x80000000
+RAMSIZE = 0x00100000 # 1MB
LOADADDR = 0x80400000 # RAM start + 4M
KERNEL_ENTRY = 0x80001000
-RAMSIZE = 0x00100000 # 1MB
IMAGE_COPY:=0
CROSS_COMPILE = mips-linux-
OBJCOPY:= $(CROSS_COMPILE)objcopy -O binary -R .reginfo -R .note -R .comment -R .mdebug -S
-CFLAGS := -fno-builtin -Os -G 0 -ffunction-sections -mno-abicalls -fno-pic -mabi=32 -march=mips32 -Wa,-32 -Wa,-march=mips32 -Wa,-mips32 -Wa,--trap -Wall -DRAMSIZE=${RAMSIZE} -DKERNEL_ENTRY=${KERNEL_ENTRY} -D_LZMA_IN_CB
+CFLAGS := -fno-builtin -Os -G 0 -ffunction-sections -mno-abicalls -fno-pic -mabi=32 -march=mips32 -Wa,-32 -Wa,-march=mips32 -Wa,-mips32 -Wa,--trap -Wall -DRAMSTART=${RAMSTART} -DRAMSIZE=${RAMSIZE} -DKERNEL_ENTRY=${KERNEL_ENTRY} -D_LZMA_IN_CB
ifeq ($(IMAGE_COPY),1)
CFLAGS += -DLOADADDR=${LOADADDR} -DIMAGE_COPY=1
endif