aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic-2.6/files/fs/yaffs2/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2008-10-22 06:51:06 +0000
committerFelix Fietkau <nbd@openwrt.org>2008-10-22 06:51:06 +0000
commit68c6bb15bad2c502d203162068f5615f008dc693 (patch)
tree8423b59e09bc1f254a9ddf4efae66c1b560bf998 /target/linux/generic-2.6/files/fs/yaffs2/Makefile
parent361ef0211c880a56221447c7228784b0e1b17bfa (diff)
downloadupstream-68c6bb15bad2c502d203162068f5615f008dc693.tar.gz
upstream-68c6bb15bad2c502d203162068f5615f008dc693.tar.bz2
upstream-68c6bb15bad2c502d203162068f5615f008dc693.zip
remove more redundant files and clone files-2.6.23 for 2.6.24 - fixes rdc build errors
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@13022 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/generic-2.6/files/fs/yaffs2/Makefile')
-rw-r--r--target/linux/generic-2.6/files/fs/yaffs2/Makefile11
1 files changed, 11 insertions, 0 deletions
diff --git a/target/linux/generic-2.6/files/fs/yaffs2/Makefile b/target/linux/generic-2.6/files/fs/yaffs2/Makefile
new file mode 100644
index 0000000000..73f46583f4
--- /dev/null
+++ b/target/linux/generic-2.6/files/fs/yaffs2/Makefile
@@ -0,0 +1,11 @@
+#
+# Makefile for the linux YAFFS filesystem routines.
+#
+
+obj-$(CONFIG_YAFFS_FS) += yaffs.o
+
+yaffs-y := yaffs_ecc.o yaffs_fs.o yaffs_guts.o yaffs_checkptrw.o
+yaffs-y += yaffs_packedtags2.o yaffs_nand.o yaffs_qsort.o
+yaffs-y += yaffs_tagscompat.o yaffs_tagsvalidity.o
+yaffs-y += yaffs_mtdif1.o yaffs_packedtags1.o
+yaffs-y += yaffs_mtdif.o yaffs_mtdif2.o