aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic-2.6/files-2.6.27/fs/yaffs2/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2008-09-29 01:08:17 +0000
committerFelix Fietkau <nbd@openwrt.org>2008-09-29 01:08:17 +0000
commitbc92b67c41bb9eb64dd342735cf04d0ca5098926 (patch)
treefb3cad267265be9ac8eb1532182422f278dc3d0a /target/linux/generic-2.6/files-2.6.27/fs/yaffs2/Makefile
parent9b2097af21c4298fb67622266d5587e4e680fc5c (diff)
downloadupstream-bc92b67c41bb9eb64dd342735cf04d0ca5098926.tar.gz
upstream-bc92b67c41bb9eb64dd342735cf04d0ca5098926.tar.bz2
upstream-bc92b67c41bb9eb64dd342735cf04d0ca5098926.zip
port generic and ixp4xx kernel patches to 2.6.27 (compiles except for iptables, but otherwise completely untested)
SVN-Revision: 12790
Diffstat (limited to 'target/linux/generic-2.6/files-2.6.27/fs/yaffs2/Makefile')
-rw-r--r--target/linux/generic-2.6/files-2.6.27/fs/yaffs2/Makefile11
1 files changed, 11 insertions, 0 deletions
diff --git a/target/linux/generic-2.6/files-2.6.27/fs/yaffs2/Makefile b/target/linux/generic-2.6/files-2.6.27/fs/yaffs2/Makefile
new file mode 100644
index 0000000000..73f46583f4
--- /dev/null
+++ b/target/linux/generic-2.6/files-2.6.27/fs/yaffs2/Makefile
@@ -0,0 +1,11 @@
+#
+# Makefile for the linux YAFFS filesystem routines.
+#
+
+obj-$(CONFIG_YAFFS_FS) += yaffs.o
+
+yaffs-y := yaffs_ecc.o yaffs_fs.o yaffs_guts.o yaffs_checkptrw.o
+yaffs-y += yaffs_packedtags2.o yaffs_nand.o yaffs_qsort.o
+yaffs-y += yaffs_tagscompat.o yaffs_tagsvalidity.o
+yaffs-y += yaffs_mtdif1.o yaffs_packedtags1.o
+yaffs-y += yaffs_mtdif.o yaffs_mtdif2.o