aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic-2.6/files-2.6.23/fs/yaffs2/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2008-10-18 21:43:30 +0000
committerFelix Fietkau <nbd@openwrt.org>2008-10-18 21:43:30 +0000
commit1e570a9288856bcd288a80115f2233c9c785706c (patch)
tree8491af08bde47e22f96c01e6f560206b3fd02a4a /target/linux/generic-2.6/files-2.6.23/fs/yaffs2/Makefile
parent487c622ac0c37f3cd26add56df9081ea7caf3835 (diff)
downloadupstream-1e570a9288856bcd288a80115f2233c9c785706c.tar.gz
upstream-1e570a9288856bcd288a80115f2233c9c785706c.tar.bz2
upstream-1e570a9288856bcd288a80115f2233c9c785706c.zip
change the way ./files* and the generic kernel files are applied. ./files now applies to *ALL* kernel versions, and is copied along with ./files-* - this gets rid of quite a bit of redundancy in the extra kernel drivers.
SVN-Revision: 13010
Diffstat (limited to 'target/linux/generic-2.6/files-2.6.23/fs/yaffs2/Makefile')
-rw-r--r--target/linux/generic-2.6/files-2.6.23/fs/yaffs2/Makefile11
1 files changed, 11 insertions, 0 deletions
diff --git a/target/linux/generic-2.6/files-2.6.23/fs/yaffs2/Makefile b/target/linux/generic-2.6/files-2.6.23/fs/yaffs2/Makefile
new file mode 100644
index 0000000000..73f46583f4
--- /dev/null
+++ b/target/linux/generic-2.6/files-2.6.23/fs/yaffs2/Makefile
@@ -0,0 +1,11 @@
+#
+# Makefile for the linux YAFFS filesystem routines.
+#
+
+obj-$(CONFIG_YAFFS_FS) += yaffs.o
+
+yaffs-y := yaffs_ecc.o yaffs_fs.o yaffs_guts.o yaffs_checkptrw.o
+yaffs-y += yaffs_packedtags2.o yaffs_nand.o yaffs_qsort.o
+yaffs-y += yaffs_tagscompat.o yaffs_tagsvalidity.o
+yaffs-y += yaffs_mtdif1.o yaffs_packedtags1.o
+yaffs-y += yaffs_mtdif.o yaffs_mtdif2.o