aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/gemini
diff options
context:
space:
mode:
authorMathias Kresin <dev@kresin.me>2019-01-16 21:57:53 +0100
committerMathias Kresin <dev@kresin.me>2019-01-26 15:23:36 +0100
commitec0d58ede42e5c8d9829933dd98265e452b7c63d (patch)
treefab885a3bb11d16ff17c969faad8cf4bcad6ca58 /target/linux/gemini
parent650df59e8a541e56b854ca03495c29db2f7cb846 (diff)
downloadupstream-ec0d58ede42e5c8d9829933dd98265e452b7c63d.tar.gz
upstream-ec0d58ede42e5c8d9829933dd98265e452b7c63d.tar.bz2
upstream-ec0d58ede42e5c8d9829933dd98265e452b7c63d.zip
gemini: fix parallel build
Due to the missing PROFILES all images are build, regardless of the selected (or currently processed in case of a multi profile build). Because of the race condition builds with eight parallel jobs fail, which can be seen on the build bots as well. Add the PROFILES variable for now, till the root cause is identified. Signed-off-by: Mathias Kresin <dev@kresin.me>
Diffstat (limited to 'target/linux/gemini')
-rw-r--r--target/linux/gemini/image/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/target/linux/gemini/image/Makefile b/target/linux/gemini/image/Makefile
index 566ac96122..5f987875d3 100644
--- a/target/linux/gemini/image/Makefile
+++ b/target/linux/gemini/image/Makefile
@@ -71,6 +71,7 @@ endef
# All DTB files are prefixed with "gemini-"
define Device/Default
+ PROFILES := Default
DEVICE_DTS := $(patsubst %.dtb,%,$(notdir $(wildcard $(if $(IB),$(KDIR),$(DTS_DIR))/*-$(1).dtb)))
KERNEL_DEPENDS = $$(wildcard $(DTS_DIR)/$$(DEVICE_DTS).dts)
KERNEL_NAME := zImage