aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/gemini/image
diff options
context:
space:
mode:
authorLinus Walleij <linus.walleij@linaro.org>2018-06-13 17:45:04 +0200
committerJohn Crispin <john@phrozen.org>2018-06-18 06:35:09 +0200
commitdc7f540ce180707a8f0bc3a57634964687b48dd3 (patch)
tree326191fb491186f99299ebdede9863bdd29fee17 /target/linux/gemini/image
parent3c8bb92655c68a07abf5358ef23eb98422ed8d6d (diff)
downloadupstream-dc7f540ce180707a8f0bc3a57634964687b48dd3.tar.gz
upstream-dc7f540ce180707a8f0bc3a57634964687b48dd3.tar.bz2
upstream-dc7f540ce180707a8f0bc3a57634964687b48dd3.zip
gemini: Cook a WRGG firmware image
This makes the Gemini build a WRGG-type firmware update image for the DIR-685. This should hopefully install the kernel from the web firmware upgrade API on the product switching it permanently to use OpenWRT. Signed-off-by: Linus Walleij <linus.walleij@linaro.org>
Diffstat (limited to 'target/linux/gemini/image')
-rw-r--r--target/linux/gemini/image/Makefile12
1 files changed, 10 insertions, 2 deletions
diff --git a/target/linux/gemini/image/Makefile b/target/linux/gemini/image/Makefile
index 3e122fc457..b631452a0f 100644
--- a/target/linux/gemini/image/Makefile
+++ b/target/linux/gemini/image/Makefile
@@ -7,9 +7,17 @@
include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/image.mk
-# Just copy the zImage for D-Link DIR-685
+# Cook a "WRGG" image, this board is apparently one in the D-Link
+# WRGG family and uses the exact same firmware format as other
+# D-Link devices.
define Build/dir685-images
- cp $(IMAGE_KERNEL) $(BIN_DIR)/$(IMG_PREFIX)-dir685-zImage
+ mkwrggimg -i $(IMAGE_KERNEL) \
+ -o $(BIN_DIR)/$(IMG_PREFIX)-dir685-fwupdate.bin \
+ -d /dev/mtdblock/1 \
+ -s wrgns01_dlwbr_dir685RBWW \
+ -v 'N/A' \
+ -m dir685 \
+ -B 96bb
endef
# Build D-Link DNS-313 images using the special header tool.