aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/gemini/image
diff options
context:
space:
mode:
authorRoman Yeryomin <roman@advem.lv>2018-05-04 18:18:51 +0300
committerJohn Crispin <john@phrozen.org>2018-05-05 06:57:00 +0200
commitce93b05bf1465b240366000f833e413c0b916125 (patch)
treedc739624fdf38918ab6ddde9f9bd66205fc20ceb /target/linux/gemini/image
parent2c35bcffd080abaf1262d0afd905b04ea8696829 (diff)
downloadupstream-ce93b05bf1465b240366000f833e413c0b916125.tar.gz
upstream-ce93b05bf1465b240366000f833e413c0b916125.tar.bz2
upstream-ce93b05bf1465b240366000f833e413c0b916125.zip
gemini: fix hard disk boot on D-Link devices
Since the D-Link devices boot from hard disk we need to add the following changes to Gemini: - Supply a bootarg in the device tree so we can boot from the right partition (/dev/sda4 on DNS-313) - Disable forced command line in config so the kernel picks up the right bootargs from the device tree - Enable EXT4 in the config as this is used for rootfs else we get nowhere, we cannot load this as a module because, well, it is supposed to be loaded from the root partition (chicken and egg problem). - Enable jbd2 and mbcache (needed by ext4) Also clean out the premature attempts to dynamically modify the command line in the Image makefile: we should pass this with the device tree bootargs instead, it works much better. Signed-off-by: Linus Walleij <linus.walleij@linaro.org> Signed-off-by: Roman Yeryomin <roman@advem.lv>
Diffstat (limited to 'target/linux/gemini/image')
-rw-r--r--target/linux/gemini/image/Makefile8
1 files changed, 1 insertions, 7 deletions
diff --git a/target/linux/gemini/image/Makefile b/target/linux/gemini/image/Makefile
index dca3b63b19..25371f6f13 100644
--- a/target/linux/gemini/image/Makefile
+++ b/target/linux/gemini/image/Makefile
@@ -70,24 +70,20 @@ endef
# of devices out of the box (former NAS42x0 IcyBox defaults)
GEMINI_NAS_PACKAGES:=kmod-md-mod kmod-md-linear kmod-md-multipath \
kmod-md-raid0 kmod-md-raid1 kmod-md-raid10 kmod-md-raid456 \
- kmod-fs-btrfs kmod-fs-cifs kmod-fs-ext4 kmod-fs-nfs \
+ kmod-fs-btrfs kmod-fs-cifs kmod-fs-nfs \
kmod-fs-nfsd kmod-fs-ntfs kmod-fs-reiserfs kmod-fs-vfat \
kmod-nls-utf8 kmod-usb-storage-extras \
samba36-server mdadm cfdisk fdisk e2fsprogs badblocks
-DIR685_CMDLINE:=-console=ttyS0,19200n8 root=/dev/sda1 rw rootwait
define Device/dlink-dir-685
DEVICE_TITLE := D-Link DIR-685 Xtreme N Storage Router
- CMDLINE := $(DIR685_CMDLINE)
DEVICE_PACKAGES := $(GEMINI_NAS_PACKAGES) \
kmod-switch-rtl8366rb swconfig
endef
TARGET_DEVICES += dlink-dir-685
-DNS313_CMDLINE:=-console=ttyS0,19200n8 root=/dev/sda4 rw rootwait
define Device/dlink-dns-313
DEVICE_TITLE := D-Link DNS-313 1-Bay Network Storage Enclosure
- CMDLINE := $(DNS313_CMDLINE)
DEVICE_PACKAGES := $(GEMINI_NAS_PACKAGES)
IMAGES += dns313-image
IMAGE/dns313-image := dns313-images
@@ -108,10 +104,8 @@ define Device/rut1xx
endef
TARGET_DEVICES += rut1xx
-SQ201_CMDLINE:=-console=ttyS0,115200n8
define Device/sq201
DEVICE_TITLE := ITian Square One SQ201
- CMDLINE := $(SQ201_CMDLINE)
DEVICE_PACKAGES := $(GEMINI_NAS_PACKAGES) rt61-pci-firmware
endef
TARGET_DEVICES += sq201