aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/gemini/Makefile
diff options
context:
space:
mode:
authorRoman Yeryomin <roman@advem.lv>2018-04-29 19:07:05 +0300
committerJohn Crispin <john@phrozen.org>2018-05-05 06:57:00 +0200
commit6409b159e8b84e172da7755088d587ccd99103ab (patch)
treeb63ecbe74f57c42d40c852d3772c965bd465da6e /target/linux/gemini/Makefile
parent20d0dace40b74b098309cefb29a1ce5d57988e7e (diff)
downloadupstream-6409b159e8b84e172da7755088d587ccd99103ab.tar.gz
upstream-6409b159e8b84e172da7755088d587ccd99103ab.tar.bz2
upstream-6409b159e8b84e172da7755088d587ccd99103ab.zip
gemini: switch to 4.14
This introduces Device/ infrastructure and images for all boards available upstream. Changes from Linus submitted version: - fix Raidsonic image generation - remove redundant (old) image generation - remove redundant header tool for dns313 board Signed-off-by: Linus Walleij <linus.walleij@linaro.org> Signed-off-by: Roman Yeryomin <roman@advem.lv>
Diffstat (limited to 'target/linux/gemini/Makefile')
-rw-r--r--target/linux/gemini/Makefile13
1 files changed, 8 insertions, 5 deletions
diff --git a/target/linux/gemini/Makefile b/target/linux/gemini/Makefile
index f02e4b179f..a9414a2606 100644
--- a/target/linux/gemini/Makefile
+++ b/target/linux/gemini/Makefile
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2009-2013 OpenWrt.org
+# Copyright (C) 2009-2018 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -9,14 +9,17 @@ include $(TOPDIR)/rules.mk
ARCH:=arm
BOARD:=gemini
BOARDNAME:=Cortina Systems CS351x
-SUBTARGETS:=raidsonic wiligear
-FEATURES:=squashfs pci rtc
+FEATURES:=squashfs pci rtc usb dt gpio
CPU_TYPE:=fa526
MAINTAINER:=Roman Yeryomin <roman@advem.lv>
-KERNEL_PATCHVER:=4.4
+KERNEL_PATCHVER:=4.14
-KERNELNAME:=zImage
+define Target/Description
+ Build firmware images for the StorLink/Cortina Gemini CS351x ARM FA526 CPU
+endef
+
+KERNELNAME:=zImage dtbs
include $(INCLUDE_DIR)/target.mk